Общие сведения

Система КОМПАС-3D Viewer предназначена для просмотра и печати документов и шаблонов документов, разработанных в системе КОМПАС-3D, а также документов, разработанных в системе КОМПАС-3D LT.

Возможны также просмотр и печать документов форматов DXF и DWG.

Если на компьютере установлена система КОМПАС-3D, то просматриваемый документ можно открыть для редактирования в этой системе.

Редактирование и сохранение документов непосредственно в системе КОМПАС-3D Viewer невозможно.


Интерфейс программы

КОМПАС-3D Viewer — многооконная и многодокументная система. В ней могут быть одновременно открыты окна нескольких документов различных типов. Любой графический документ или документ-модель может отображаться в нескольких окнах.

Команды вызываются из страниц Главного меню или при помощи кнопок на инструментальных панелях Стандартная, Вид, Текущее состояние.

Состав меню и панелей зависит от типа активного документа. Команды, управляющие отображением инструментальных панелей, находятся в меню Вид — Панели инструментов.

Пользователь может изменять состав Главного меню и системных инструментальных панелей, а также создавать собственные панели. Для вызова диалога, позволяющего произвести эту настройку, служит команда Сервис — Настройка интерфейса....

В Строке сообщений отображаются подсказки по текущему действию или описание выбранной команды. Включение и отключение показа Строки сообщений производится командой Вид — Строка сообщений.

Смотрите также


Открытие и закрытие документов

Чтобы открыть документ для просмотра, выполните следующие действия.

1. Вызовите команду Открыть.

2. В появившемся диалоге выберите тип файлов из одноименного списка.

3. Укажите каталог и имя файла.

4. Нажмите кнопку Открыть.

Выбранный документ будет открыт в отдельном окне.

В том случае, если вы недавно просматривали документ, а затем закрыли его, повторное открытие можно выполнить более быстрым способом. В нижней части меню Файл отображается список последних девяти документов, с которыми велась работа. Фактически это перечень документов в той последовательности, в которой они закрывались. Чтобы открыть нужный документ, просто выберите его имя в меню.

Если вы попытаетесь открыть уже загруженный для просмотра документ, КОМПАС-3D Viewer не выполнит повторное открытие, а просто активизирует окно этого документа.

В случае, если просматриваемый документ редактируется в КОМПАС-3D, внесенные изменения (при условии, что они сохранены) можно отразить в окне КОМПАС-3D Viewer.

Для этого вызовите команду Перечитать файл. Текущий документ будет открыт заново в этом же окне.

Команда Перечитать файл недоступна для документов-моделей.

Чтобы закрыть текущий документ, вызовите команду Файл — Закрыть.

Чтобы закрыть все открытые документы, вызовите команду Окно — Закрыть все.

Смотрите также


Работа с окнами документов

КОМПАС-3D Viewer позволяет работать одновременно с несколькими различными документами.

Каждый документ, который открывается для просмотра, отображается в отдельном окне.

Если КОМПАС-чертеж расположен на нескольких листах, то в одном окне будут показаны все листы. При этом оформления и форматы отдельных листов могут быть различными.

При необходимости с одним и тем же графическим документом и документом-моделью можно работать в нескольких окнах. Чтобы открыть дополнительное окно документа, вызовите команду Окно — Новое окно документа. В разных окнах могут отображаться разные части документа в разных масштабах.

Каждое окно имеет заголовок, который содержит название отображающегося в нем документа, кнопку системного меню и кнопки управления окном.

Приемы работы с окнами стандартны (перетаскивание окна за его заголовок мышью, изменение границ окна и т.д.) и ничем не отличаются от принятых в других Windows-приложениях. Чтобы разместить на экране окна документов удобным образом, используйте команды Каскад и Мозаика... из меню Окно.

Любое окно документа можно минимизировать до условного значка — пиктограммы. Это может быть удобным в случае, когда документ не нужен только на какое-то время, и желательно не закрывать его совсем. Для рационального размещения пиктограмм документов (они обычно отображаются в нижней части главного окна КОМПАС-3D Viewer) используйте команду Окно — Упорядочить значки.

Для последовательного переключения между окнами документов можно использовать комбинацию клавиш <Ctrl>+<F6>, а для произвольного — команды меню Окно. Кроме того, для выбора текущего документа можно пользоваться закладками документов.

Управление документами и окнами возможно также в диалоге, вызываемом командой Окно — Все окна.

Смотрите также


Переход к последующему/предыдущему документу

При просмотре КОМПАС-документов с помощью КОМПАС-3D Viewer вы можете открывать документы друг за другом без обращения к команде Файл — Открыть или Проводнику Windows.

Для перехода от одного документа к другому служат команды Предыдущий документ и Следующий документ на панели Вид. Кроме того, для перехода между документами можно пользоваться комбинациями клавиш: <Alt>+<Page up> и <Alt>+<Page down>.

Предыдущим (последующим) документом по отношению к данному считается документ, находящийся в той же папке, что и данный, и предшествующий ему (следующий за ним) при упорядочении файлов по типу.

При вызове команды Предыдущий документ в активном окне открывается предыдущий документ по отношению к активному, а при вызове команды Последующий документ — последующий.

Таким образом, если активный документ был открыт в одном окне, то при вызове команды Предыдущий документ или Следующий документ этот документ закрывается.

Если документ, открытый в активном окне, последний в отсортированном по типу списке файлов, то недоступна команда Следующий документ, а если первый — то команда Предыдущий документ.


Масштаб отображения в окне

КОМПАС-3D Viewer предоставляет пользователю широкий выбор средств для изменения масштаба отоборажения документа в окне.

Набор команд для изменения масштаба изображения зависит от типа текущего документа. Кнопки для вызова команд изменения масштаба расположены на панели Вид.

Чтобы увеличить или уменьшить масштаб отображения документа, вызовите команду Увеличить масштаб или Уменьшить масштаб.

Текущий масштаб отображения документа показан в одноименном поле со списком на панели Вид. Чтобы изменить масштаб, разверните список и выберите нужное значение. Можно также ввести значение с клавиатуры.

Если панель Вид расположена вертикально, для вызова этого поля нажмите кнопку Текущий масштаб.

Увеличение и уменьшение масштаба, а также явное его задание доступны при просмотре документов всех типов.

При работе с графическими документами и документами-моделями доступны следующие варианты задания масштаба отображения:

Увеличение масштаба произвольного участка

Плавное изменение масштаба

Отображение документа целиком

При работе с текстовыми документами и спецификациями возможен автоматический подбор масштаба.

При работе с графическими документами возможен переход к предыдущему или последующему масштабу отображения.

Смотрите также


Сдвиг изображения в окне

Сдвиг (прокрутка) изображения — перемещение изображения документа в окне без изменения масштаба отображения.

Чтобы переместить изображение в графическом документе или документе-модели, вызовите команду Сдвинуть.

Курсор изменит свою форму.

Для обращения к команде сдвига изображения можно также нажать комбинацию клавиш <Shift>+<Ctrl>, а затем левую кнопку мыши.

Перемещайте курсор, удерживая кнопку мыши нажатой (если вы вызывали команду с помощью комбинации клавиш <Shift>+<Ctrl>, то эти клавиши также нужно удерживать нажатыми). Достигнув края экрана, отпустите кнопку мыши, переместите курсор в середину экрана, а затем вновь нажмите левую кнопку и перемещайте мышь.

После того, как рабочее поле сдвинуто в нужное положение, отпустите кнопку мыши и клавиши.

Если вы пользуетесь трехкнопочной мышью или мышью с колесом, то для сдвига изображения в графическом, текстовом документе и документе-спецификации можно перемещать мышь с нажатой средней кнопкой (колесом).

При работе с текстовыми документами и спецификациями документ можно листать — прокручивать постранично.

Чтобы последовательно переходить от одной страницы к другой, нажимайте клавиши <Page Up> и <Page Down>. Для произвольного перехода к нужной странице введите ее номер в поле Текущая страница на панели Текущее состояние и нажмите клавишу <Enter>.

Если панель Текущее состояние расположена вертикально, то для доступа к полю Текущая страница нажмите соответствующую кнопку.

Смотрите также


Вращение модели

При просмотре деталей и сборок вы можете запустить непрерывное вращение модели в заданном направлении с заданной скоростью.

Чтобы запустить вращение, выполните следующие действия.

1. Вызовите команду Вращать модель.

Курсор примет вид двух дугообразных стрелок.

2. Нажмите левую кнопку мыши в окне просмотра, переместите курсор в требуемом направлении вращения и отпустите кнопку мыши. Модель начнет вращаться в заданном направлении вокруг центра габаритного параллелограмма.

2.1. Чтобы модель вращалась вокруг определенной точки (вершины детали, центра сферы), подведите курсор к нужному элементу в окне модели и щелкните мышью.

Курсор примет вид «звездочки» с двумя дугообразными стрелками.

Затем нажмите левую кнопку мыши, переместите курсор в требуемом направлении и отпустите кнопку.

2.1. Чтобы модель вращалась вокруг оси (прямолинейного ребра, оси конической или цилиндрической грани), подведите курсор к нужному элементу в окне модели и щелкните мышью.

Курсор примет вид «оси» с двумя дугообразными стрелками.

Затем нажмите левую кнопку мыши, переместите курсор в требуемом направлении и отпустите кнопку.

2.1. Чтобы модель вращалась вокруг оси, проходящей через указанную точку плоской грани перпендикулярно этой грани, подведите курсор к нужной точке плоскости в окне модели и щелкните мышью.

Курсор примет вид «плоскости» с двумя дугообразными стрелками.

Затем нажмите левую кнопку мыши, переместите курсор в требуемом направлении и отпустите кнопку.

Чем быстрее перемещался курсор при задании направления вращения, тем выше будет скорость вращения.

Чтобы прервать вращение, щелкните мышью в любом месте окна. Модель остановится. При этом команда Вращать модель не прерывается, и вы можете задать другие направление и скорость вращения.


Поворот модели

Чтобы просмотреть модель с различных сторон, вы можете поворачивать ее в произвольных направлениях. Для этого выполните следующие действия.

1. Вызовите команду Повернуть.

Курсор примет вид двух дугообразных стрелок.

2. Нажмите левую кнопку мыши в окне модели и, не отпуская ее, перемещайте курсор. Модель будет поворачиваться вокруг центральной точки габаритного параллелограмма.

2.1. Чтобы вращать модель вокруг определенной точки (вершины детали, центра сферы), подведите курсор к нужному элементу в окне модели и щелкните мышью.

Курсор примет вид «звездочки» с двумя дугообразными стрелками.

Затем нажмите левую кнопку мыши и, не отпуская ее, перемещайте курсор.

2.1. Чтобы вращать модель вокруг оси (прямолинейного ребра оси конической или цилиндрической грани), подведите курсор к нужному элементу в окне модели и щелкните мышью.

Курсор примет вид «оси» с двумя дугообразными стрелками.

Затем нажмите левую кнопку мыши и, не отпуская ее, перемещайте курсор.

2.1. Чтобы вращать модель вокруг оси, проходящей через указанную точку плоской грани перпендикулярно этой грани, подведите курсор к нужной точке плоскости в окне модели и щелкните мышью.

Курсор примет вид «плоскости» с двумя дугообразными стрелками.

Затем нажмите левую кнопку мыши и, не отпуская ее, перемещайте курсор.

Если вы пользуетесь мышью с колесом или трехкнопочной мышью, то перейти к вращению модели вокруг центра габаритного параллелепипеда можно и без вызова команды поворота. Для этого просто перемещайте мышь с нажатой средней кнопкой или колесом. Если при этом удерживать нажатой клавишу <Alt>, то модель будет вращаться в плоскости экрана.

Кроме того, вы можете повернуть модель на 90 градусов по часовой стрелке или против часовой стрелки в плоскости экрана. Для этого служат команды Вид — Поворот — Повернуть против часовой стрелки и Вид — Поворот — Повернуть по часовой стрелке.

Смотрите также


Выбор ориентации модели

Ориентация модели — положение модели относительно наблюдателя.

Для изменения ориентации просматриваемой модели можно воспользоваться командой поворота.

Часто требуется такая ориентация, при которой одна из плоскостей проекций параллельна плоскости экрана (в этом случае изображение модели соответствует ее изображению на чертеже в стандартной проекции, например, на виде сверху или слева). Такую ориентацию трудно получить, поворачивая модель мышью. В этом случае для изменения ориентации можно пользоваться предусмотренным системой списком названий ориентаций.

На панели Вид расположена кнопка Ориентация. Нажатие на стрелку рядом с этой кнопкой вызывает меню с перечнем стандартных названий ориентаций: Сверху, Снизу, Слева, Справа, Спереди, Сзади, Изометрия XYZ, Изометрия YZX, Изометрия ZXY, Диметрия (каждое из них соответствует направлению взгляда наблюдателя на модель). Выберите из этого меню команду, соответствующую нужной ориентации. Изображение будет перестроено в соответствии с указанным направлением взгляда.

В окне модели находится специальный символ системы координат, несвязанный с началом координат модели. Он расположен в левом нижнем углу окна и состоит из трех объемных стрелок красного, зеленого и синего цветов, показывающих положительные направления осей X, Y, Z соответственно. При повороте модели этот символ системы координат поворачивается — так же, как и символ, расположенный в начале координат, но, в отличие от последнего, не сдвигается при перемещении модели и не может быть отключен.

Вы можете не только использовать существующие названия ориентаций, но и сохранять текущую ориентацию под каким-либо именем, а затем возвращаться к ней в любой момент, выбрав это имя из списка. Для этого выполните следующие действия.

1. Нажмите кнопку Ориентация. На экране появится диалог со списком существующих в модели названий ориентаций.

2. Нажмите в нем кнопку Добавить и введите название новой ориентации.

3. Выйдите из диалога. Новое название появится в меню кнопки Ориентация.

Впоследствии, когда ориентация модели изменится, Вы можете выбрать созданную вами ориентацию из меню кнопки Ориентация, и модель повернется так, чтобы ее ориентация соответствовала указанному названию.

В диалоге выбора ориентации можно не только создать новую ориентацию, но и выбрать существующую, а также удалить из списка созданное пользователем название ориентации.

Чтобы выбрать существующую ориентацию, установите выделение на ее названии в списке и нажмите кнопку Установить диалога. Изображение будет перестроено в соответствии с указанным направлением взгляда.

Так как запись документов в КОМПАС-3D Viewer невозможна, сформированный пользователем список ориентаций сохраняется только до закрытия просматриваемой модели. При повторном ее открытии восстанавливается прежний перечень ориентаций.

Если модель открыта для просмотра в нескольких окнах, в каждом из них может быть своя ориентация модели и масштаб изображения.


Выбор способа отображения

При просмотре моделей в КОМПАС-3D Viewer доступны несколько типов отображения модели. Чтобы установить тип отображения, выберите его название в меню Вид — Отображение или нажмите соответствующую кнопку на панели Вид.

Типы отображения моделей
Тип | Описание | Как выглядит
Каркас | Совокупность всех ребер и линии очерка модели. |
Без невидимых линий | Совокупность видимых при текущей ориентации модели ребер, видимых частей ребер и линии очерка модели. |
Невидимые линии тонкие | Невидимые ребра и части ребер отображаются отличающимся от видимых линий (более светлым) цветом. |
Полутоновое отображение | Отображается поверхность модели. Учитываются оптические свойства ее поверхности (цвет, блеск, диффузия и т.д.). |
Полутоновое отображение с каркасом | Добавляет к полутоновому отображению каркас без невидимых линий. Цвет линий каркаса — черный. |

Если модель открыта для просмотра в нескольких окнах, в каждом из них может быть установлен свой способ отображения.


Разнесение компонентов сборки

Иногда сборку требуется отобразить в «разобранном» виде (так, чтобы были видны все ее компоненты).

Параметры разнесения (перечень компонентов, перемещаемых при разнесении, направления и величины их перемещения) задаются при редактировании сборки в КОМПАС-3D.

Есл и в просматриваемом документе-сборке установлены параметры разнесения, то становится доступной команда Разнести компоненты.

Эта команда позволяет включать и выключать отображение сборки в разнесенном виде.

Разнесение компонентов сборки


Упрощенное отображение моделей

При работе с деталями и сборками можно включить режим упрощенного отображения модели, позволяющий ускорить формирование изображения модели на экране.

Если режим упрощенного отображения включен, то во время изменения изображения и при установке мелкого масштаба отображения относительно небольшие компоненты сборки и тела детали заменяются параллелепипедами соответствующих габаритов и цветов. В случае изменения изображения возможно дополнительное упрощение, например, временное отключение отрисовки вспомогательных объектов.

После завершения изменения изображения, а также после увеличения масштаба отображение модели восстанавливается. Режим упрощения действует при всех типах отображения модели.

Настройка работы режима упрощенного отображения производится на вкладке Система настроечного диалога, в разделе Редактор моделей — Упрощения. Этот раздел содержит два пункта: Модель и Прочие.

Пункт Модель позволяет установить уровень детализации модели. Чем уровень детализации меньше, тем более крупные компоненты или тела превращаются в параллелепипеды и тем быстрее происходит изменение изображения модели. В этом же пункте можно указать, требуется ли скрывать или упрощать стандартные компоненты сборки.

Пункт Прочие позволяет включить использование во время работы режима упрощенного отображения дополнительные средства упрощения. Кроме того, в этом пункте можно включить отображение точек на месте компонентов или тел, ставших невидимыми из-за мелкого масштаба отображения.

Особенности упрощения подсборок

По умолчанию режим упрощенного отображения в деталях и сборках включен.

Чтобы отключить в модели режим упрощенного отображения, вызовите команду Вид — Упрощения — Упрощенное отображение или отожмите кнопку Упрощенное отображение на панели Вид.


Переключение между листами многолистового чертежа

Все листы многолистового чертежа отображаются на экране одновременно. Однако может быть выбран такой масштаб отображения, что часть листов окажется за пределами экрана. Чтобы выбрать лист чертежа для показа на экране, используйте элементы управления, расположенные на панели Текущее состояние.

Кнопки Перейти к предыдущему листу и Перейти к последующему листу позволяют показать на экране предыдущий и последующий листы относительно текущего.

Кнопки Перейти к первому листу и Перейти к последнему листу позволяют показать первый или последний листы документа.

Чтобы показать лист документа с конкретным номером, следует выбрать этот номер из раскрывающегося списка Показать лист.


Показ погашенных видов и слоев

Виды и слои в графических документах КОМПАС-3D могут находиться в одном из следующих состояний:

– активный — в него записываются вновь создаваемые объекты,

– текущий — его объекты доступны для редактирования,

– фоновый — его объекты видны на экране, но недоступны для редактирования,

– погашенный — его объекты не видны на экране.

Если графический документ, открытый для просмотра в КОМПАС-3D Viewer, содержит погашенные виды или слои, становятся доступными команды управления отображением этих видов и слоев.

Чтобы включить показ объектов, расположенных в погашенных видах, нажмите кнопку Показать погашенные виды.

Чтобы включить показ объектов, расположенных на погашенных слоях, нажмите кнопку Показать погашенные слои.

По умолчанию названные кнопки не отображаются на экране. Чтобы команды были доступны, необходимо настроить панель Текущее состояние для работы с графическими документами, добавив на нее кнопки Показать погашенные виды и Показаать погашенные слои.

Управление печатью погашенных видов и слоев производится отдельно, при настройке фильтров вывода на печать.


Просмотр файлов форматов DXF и DWG

Для открытия файла формата DXF или DWG вызовите команду Файл — Открыть. В списке Тип файла появившегося диалога выберите нужный формат и укажите имя файла. Затем нажмите кнопку Открыть диалога.

Поскольку КОМПАС-3D Viewer работает только с КОМПАС-документами, при открытии файла формата DXF или DWG он автоматически импортируется в формат КОМПАС.

По умолчанию импорт производится без выдачи диалога настройки импорта. После нажатия кнопки Открыть выбранный файл *.dxf или *.dwg импортируется с параметрами, которые были заданы во время последней настройки импорта (или с умолчательными параметрами, если настройка не производилась). Чтобы вызвать диалог настройки параметров импорта, необходимо, указав нужный файл, раскрыть меню кнопки Открыть и выбрать из него команду Открыть с параметрами....

Если изображение в импортированном файле не соответствует ожидаемому, закройте его и импортируйте снова, изменив настройки импорта.

Открытые в КОМПАС-3D Viewer файлы формата DXF или DWG можно просматривать и печатать так же, как графические документы КОМПАС.


Общие сведения о режиме предварительного просмотра

Общие сведения
о режиме предварительного просмотра

Режим предварительного просмотра для печати — специальный режим работы КОМПАС-3D Viewer.

Для перехода в этот режим из режима просмотра вызовите команду Предварительный просмотр.

Режим предварительного просмотра имеет собственное Главное меню, Панель управления и Панель свойств.

В режиме предварительного просмотра на экране показывается условное поле вывода (один или несколько листов бумаги). На нем реалистично отображается выбранный документ (или несколько выбранных документов).

Если формат листа бумаги, установленный в настройках текущего принтера, меньше, чем изображение документа (или документов), система автоматически рассчитывает необходимое для вывода количество листов. При этом поле вывода в режиме просмотра разделяется пунктирными линиями на части, соответствующие установленному в данный момент формату бумаги и ее ориентации.

Размер листов бумаги с учетом «мертвых зон» (областей у края листа, которые принтер не может запечатать в силу своих конструктивных особенностей) и необходимое количество листов отображается в нижней части экрана — Строке состояния.

При размещении документа на поле вывода можно использовать следующие приемы.

Перемещение документа

Поворот документа

Масштабирование документа

Документ (документы), размещение которого на поле вывода производится в данный момент, считается текущим. Он отображается заключенным в габаритную рамку зеленого цвета. Чтобы сделать документ текущим, следует щелкнуть по его изображению мышью или выбрать его имя из списка Документ на Панели свойств. Чтобы сделать текущими несколько документов, следует указывать их, удерживая нажатой клавишу <Ctrl>.

После того, как документ размещен наилучшим образом, вызовите команду Файл — Печать для начала вывода документа на бумагу.

Можно также нажать кнопку Печать на Панели управления.

Смотрите также


Выбор нужного принтера (плоттера) и его настройка

Выбор нужного принтера (плоттера)
и его настройка

КОМПАС-3D Viewer позволяет выводить документы на любое внешнее устройство, для которого имеется драйвер поддержки Windows. Такие драйверы входят в комплект поставки всех современных периферийных устройств.

Подключенным, или доступным, будем называть плоттер или принтер, название которого отображается в списке доступных устройств. Выполнить подключение драйвера устройства к Windows можно через Панель Управления (Control Panel).

Для получения информации о том, как подключить принтер или плоттер, обратитесь к документации по Windows и имеющемуся у вас устройству вывода.

Чтобы выбрать нужный плоттер (принтер) и настроить его параметры, выполните следующие действия.

1. Нажмите кнопку Параметры плоттера/принтера на Панели управления или вызовите соответствующую команду из меню Файл.

2. В появившемся на экране диалоге Настройка печати выберите нужное имя устройства из списка доступных устройств.

3. Назначьте нужные размер и ориентацию листов бумаги. Размер бумаги выбирается из списка форматов, поддерживаемых принтером или плоттером.

4. Выберите нужный способ подачи бумаги при печати.

5. Если необходимо выполнить настройку различных параметров печати (градации оттенков, интенсивность и т.д., конкретный набор зависит от типа устройства), нажмите кнопку Свойства для вызова системного диалога драйвера устройства.

6. Закройте диалог, нажав кнопку ОК. Теперь вывод на печать будет выполняться в соответствии с теми параметрами, которые были установлены в диалоге.


Масштаб отображения поля вывода

По умолчанию поле вывода отображается на экране в таком масштабе, чтобы оно было видно полностью.

Текущий масштаб отображения поля вывода показывается в одноименном поле на Панели управления.

Если документов много (или выбранный документ содержит несколько страниц), то масштаб отображения поля вывода оказывается слишком мелким. Это создает неудобства при размещении документов.

Вы можете увеличить масштаб отображения поля вывода так, чтобы границы страниц и печатаемое изображение были хорошо видны на экране.

Для этого вызовите команду Увеличить масштаб или нажмите кнопку <+> на дополнительной (цифровой) клавиатуре. Текущий масштаб будет увеличен в 1,2 раза.

Вы можете также увеличить масштаб произвольного участка поля вывода. Для этого вызовите команду Увеличить масштаб рамкой. После этого щелкните мышью в точке первого угла рамки, которая должна охватить увеличиваемую область. Затем перемещайте курсор для достижения нужного размера рамки. При этом на экране будет отображаться фантом рамки.

После фиксации второго угла рамки изображение будет увеличено таким образом, чтобы область поля вывода, ограниченная рамкой, занимала всю площадь окна.

Кроме того, возможно задание произвольного масштаба отображения. Для этого введите нужное значение в поле Текущий масштаб на Панели управления и нажмите клавишу <Enter>.

Уменьшение масштаба производится командой Уменьшить масштаб или нажатием клавиши <-> на дополнительной клавиатуре.

Вы можете также вернуться к одному из предыдущих масштабов отображения поля вывода. Для этого вызовите команду Предыдущий из меню Вид — Масштаб. Чтобы вновь перейти к следующему масштабу отображения, вызовите из этого же меню команду Последующий масштаб.

Чтобы вернуться к масштабу, при котором на экране видно все поле вывода целиком, нажмите кнопку Показать все на Панели управления.

Когда масштаб отображения поля вывода увеличен, на экране отображается ограниченная область этого поля. Чтобы, не изменяя масштаб, увидеть другие области поля вывода, воспользуйтесь командой сдвига изображения.

Для вызова команды нажмите кнопку Сдвинуть на Панели управления или выберите ее название из меню Вид.

После этого форма курсора изменится: он превратится в четырехстороннюю стрелку.

Удерживая кнопку мыши нажатой, перемещайте курсор. Вслед за движением курсора будет прокручиваться поле вывода с размещенными на нем документами. Если достигнут край экрана и необходимо продвинуть поле вывода еще дальше, отпустите кнопку мыши, переместите курсор в нужное положение, а затем вновь нажмите левую кнопку мыши и продолжайте прокрутку рабочего поля.

Если вы пользуетесь трехкнопочной мышью или мышью с колесом, то для сдвига изображения можно перемещать мышь с нажатой средней кнопкой (колесом).


Выбор части изображения для печати

Вы можете напечатать не весь текущий документ целиком, а только его часть — область, ограниченную прямоугольником произвольных размеров.

Для этого активизируйте переключатель Указать часть на Панели свойств.

На экране появится диалог, в котором показан текущий документ и рамка, ограничивающая печатаемую часть. По умолчанию размеры рамки соответствуют габаритам изображения.

Чтобы изменить размеры рамки, введите нужные значения в поля группы Отступ в левой части диалога. Можно также переместить стороны или углы рамки мышью. Завершив настройку, закройте диалог.

После этого на поле вывода будет отображаться не весь документ, а только указанная часть.

Вы можете управлять способом печати текущего документа с помощью переключателей группы Способ вывода на Панели свойств. Активизация переключателя Вывести часть текущего документа отображает на поле вывода область документа, ограниченную рамкой, активизация переключателя Вывести текущий документ полностью — весь документ целиком.

Часть документа можно переместить, повернуть на поле вывода или промасштабировать так же, как и целый документ.


Отмена печати указанных страниц

Если документ (или несколько документов) не умещаются на том формате, который может вывести подключенный принтер или плоттер, КОМПАС-3D Viewer автоматически размещает изображение на дополнительных форматах (страницах).

Вы можете указать, какие страницы должны выводиться на печать, а какие — нет. Для отмены печати каких-либо страниц выполните следующие действия.

1. Нажмите кнопку Включить/Выключить листы на Панели управления или вызовите соответствующую команду из меню Сервис.

При этом система переходит в режим указания страниц на поле печати (признаком режима является отображение кнопки Включить/Выключить листы как нажатой). В этом режиме не выполняются никакие действия по компоновке документов.

2. Щелкните мышью на странице, печать которой требуется запретить. При этом изменится цвет, которым указанная страница изображена на экране.

Повторная фиксация курсора внутри отмеченной ранее страницы отменяет запрещение на ее печать.

3. Для выхода из режима указания страниц отожмите кнопку Включить/Выключить листы.


Печать нескольких документов одновременно

КОМПАС-3D Viewer позволяет вывести на печать не только один активный документ, но и сразу несколько различных документов. Средства одновременной компоновки и вывода позволяют сократить общее время, затрачиваемое на печать документов, а также более рационально расходовать бумагу.

Чтобы напечатать несколько документов, выполните следующие действия.

1. Загрузите КОМПАС-3D Viewer и откройте все документы, которые требуется напечатать.

2. Вызовите команду Файл — Предварительный просмотр или нажмите соответствующую кнопку на панели Стандартная.

На экране появится диалог выбора документов для печати. Активный документ выделен в списке.

3. Включите опцию Выделить все документы и нажмите кнопку ОК для входа в режим предварительного просмотра.

4. Выполните компоновку документов на поле вывода и установите нужное количество копий.

5. Чтобы добавить документы в набор для печати, нажмите кнопку Добавить документ... на Панели управления.

В появившемся диалоге выберите нужное имя файла (или несколько имен файлов).

Чтобы отказаться от печати каких-либо документов или каких-либо страниц многостраничного документа, выделите их и нажмите кнопку Удалить документ из просмотра.

6. Нажмите кнопку Печать на Панели управления для начала вывода документов на бумагу.


Установка фильтров вывода

Иногда требуется вывести документ таким образом, чтобы некоторые объекты оформления или некоторые графические объекты не были напечатаны.

Управление выводом объектов документа производится в диалоге, вызываемом командой Сервис — Фильтры вывода на печать. В этом диалоге вы можете включить или отменить печать различных объектов.


Особенности вывода документов на векторные устройства

Особенности вывода документов
на векторные устройства

Печать документов на векторных устройствах (например, плоттерах) имеет некоторые особенности.

Документы, которые будут напечатаны на векторном устройстве, должны иметь специальные оформления, в которых используются векторные шрифты. Эти оформления хранятся в системной библиотеке Vector.lyt. Присвоение оформлений документам производится при редактировании документа в системе КОМПАС-3D.

Такие графические объекты, как шрифты True Type, сплошные заливки цветом и растровые изображения, не могут быть корректно выведены на векторное устройство. Поэтому при попытке напечатать документ, содержащий перечисленные объекты, на экране появляется предупреждение.

В нем перечислены документы, в которых обнаружены шрифты True Type, растровые изображения и заливки, а также типы объектов (например, размеры, макроэлементы и т.д.), содержащих шрифты True Type, растры и заливки.

Вы можете отказаться от вывода растровых изображений и заливок, либо указать, выводить или не выводить эти документы, нажав соответствующую кнопку диалога.

При подтверждении вывода перечисленных в диалоге документов следует иметь в виду, что гарантии корректной печати указанных объектов отсутствуют.


Завершение предварительного просмотра для печати

Чтобы закончить работу в режиме предварительного просмотра, нажмите кнопку Закрыть просмотр на Панели управления или вызовите соответствующую команду из меню Файл.

Система вернется в обычный режим редактирования документов.


Общие сведения о заданиях на печать

Если вам приходится распечатывать одни и те же документы с одними и теми же настройками, удобно использовать задания на печать.

Задание на печать представляет собой файл, в который записываются номера листов и имена файлов документов, выбранных для печати, настройки их размещения на поле вывода, настройки параметров вывода и данные об устройстве вывода.

Файл задания на печать имеет расширение pjd.

Файл задания записывается в текстовом формате, поэтому при необходимости он может быть открыт и отредактирован любым текстовым редактором, например, Блокнотом, входящим в состав стандартных программ Windows.

При загрузке файла задания на печать записанные в него листы документов отображаются в режиме предварительного просмотра с сохраненными настройками.


Сохранение задания на печать

Чтобы сохранить задание на печать, вызовите команду Файл — Сохранить задание на печать... в режиме предварительного просмотра. На экране появится стандартный диалог сохранения файла. Введите имя файла и нажмите кнопку Сохранить. По умолчанию файлу задания присваивается имя «Задание на печать».

Каждое новое задание сохраняется в отдельном файле. При этом сохраняются следующие данные:

– относительные и абсолютные пути к файлам документов, выбранных для печати,

– номера листов документов, выбранных для печати,

– выбранное устройство печати и его настройки,

– расположение, ориентация и масштаб листов документов, заданные в режиме предварительного просмотра,

– признак печатаемости страниц устройства вывода, установленный при помощи команды Включить/выключить печать страниц,

– настройки фильтров,

– настройки параметров вывода, кроме параметров Количество копий, Масштаб печати документов по умолчанию и Помнить список из N заданий на печать.

Чтобы иметь возможность переносить папки с файлами чертежей и файлом задания на печать в другие папки без нарушения актуальности файла задания, разместите файл задания на печать рядом с файлами чертежей (в одной папке) или в родительской папке.


Загрузка задания на печать

Чтобы загрузить задание на печать, вызовите команду Файл — Загрузить задание на печать... в режиме предварительного просмотра. На экране появится стандартный диалог открытия файла. Выберите имя нужного файла задания и нажмите кнопку Открыть.

Если вы недавно сохраняли или загружали задание на печать, то можете выбрать его имя из списка заданий. Этот список отображается в меню Файл в режиме предварительного просмотра и в меню Файл — Задание на печать в главном окне. По умолчанию он содержит девять последних сохраненных или загруженных заданий на печать.

На экране появится диалог выбора варианта добавления листов документов .

Диалог выбора варианта добавления листов документов

Нажмите кнопку Добавить к имеющимся листам, чтобы добавить листы документов задания к листам документов, открытых для просмотра. При этом листы документов задания будут расположены после листов документов, открытых для просмотра. Относительное размещение листов сохранится.

В случае добавления листов игнорируется сохраненный в задании признак печатаемости страниц устройства вывода, установленный при помощи команды Включить/выключить печать страниц.

Текущие настройки вывода изменятся в соответствии с загруженным заданием.

Нажмите кнопку Заменить имеющиеся листы, чтобы заменить листы документов, открытых для просмотра, листами документов задания.

Кнопка Отмена позволяет отказаться от загрузки задания на печать.

Чтобы загрузить задание на печать из главного окна программы, вызовите команду Файл — Задание на печать — Загрузить... или выберите имя нужного файла из списка заданий. В этом случае диалог Выберите вариант добавления листов документов не появляется. Произойдет автоматический переход в режим предварительного просмотра, в котором отобразятся листы документов задания.

После загрузки задания на печать в режиме предварительного просмотра можно работать как обычно: изменять текущие настройки, удалять или перемещать листы документов и т.п.

Произведенные изменения не сохраняются в файле задания на печать. При необходимости вы можете сохранить текущие настройки в новый файл задания или перезаписать существующий.

Возможные проблемы при загрузке задания

При загрузке задания на печать возможно возникновение проблем разного рода.

Если файл задания содержит ошибки и не может быть загружен, то на экране появится сообщение Файл задания на печать содержит ошибки и не может быть загружен.

Если при загрузке задания на печать возникли проблемы, не препятствующие ее продолжению, то по окончании загрузки на экране появится Информационное окно

Информационное окно

В окне отображаются:

– текущая дата,

– полное имя файла задания на печать,

– список проблем, возникших при загрузке.

При загрузке задания на печать возможно возникновение следующих проблем.

– В задании на печать отсутствуют данные по устройству вывода. Будет использовано текущее устройство вывода. Это сообщение появляется в окне информации, если в задании на печать отсутствуют данные об устройстве вывода, которые задаются в диалоге Настройка печати. В этом случае устройством вывода станет текущее устройство или устройство по умолчанию.

– Указанное в задании на печать устройство вывода отсутствует в системе. Будет использовано текущее устройство вывода. Это сообщение появляется в окне информации, если сохраненное в задании на печать устройство вывода отсутствует в системе. В этом случае для печати используется текущее устройство вывода или назначенное по умолчанию. Сохраненный в задании признак печатаемости страниц устройства вывода, установленный при помощи команды Включить/выключить печать страниц игнорируется.

– В задании на печать отсутствуют параметры страницы. Будут использованы настройки устройства вывода. Это сообщение появляется в окне информации, если в задании на печать отсутствуют параметры страницы (размер и ориентация), которые задаются в диалоге Настройка печати. В этом случае при загрузке задания используются настройки устройства вывода.

– В задании на печать отсутствуют установки фильтров вывода на печать. Будут использованы текущие настройки фильтров. Это сообщение появляется в окне информации, если в задании на печать отсутствуют установки фильтров вывода, которые задаются в диалоге Установка фильтров вывода на печать. В этом случае при загрузке задания используются текущие настройки фильтров.

– В задании на печать отсутствуют данные о параметрах вывода. Будут использованы текущие настройки параметров вывода. Это сообщение появляется в окне информации, если в задании на печать отсутствуют данные о параметрах вывода, которые задаются в диалоге Настройка параметров вывода. В этом случае при загрузке задания используются текущие настройки этих параметров.

– Лист <номер листа> отсутствует в файле <полное имя файла>. Это сообщение появляется в окне информации, если при загрузке задания не найден один из листов документов, записанных в задании. В этом случае задание загружается без этого листа. Если все листы всех документов, записанные в задании, отсутствуют, загрузка файла задания прерывается.

– Область печати для листа <номер листа> выходит за его пределы, файл <полное имя файла>. Это сообщение появляется в окне информации, если задана печать только части листа, и границы области печати выходят за текущие габариты листа. В этом случае задание загружается без этого листа. Если данная ошибка присутствует во всех листах всех документов, записанных в задании, загрузка файла задания прерывается.

– Не найден файл <полное имя файла>. Это сообщение появляется в окне информации, если при загрузке задания не найден один из документов, записанных в задании. В этом случае задание загружается без этого документа. Если все документы, записанные в задании, отсутствуют, загрузка файла задания прерывается.

– Невозможно открыть файл <полное имя файла>. Это сообщение появляется в окне информации, если один из документов, записанных в задании, найден, но не может быть открыт. В этом случае задание загружается без этого документа. Если все документы, записанные в задании, не могут быть открыты, загрузка файла задания прерывается.

Если загрузка задания на печать вызвана из главного окна программы, и все документы, записанные в задании, содержат ошибки, или не найден ни один из этих документов, то загрузка файла задания будет прервана. На экране появится сообщение При обработке выбранного файла задания на печать не удалось сформировать данные для вывода. Для получения подробной информации войдите в режим предварительного просмотра и загрузите этот файл.


Печать графических документов и моделей

Чтобы напечатать графический документ или модель (или несколько документов), выполните следующие действия.

1. Вызовите команду Предварительный просмотр.

Если для работы загружен один документ, он будет сразу показан в режиме предварительного просмотра.

Если загружено несколько документов, на экране появится диалог выбора документов для печати. Вы можете выбрать один или сразу несколько открытых документов, выделив их в списке. Кроме того, нажав кнопку Из файла, можно выбрать для печати закрытые документы. Выбранные документы будут показаны в режиме предварительного просмотра.

2. В режиме предварительного просмотра скомпонуйте и настройте изображение.

3. Чтобы отказаться от печати какого-либо документа, выделите его и вызовите команду Удалить из просмотра.

4. Чтобы добавить документы в набор для печати, вызовите команду Добавить документ. В появившемся диалоге выберите нужное имя файла (или несколько имен файлов).

5. Вызовите команду Печать.


Печать текстовых документов и спецификаций

Чтобы напечатать текстовый документ или спецификацию, вызовите команду Файл — Печать.

На экране появится диалог настройки печати текстовых документов. В этом диалоге вы можете задать диапазон печати, количество копий и др.

Настроив параметры печати, нажмите кнопку OK для начала вывода на бумагу.

Воспользовавшись командой Файл — Предварительный просмотр, вы можете перейти в режим предварительного просмотра перед печатью. Настройка вывода текстовых документов в этом режима не так удобна, как в специальном диалоге. Однако режим предварительного просмотра и пробную печать из этого режима можно использовать, чтобы подобрать оптимальные масштаб вывода и положение начала документа.


Редактирование документов в КОМПАС

Если на вашем рабочем месте установлена система трехмерного твердотельного моделирования КОМПАС-3D, то вы можете открыть просматриваемый документ в этой системе.

Для этого вызовите команду Файл — Редактировать в КОМПАС.

В системе КОМПАС-3D откроется новое окно, в котором будет загружен для редактирования документ, просматривавшийся в КОМПАС-3D Viewer. Вы можете внести в этот документ любые изменения.


Общая настройка

При запуске и во время работы системы КОМПАС-3D Viewer, кроме собственно файлов системы, используются файлы конфигурации, файлы библиотек, различные служебные файлы. Умолчательные сведения о путях к этим файлам, а также к папкам для размещения временных файлов и документов хранятся внутри системы в виде значений переменных среды КОМПАС-3D Viewer.

Если значения переменных должны отличатся от умолчательных, следует использовать конфигурационный файл KViewer.ini, содержащий одноименные переменным ключи с нужными значениями. Этот файл отсутствует в комплекте поставки. Его необходимо создать самостоятельно и поместить в ту же папку, где находится файл KViewer.exe.

При запуске системы КОМПАС-3D Viewer поиск файла KViewer.ini ведется только в папке с файлом KViewer.exe. Поэтому размещение файла KViewer.ini в другой папке равносильно его отсутствию.


Настройка интерфейса

Чтобы настроить интерфейс программы КОМПАС-3D Viewer, вызовите команду Сервис — Настройка интерфейса.... На экране появится диалог настройки интерфейса, содержащий следующие вкладки:

Команды

Панели инструментов

Клавиатура

Меню

Параметры

Порядок настройки интерфейса КОМПАС-3D Viewer во многом аналогичен порядку настройки других приложений Windows, поэтому подробное описание каждой возможности здесь не приводится. Рассмотрены лишь следующие основные приемы.

Настройка состава Главного меню и панелей инструментов

Создание пользовательской Инструментальной панели

Настройка клавиш быстрого вызова команд («горячие клавиши»)

Настройка представления кнопок на панели инструментов

Кроме того, вы можете выбрать стиль отображения элементов интерфейса в диалоге, вызываемом командой Сервис — Вид приложения....


Команда

пустые листы

Позволяет запретить вывод всех страниц (листов) бумаги, которые не заняты печатаемыми документами.


Команда Закрыть просмотр

Позволяет завершить работу в режиме предварительного просмотра для печати и вернуться к просмотру документов.

Для вызова команды нажмите кнопку Закрыть просмотр Панели управления или выберите ее название в меню Файл.


Файл соответствия типов и стилей линий (*.ALS)

Текстовый файл, содержащий соответствия между типами линий системы AutoCAD и стилями линий чертежно-графического редактора системы КОМПАС-3D.

Пример файла *.ALS.

Continuous | | 1 | 0 | 0.4 |
Center | | 5 | 2 | 0.18 |
Dashed | | 50 | 3 | 0.18 |
Divide | | 130 | 5 | 0.18 |
FENCELINE2 | | 7 | 6 | 0.18 | D:\KOMPAS\sys\Graphic.lcs |

В каждой строке этого файла записано одно соответствие следующим образом: название типа линии в AutoCAD, вертикальная черта, номер цвета линии в AutoCAD, вертикальная черта, номер системного стиля линии КОМПАС или номер стиля в библиотеке, вертикальная черта, значение толщины линии в миллиметрах, вертикальная черта, абсолютный путь к файлу библиотеки стилей линий.

Если вы передаете на другой компьютер файл *.ALS, содержащий ссылки на пользовательские библиотеки стилей линий, то вместе с ним следует передать и эти библиотеки. Чтобы файл *.ALS можно было использовать на другом компьютере, необходимо разместить библиотеки по путям, указанным в этом файле. Если это трудно сделать (например, на компьютере нет жесткого диска с нужным именем), отредактируйте файл *.ALS, указав фактические пути к библиотекам стилей линий.

Если при импорте обнаруживается, что в библиотеке отсутствует стиль с номером, указанным в файле *.ALS, или сама библиотека отсутствует по пути, указанному в файле *.ALS, то соответствующий тип линии AutoCAD заменяется системной линией КОМПАС «Тонкая» (№1).

Смотрите также


Особенности чтения размеров и линий-выносок при импорте файлов форматов DWG и DXF

Особенности чтения размеров и линий-выносок
при импорте файлов форматов DWG и DXF

При импорте изображений, содержащих размерные линии, выполняется следующее соответствие между типами размерных стрелок AutoCAD (Arrowhead) и типами стрелок КОМПАС.

– Стрелка типа Dot small импортируется как точка.

– Стрелка типа Closed filled, Open, Open 30, Closed, Closed blank импортируется как стрелка.

– Стрелка типа Oblique и Architectural tick импортируется как засечка.

– Стрелки остальных типов при чтении превращаются в макроэлементы.

При импорте изображений, содержащих линии-выноски, выполняется такое же соответствие между типами стрелок, за исключением типов Oblique и Architectural tick — линии-выноски с этим типом стрелки превращаются в макроэлементы.

Размерные линии и линии-выноски AutoCAD с типом стрелки None импортируются без точки и стрелки.

Описанное соответствие выполняется, если размеры читаются обычным или комбинированным способом. Если чтение размеров производится макроэлементами, то все размеры и линии-выноски вне зависимости от используемого типа стрелки превращаются в макроэлементы.

Кроме того, размеры в документе AutoCAD могут иметь пользовательский тип стрелки (так называемые блок-стрелки). Размеры с такими типами стрелок импортируются как макроэлементы вне зависимости от выбранного варианта чтения размеров.


Команда Разнести

Позволяет разнести в пространстве компоненты сборки (это может потребоваться для более наглядного представления сборки).

Команда доступна, если для текущей сборки заданы компоненты и параметры разнесения (направление и расстояние). Эти параметры задаются при создании модели в системе КОМПАС-3D.

Для разнесения сборки нажмите соответствующую кнопку на панели Вид или вызовите команду Сервис — Разнести.

Все компоненты сборки, для которых заданы параметры разнесения, будут разнесены в соответствии с этими параметрами, а кнопка (рядом с названием команды в меню, а также на панели Вид) останется нажатой. Чтобы отключить разнесение компонентов (привести сборку в «неразобранное» состояние), вызовите команду снова.


Команда Вид приложения...

Позволяет выбрать стиль отображения элементов окна системы. После вызова команды на экране появляется диалог, в котором можно установить нужный стиль.


Команда Включить упрощение сборки

Позволяет включать и выключать упрощенное отображение сборок.

Для вызова команды нажмите кнопку Включить/Выключить режим упрощения сборки на панели Вид или выберите название команды из меню Сервис.


Команда Вращать модель

Позволяет запустить непрерывное вращение загруженной для просмотра модели. При просмотре графических и текстовых документов команда недоступна.

Для вызова команды нажмите кнопку Вращать модель на панели Вид или выберите ее название из меню Вид.

После вызова команды курсор принимает форму двух дугообразных стрелок.

Нажмите левую кнопку мыши в окне просмотра, переместите курсор в требуемом направлении вращения и отпустите кнопку мыши. Модель начнет вращаться в заданном направлении вокруг центра габаритного параллелограмма.

– Чтобы модель вращалась вокруг определенной точки (вершины детали, центра сферы), подведите курсор к нужному элементу в окне модели и щелкните мышью.

Курсор примет вид «звездочки» с двумя дугообразными стрелками.

Затем нажмите левую кнопку мыши, переместите курсор в требуемом направлении и отпустите кнопку.

– Чтобы модель вращалась вокруг оси (прямолинейного ребра, оси конической или цилиндрической грани), подведите курсор к нужному элементу в окне модели и щелкните мышью.

Курсор примет вид «оси» с двумя дугообразными стрелками.

Затем нажмите левую кнопку мыши, переместите курсор в требуемом направлении и отпустите кнопку.

– Чтобы модель вращалась вокруг оси, проходящей через указанную точку плоской грани перпендикулярно этой грани, подведите курсор к нужной точке плоскости в окне модели и щелкните мышью.

Курсор примет вид «плоскости» с двумя дугообразными стрелками.

Затем нажмите левую кнопку мыши, переместите курсор в требуемом направлении и отпустите кнопку.

Чем быстрее перемещался курсор при задании направления вращения, тем выше будет скорость вращения.

Чтобы прервать вращение, щелкните мышью в любом месте окна. Модель остановится. При этом команда Вращать модель не прерывается, и вы можете задать другие направление и скорость вращения.

Отказаться от вращения детали можно, нажав клавишу <Esc> или вызвав другую команду.


Команда Закрыть все

Закрывает все открытые окна документов.

Для быстрого закрытия всех документов и завершения сеанса работы КОМПАС-3D Viewer вызовите команду Файл — Выход.


Команда Быстрое отображение линий

Управляет режимом быстрого отображения линий модели.

При включенном режиме ускоряется отрисовка линий, изображающих модель без невидимых линий, с тонкими невидимыми линиями или в каркасном отображении.

Ускорение прорисовки модели достигается благодаря применению так называемого графического способа расчета линий модели. При отключенном режиме быстрого отображения этот расчет ведется математически. Математический расчет дает несколько более точный результат, но требует гораздо больше времени.

Ускорение отрисовки особенно заметно во время сдвига или поворота модели: он становится быстрее и выглядит более "плавным", т.е. приближается к перемещению в реальном времени. Благодаря этому становится удобнее контролировать перемещения.


Команда Масштаб по высоте листа

Позволяет изменить масштаб отображения текущего текстового документа или спецификации таким образом, чтобы страница документа полностью помещалась в окне по высоте (вертикальный размер изображения становится равным высоте окна).

Для вызова команды нажмите кнопку Масштаб по высоте на панели Вид или выберите ее название в контекстном меню.


Команда Масштаб по ширине листа

Позволяет изменить масштаб отображения текущего текстового документа или спецификации таким образом, чтобы страница документа полностью помещалась в окне по ширине (горизонтальный размер изображения становится равным ширине окна).

Для вызова нажмите кнопку Масштаб по ширине на панели Вид или выберите ее название в контекстном меню.


Команда Отображение — Без невидимых линий

Позволяет отобразить модель без линий невидимого контура.

Отображение модели без невидимых линий представляет собой совокупность видимых (в текущей ориентации модели) ребер, видимых частей ребер и линии очерка модели.

Для вызова команды нажмите кнопку Без невидимых линий на панели Вид или выберите ее название из меню Вид.

Сразу после вызова команды модель в активном окне отобразится без невидимых линий.

Отображение модели без невидимых линий

_________________

Смотрите также

Команда Отображение — Каркас

Команда Отображение — Невидимые линии тонкие

Команда Отображение — Полутоновое

Команда Отображение — Полутоновое с каркасом


Команда Отображение — Невидимые линии тонкие

Позволяет отобразить линии невидимого контура (невидимые ребрами и части ребер) модели более светлыми, чем видимые линии.

Для вызова команды нажмите кнопку Невидимые линии тонкие на панели Вид или выберите ее название из меню Вид.

Сразу после вызова команды модель в активном окне отобразится с невидимыми линиями, отличающимися от видимых линий.

Отображение модели с тонкими невидимыми линиями

Смотрите также

Команда Отображение — Каркас

Команда Отображение — Без невидимых линий

Команда Отображение — Полутоновое

Команда Отображение — Полутоновое с каркасом


Команда Скрыть все вспомогательные объекты

Позволяет отменить или включить одновременный показ всех вспомогательных объектов в окне модели.

Вызов команды Скрыть все вспомогательные объекты равносилен одновременному вызову следующих команд:

– Скрыть конструктивные плоскости,

– Скрыть конструктивные оси,

– Скрыть эскизы,

– Скрыть начала координат,

– Скрыть поверхности,

– Скрыть изображение резьбы,

– Скрыть пространственные кривые,

– Скрыть контрольные точки,

– Скрыть размеры,

– Скрыть условные обозначения.

При работе со сборкой команда может быть вызвана:

– из меню Вид — Скрыть; в этом случае она действует как на вспомогательные объекты в самой сборке, так и на вспомогательные объекты в ее компонентах,

– из меню Вид — Скрыть во всех компонентах; в этом случае она действует только на вспомогательные объекты в компонентах сборки.


Команда Скрыть конструктивные оси

Позволяет отменить или включить показ всех вспомогательных конструктивных осей в окне модели.

При работе со сборкой команда может быть вызвана:

– из меню Вид — Скрыть; в этом случае она действует как на оси в самой сборке, так и на оси в ее компонентах,

– из меню Вид — Скрыть во всех компонентах; в этом случае она действует только на оси в компонентах сборки.

Смотрите также

Команда Скрыть конструктивные плоскости

Команда Скрыть эскизы

Команда Скрыть начала координат

Команда Скрыть поверхности

Команда Скрыть условные изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть контрольные точки

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть все вспомогательные объекты


Команда Скрыть начала координат

Позволяет отменить или включить показ всех начал координат в окне детали или сборки.

При работе со сборкой команда может быть вызвана:

– из меню Вид — Скрыть; в этом случае она действует как на начало координат в самой сборке, так и на начала координат ее компонентов,

– из меню Вид — Скрыть во всех компонентах; в этом случае она действует только на начала координат компонентов сборки.

Смотрите также

Команда Скрыть конструктивные плоскости

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть поверхности

Команда Скрыть условные изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть контрольные точки

Команда Скрыть все вспомогательные объекты


Команда Скрыть конструктивные плоскости

Позволяет отменить или включить показ всех вспомогательных конструктивных плоскостей в окне модели.

При работе со сборкой команда может быть вызвана:

– из меню Вид — Скрыть; в этом случае она действует как на плоскости в самой сборке, так и на плоскости в ее компонентах,

– из меню Вид — Скрыть во всех компонентах; в этом случае она действует только на плоскости в компонентах сборки.

Смотрите также

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть начала координат

Команда Скрыть поверхности

Команда Скрыть условные изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть контрольные точки

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть все вспомогательные объекты


Команда Скрыть контрольные точки

Позволяет отменить или включить показ всех контрольных и присоединительных точек в окне модели.

При работе со сборкой команда может быть вызвана:

– из меню Вид — Скрыть; в этом случае она действует как на точки в самой сборке, так и на точки в ее компонентах,

– из меню Вид — Скрыть во всех компонентах; в этом случае она действует только на точки в компонентах сборки.

Смотрите также

Команда Скрыть конструктивные плоскости

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть начала координат

Команда Скрыть поверхности

Команда Скрыть условные изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть все вспомогательные объекты


Команда Скрыть пространственные кривые

Позволяет отменить или включить показ всех пространственных кривых в окне детали или сборки.

При работе со сборкой команда может быть вызвана:

– из меню Вид — Скрыть; в этом случае она действует как на кривые в самой сборке, так и на кривые в ее компонентах,

– из меню Вид — Скрыть во всех компонентах; в этом случае она действует только на кривые в компонентах сборки.

Смотрите также

Команда Скрыть конструктивные плоскости

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть начала координат

Команда Скрыть поверхности

Команда Скрыть условные изображения резьбы

Команда Скрыть контрольные точки

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть все вспомогательные объекты


Команда Скрыть условные обозначения

Позволяет отменить или включить показ всех условных обозначений в окне модели.

При работе со сборкой команда может быть вызвана:

– из меню Вид — Скрыть; в этом случае она действует как на обозначения в самой сборке, так и на обозначения в ее компонентах,

– из меню Вид — Скрыть во всех компонентах; в этом случае она действует только на обозначения в компонентах сборки.

Смотрите также

Команда Скрыть конструктивные плоскости

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть начала координат

Команда Скрыть поверхности

Команда Скрыть условные изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть контрольные точки

Команда Скрыть размеры

Команда Скрыть все вспомогательные объекты


Команда Скрыть размеры

Позволяет отменить или включить показ справочных размеров всех типов в окне модели.

При работе со сборкой команда может быть вызвана:

– из меню Вид — Скрыть; в этом случае она действует как на размеры в самой сборке, так и на размеры в ее компонентах,

– из меню Вид — Скрыть во всех компонентах; в этом случае она действует только на размеры в компонентах сборки.

Смотрите также

Команда Скрыть конструктивные плоскости

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть начала координат

Команда Скрыть поверхности

Команда Скрыть условные изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть контрольные точки

Команда Скрыть условные обозначения

Команда Скрыть все вспомогательные объекты


Команда Скрыть эскизы

Позволяет отменить или включить показ в окне модели всех эскизов, не задействованных в выполнении операций.

При работе со сборкой команда может быть вызвана:

– из меню Вид — Скрыть; в этом случае она действует как на эскизы в самой сборке, так и на эскизы в ее компонентах,

– из меню Вид — Скрыть во всех компонентах; в этом случае она действует только на эскизы в компонентах сборки.

Смотрите также

Команда Скрыть конструктивные оси

Команда Скрыть конструктивные плоскости

Команда Скрыть начала координат

Команда Скрыть поверхности

Команда Скрыть условные изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть контрольные точки

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть все вспомогательные объекты


Команда Скрыть поверхности

Позволяет отменить или включить показ всех поверхностей в окне детали или сборки.

При работе со сборкой команда может быть вызвана:

– из меню Вид — Скрыть; в этом случае она действует как на поверхности в самой сборке, так и на поверхности в ее компонентах,

– из меню Вид — Скрыть во всех компонентах; в этом случае она действует только на поверхности в компонентах сборки.

Смотрите также

Команда Скрыть конструктивные плоскости

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть начала координат

Команда Скрыть условные изображения резьбы

Команда Скрыть пространственные кривые

Команда Скрыть контрольные точки

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть все вспомогательные объекты


Команда Скрыть условные изображения резьбы

Позволяет отменить или включить показ всех изображений резьбы в окне детали или сборки.

При работе со сборкой команда может быть вызвана:

– из меню Вид — Скрыть; в этом случае она действует как на изображения резьбы в самой сборке, так и на изображения резьбы в ее компонентах,

– из меню Вид — Скрыть во всех компонентах; в этом случае она действует только на изображения резьбы в компонентах сборки.

Смотрите также

Команда Скрыть конструктивные плоскости

Команда Скрыть конструктивные оси

Команда Скрыть эскизы

Команда Скрыть начала координат

Команда Скрыть поверхности

Команда Скрыть пространственные кривые

Команда Скрыть контрольные точки

Команда Скрыть размеры

Команда Скрыть условные обозначения

Команда Скрыть все вспомогательные объекты


Команда Упрощенное отображение

Позволяет включать и выключать режим упрощенного отображения модели.

Для вызова команды нажмите кнопку Упрощенное отображение на панели Вид или выберите название команды из меню Вид — Упрощения.


Команда Сдвинуть

Позволяет сдвинуть изображение в активном окне.

Для вызова команды нажмите кнопку Сдвинуть на панели Вид или выберите ее название из меню Вид.

После этого форма курсора изменится: он превратится в четырехстороннюю стрелку.

Удерживая кнопку мыши нажатой, перемещайте курсор. Вслед за движением курсора будет прокручиваться рабочее поле документа. Если достигнут край экрана и необходимо продвинуть рабочее поле еще дальше, отпустите кнопку мыши, переместите курсор в нужное положение, а затем вновь нажмите левую кнопку мыши и продолжайте прокрутку рабочего поля.

Если вы пользуетесь трехкнопочной мышью или мышью с колесом, то для сдвига изображения в графическом, текстовом документе и документе — спецификации можно перемещать мышь с нажатой средней кнопкой (колесом). Для сдвига изображения в документе — модели следует дополнительно удерживать нажатой клавишу <Shift>.


Команда Показать лист

Кнопка Показать лист позволяет показать текущий лист полностью. При этом масштаб отображения изменятся так, чтобы текущий лист полностью умещался в окне чертежа, а положение текущего листа изменяется так, чтобы его центр совпадал с центром окна чертежа.

Поле Список листов позволяет выбрать текущий лист. Разверните список и укажите в нем номер нужного листа. Лист с выбранным номером будет показан на экране без изменения масштаба.


Команда Первый лист

Позволяет сделать текущим первый лист документа. Масштаб отображения при этом не изменяется. Кнопка недоступна, если первый лист является текущим.


Команда Последний лист

Позволяет сделать текущим последний лист документа. Масштаб отображения при этом не изменяется. Кнопка недоступна, если последний лист является текущим.


Команда Последующий лист

Позволяет сделать текущим лист, следующий за листом, который является текущим в данный момент. Масштаб отображения при этом не изменяется. Кнопка недоступна, если последний лист является текущим.


Команда Предыдущий лист

Позволяет сделать текущим лист, предшествующий листу, который является текущим в данный момент. Масштаб отображения при этом не изменяется. Кнопка недоступна, если первый лист


Команда Ориентация

Позволяет изменить текущую ориентацию модели.

Для вызова команды выберите ее название из меню Вид или нажмите кнопку Ориентация на панели Вид.

На экране появится диалог ориентаций модели, в котором можно изменить текущую ориентацию на стандартную или пользовательскую ориентацию из списка, а также сохранить текущую ориентацию в списке.

Другим способом задания нужной ориентации модели является выбор нужной команды из меню кнопки Ориентация.

Команды этого меню можно расположить в виде кнопок на отдельной панели и поместить ее в любом удобном месте. Для этого «перетащите» меню кнопки Ориентация мышью за заголовок в любом направлении. Будет сформирована панель Ориентация.

Панель Ориентация не содержит кнопки для задания пользовательских ориентаций модели.

Обратите внимание на отличие панели Ориентация от остальных инструментальных панелей: состав и порядок кнопок на ней изменить невозможно.

Смотрите также

Команда Повернуть


Текущая страница

В этом поле, расположенном на панели Текущее состояние, показан номер страницы, которая отображается на экране.

Чтобы переместиться на другую страницу, наберите ее номер в этом поле и нажмите клавишу <Enter>.

Если панель Текущее состояние расположена вертикально, то для доступа к полю Текущая страница нажмите соответствующую кнопку.


Команда Приблизить/отдалить изображение

Позволяет плавно менять масштаб, приближая или отдаляя изображение.

Для вызова команды нажмите кнопку Увеличить масштаб на панели Вид или выберите ее название из меню Вид.

Нажмите левую кнопку мыши и перемещайте курсор в вертикальном направлении. При движении курсора вверх изображение будет плавно увеличиваться, в обратном направлении — уменьшаться.

Центром панорамирования является центральная точка экрана.

Чтобы центр панорамирования находился в точке, в которой была нажата левая кнопка мыши, удерживайте нажатой клавишу <Shift>.

Если вы пользуетесь мышью с колесом, то для панорамирования изображения вращайте колесо мыши. Для панорамирования изображений в текстовых документах и документах — спецификациях следует дополнительно удерживать нажатой клавишу <Ctrl>.

Центром панорамирования является центральная точка экрана.

Чтобы центр панорамирования изображений графических и трехмерных объектов находился в точке, в которой было начато вращение колеса мыши, удерживайте нажатой клавишу <Shift>.

Смотрите также


Команда Параметры...

Позволяет настроить различные системные параметры.

После вызова команды на экране появляется настроечный диалог.

Для изменения какой-либо группы выберите в правой части диалога название нужной группы, а в левой — нужные значения параметров.

Чтобы развернуть содержание какого-либо раздела, установите курсор на значке плюса рядом с заголовком раздела и щелкните левой кнопкой мыши. Повторный щелчок на символе (после разворачивания раздела он отображается как минус) приведет к сворачиванию содержания.

Для сохранения всех изменений и выхода из диалога нажмите кнопку ОК, для выхода без сохранения изменений — кнопку Отмена.


Команда Отображение – Перспектива

Позволяет включить или выключить отображение модели в перспективной проекции.

Для вызова команды нажмите кнопку Перспектива на панели Вид или выберите ее название из меню Вид.

Точка схода перспективы расположена посередине окна модели.

Все типы отображения (каркасное, полутоновое, без невидимых линий и с тонкими невидимыми линиями) можно сочетать с перспективной проекцией.

Смотрите также


Команда Загрузить задание на печать...

Команда позволяет загрузить задание на печать.

Чтобы загрузить задание на печать, вызовите команду Файл — Задание на печать — Загрузить... Главного меню. На экране появится стандартный диалог открытия файла. Выберите имя нужного файла и нажмите кнопку Открыть. Произойдет автоматический переход в режим предварительного просмотра, в котором отобразятся листы документов задания.

Если вы недавно сохраняли или загружали задание на печать, то можете выбрать его имя из списка заданий. Этот список отображается в меню Файл подменю Задание на печать в главном окне программы и в меню Файл в режиме предварительного просмотра. По умолчанию он содержит девять последних сохраненных или загруженных заданий на печать.

Чтобы вызвать загрузку задания на печать из окна предварительного просмотра, вызовите команду Файл — Загрузить задание на печать.... В этом случае после стандартного диалога открытия файла на экране появится диалог выбора варианта добавления листов документов. Для продолжения загрузки выберите один из предлагаемых в диалоге вариантов добавления листов документов задания. Для прекращения загрузки нажмите кнопку Отмена.

После загрузки задания на печать в режиме предварительного просмотра можно работать как обычно: изменять текущие настройки, удалять или перемещать листы документов и т.п.

Произведенные изменения не сохраняются в файле задания на печать. При необходимости вы можете сохранить текущие настройки в новом файле задания или перезаписать существующий.

Возможные проблемы при загрузке задания

Смотрите также

Команда Сохранить задание на печать...


Команда Сохранить задание на печать...

Команда позволяет сохранить задание на печать.

Чтобы сохранить задание на печать, вызовите команду Файл — Сохранить задание на печать.... На экране появится стандартный диалог сохранения файла. Введите имя файла и нажмите кнопку Сохранить. По умолчанию файлу задания присваивается имя «Задание на печать».

Подробнее...

Смотрите также

Команда Загрузить задание на печать...


Команда Добавить документ

Позволяет добавить один или несколько документов в набор предварительного просмотра для печати.

Для вызова команды нажмите кнопку Добавить документ на Панели управления или выберите ее название из меню Файл.

После вызова команды на экране появляется диалог, в котором следует выбрать нужные файлы документов для включения их в просмотр.


Команда Исключить документ

Позволяет исключить выделенный документ или лист (листы) многолистового документа из очереди на печать.

Для вызова команды нажмите кнопку Исключить документ на Панели управления или выберите ее название из меню Файл.

Команда недоступна, если в поле просмотра находится один документ, состоящий из одного листа.


Команда Включить все листы

Вызывается из контекстного меню.

Позволяет включить все выключенные на момент вызова команды листы. Команда доступна, если запрещен вывод на печать хотя бы одного листа.

Для включения и выключения отдельных листов пользуйтесь командой Включить/выключить листы из меню Сервис.


Команда Инвертировать листы

Вызывается из контекстного меню.

Позволяет включить выключенные на момент вызова команды листы и выключить включенные. Для включения и выключения отдельных листов пользуйтесь командой Включить/выключить листы из меню Редактор.


Команда Включить/выключить листы

Позволяет запретить вывод на печать указанной страницы (листа) или отменить запрет.

Для вызова команды нажмите кнопку Включить/выключить листы на Панели управления или выберите ее название из меню Сервис.

После вызова команды включается режим указания страниц на поле печати (признаком того, что режим включен, является отображение кнопки Листы как нажатой). Чтобы отменить вывод на печать какой-либо страницы, зафиксируйте курсор внутри этой страницы. При этом изменится цвет, которым указанная страница изображена на экране.

Повторная фиксация курсора внутри отмеченной страницы отменяет запрещение на ее печать.

Для выхода из режима указания страниц вызовите еще раз команду или нажмите кнопку Листы (она вернется в исходное ненажатое положение).


Команда Повернуть против часовой стрелки

Поворачивает документ на 90 градусов против часовой стрелки на поле печати.

Для вызова команды нажмите кнопку Повернуть против часовой стрелки на Панели управления или выберите ее название из меню Сервис.


Команда Повернуть по часовой стрелке

Поворачивает документ на 90 градусов по часовой стрелке на поле печати.

Для вызова команды нажмите кнопку Повернуть по часовой стрелке на Панели управления или выберите ее название из меню Сервис.


Команда Фильтры вывода на печать

Позволяет запретить вывод на печать объектов, обладающих определенными признаками (например, объектов конкретного типа), или отменить запрет.

Для вызова команды нажмите кнопку Фильтры вывода на печать на Панели управленияl или выберите ее название из меню Сервис.

После вызова команды на экране появится диалог настройки фильтра. Объекты с отмеченными в нем признаками (стилем линии, типом и т.д.) будут выводиться на печать.


Команда Настройка параметров вывода

Позволяет настроить параметры вывода документа на печать (количество копий, цвет, точность вывода моделей и т.п.).

Для вызова команды нажмите кнопку Настройка параметров вывода на Панели управленияl или выберите ее название из меню Файл.

После вызова команды на экране появится диалог, в котором можно сделать необходимые настройки.


Команда Подогнать масштаб...

Позволяет автоматически пересчитать масштаб печати изображения для его размещения на заданном количестве листов.

После вызова команды на экране появляется диалог для задания количества листов, на которых следует разместить изображение.


Текущий масштаб поля вывода

В этом поле, расположенном на Панели управления, показан масштаб отображения поля вывода.

Чтобы изменить масштаб, разверните список и выберите нужное значение. Можно также ввести значение с клавиатуры.

Смотрите также


Текущий шаг курсора

В этом поле отображается значение шага курсора, то есть расстояние, на которое переместится текущий документ (документы) при однократном нажатии управляющей клавиши (любой из клавиш со стрелками).

Вы можете изменить шаг курсора, набрав вручную нужное значение. Чтобы поле ввода стало доступным, установите в него курсор и щелкните левой кнопкой мыши.

Можно также выбрать значение шага из списка. Чтобы открыть список, щелкните на клавише со стрелкой рядом с полем ввода.


Команда Сдвинуть

Позволяет сдвинуть поле вывода в окне предварительного просмотра.

Для вызова команды нажмите кнопку Сдвинуть на Панели управления или выберите ее название из меню Вид — Масштаб.

После этого форма курсора изменится: он превратится в четырехстороннюю стрелку.

Удерживая кнопку мыши нажатой, перемещайте курсор. Вслед за движением курсора будет прокручиваться поле вывода. Если достигнут край экрана и необходимо продвинуть поле вывода еще дальше, отпустите кнопку мыши, переместите курсор в нужное положение, а затем вновь нажмите левую кнопку мыши и продолжайте прокрутку рабочего поля.

Если вы пользуетесь трехкнопочной мышью или мышью с колесом, то для сдвига поля вывода можно перемещать мышь с нажатой средней кнопкой (колесом).

Если масштаб отображения в окне предварительного просмотра таков, что поле вывода отображается целиком, командой сдвига воспользоваться невозможно.


Команда Показать все

Изменяет масштаб отображения поля вывода таким образом, чтобы оно было видно на экране целиком.

Для вызова команды нажмите кнопку Показать все на Панели управления или выберите ее название из меню Вид — Масштаб. Можно также нажать клавишу <F9>.

Смотрите также


Команда Увеличить масштаб

Позволяет увеличить масштаб отображения поля вывода.

Для вызова команды нажмите кнопку Увеличить масштаб на Панели управления или выберите ее название из меню Вид — Масштаб. Можно также нажать клавишу <+> на цифровой клавиатуре.

Смотрите также


Команда Уменьшить масштаб

Позволяет уменьшить масштаб отображения поля вывода.

Для вызова команды нажмите кнопку Уменьшить масштаб на Панели управления или выберите ее название из меню Вид — Масштаб. Можно также нажать клавишу <-> на цифровой клавиатуре.

Смотрите также


Команда Увеличить масштаб рамкой

Позволяет изменить масштаб отображения поля вывода с помощью прямоугольной рамки.

Для вызова команды нажмите кнопку Увеличить масштаб рамкой на Панели управления или выберите ее название из меню Вид — Масштаб.

После этого внешний вид курсора изменится: он превратится в перекрестье. Укажите первый угол, затем перемещайте курсор для достижения нужного размера рамки. На экране будет отображаться фантом рамки. Укажите второй угол рамки.

Масштаб отображения увеличится так, чтобы область, ограниченная рамкой, полностью умещалась в окне предварительного просмотра.

Смотрите также


Команда Обновить изображение

Позволяет обновить изображение в активном окне.

При обновлении масштаб отображения документа в окне не изменяется.

Для вызова команды нажмите кнопку Обновить изображение на панели Вид или выберите ее название из меню Вид. Можно также нажать комбинацию клавиш <Ctrl>+<F9>.


Команда Повернуть против часовой стрелки

Позволяет повернуть модель на 90 градусов против часовой стрелки в плоскости экрана.


Команда Повернуть по часовой стрелке

Позволяет повернуть модель на 90 градусов по часовой стрелке в плоскости экрана.


Команда Повернуть

Позволяет динамически поворачивать изображение модели.

Для вызова команды нажмите кнопку Повернуть на панели Вид или выберите ее название из меню Вид.

После вызова команды изменяется внешний вид курсора (он превращается в две дугообразные стрелки).

Нажмите левую кнопку мыши в окне модели и, не отпуская ее, перемещайте курсор. Модель будет поворачиваться вокруг центральной точки габаритного параллелограмма.

Если вы пользуетесь мышью с колесом или трехкнопочной мышью, то для вращения модели вокруг центра габаритного параллелепипеда можно перемещать мышь с нажатой средней кнопкой или колесом. Если при этом удерживать нажатой клавишу <Alt>, то модель будет вращаться в плоскости экрана.

Если требуется вращать модель вокруг точки (вершины детали, центра сферы), подведите курсор к нужному элементу в окне модели и щелкните левой кнопкой мыши.

Курсор примет вид «звездочки» с двумя дугообразными стрелками.

Нажмите левую кнопку мыши в окне модели и, не отпуская ее, перемещайте курсор. Модель будет поворачиваться вокруг выбранной точки.

Направление вращения вокруг центральной точки габаритного параллелограмма или вокруг точки зависит от направления перемещения курсора.

Если требуется вращать модель в плоскости экрана, перемещайте курсор (с нажатой левой кнопкой мыши) горизонтально, удерживая при этом нажатой клавишу <Alt>.

Если требуется вращать модель вокруг конструктивной оси или прямолинейного ребра, подведите курсор к нужному элементу в окне модели и щелкните левой кнопкой мыши.

Курсор примет вид «оси» с двумя дугообразными стрелками.

Нажмите левую кнопку мыши в окне модели и, не отпуская ее, перемещайте курсор. Модель будет поворачиваться вокруг выбранной оси.

Если требуется вращать модель вокруг оси, проходящей через указанную точку плоскости (вспомогательной, проекционной плоскости или плоской грани детали) перпендикулярно этой плоскости, подведите курсор к нужной точке плоскости в окне модели и щелкните левой кнопкой мыши.

Курсор примет вид «плоскости» с двумя дугообразными стрелками.

Нажмите левую кнопку мыши в окне модели и, не отпуская ее, перемещайте курсор. Модель будет поворачиваться вокруг указанной оси.

Для выхода из команды поворота модели нажмите кнопку Прервать команду на Панели специального управления или клавишу <Esc>.

Смотрите также


Текущий масштаб

В этом поле, расположенном на панели Вид, показан масштаб отображения в активном окне.

Если панель расположена вертикально, для вызова этого поля нажмите кнопку Текущий масштаб.

Чтобы изменить масштаб, разверните список и выберите нужное значение. Можно также ввести значение с клавиатуры.

Смотрите также


Команда Параметры...

Позволяет настроить различные системные параметры, а также параметры текущего окна.

После вызова команды на экране появляется настроечный диалог.

Для изменения какой-либо группы выберите в правой части диалога название нужной группы, а в левой - нужные значения параметров.

Чтобы развернуть содержание какого-либо раздела, установите курсор на значке плюса рядом с заголовком раздела и щелкните левой кнопкой мыши. Повторный щелчок на символе (после разворачивания раздела он отображается как минус) приведет к сворачиванию содержания.

Для сохранения всех изменений и выхода из диалога нажмите кнопку ОК, для выхода без сохранения изменений — кнопку Отмена.


Команда Отображение – Полутоновое

Позволяет получить полутоновое изображение модели.

Для вызова команды нажмите кнопку Полутоновое отображение на панели Вид или выберите ее название из меню Вид.

Сразу после вызова команды в активном окне появится полутоновое изображение модели.

При полутоновом отображении модели учитываются оптические свойства ее поверхности (цвет, блеск, диффузия и т.д.).

Смотрите также

Команда Отображение — Каркас

Команда Отображение — Без невидимых линий

Команда Отображение — Невидимые линии тонкие

Команда Отображение — Полутоновое с каркасом


Команда Отображение - Полутоновое с каркасом

Позволяет добавить к полутоновому отображению модели изображения видимых (в текущей ориентации модели) ребер и линий очерка.

Для вызова команды нажмите кнопку Полутоновое с каркасом на панели Вид или выберите ее название из меню Вид.

Цвет линий каркаса — черный.

Смотрите также

Команда Отображение — Каркас

Команда Отображение — Без невидимых линий

Команда Отображение — Невидимые линии тонкие

Команда Отображение — Полутоновое


Показать закладки

Управляет отображением на экране закладок документов.

Для вызова команды выберите ее название из меню Окно или из контекстного меню закладки.


Команда Свойства...

Позволяет просмотреть справочную информацию, хранящуюся вместе с активным документом. При этом на экран выводится соответствующий диалог. На вкладках диалога вы можете просмотреть сведения об авторе, датах создания и изменения файла, комментарий к документу и его внешние ссылки (ссылки на библиотеки стилей, фрагментов, внешние вставки).


Команда Мозаика для текущего документа

Размещает все открытые окна активного документа таким образом, чтобы они прилегали друг к другу и все были видимыми.


Команда Настройка интерфейса...

Позволяет настроить интерфейс системы: состав инструментальных панелей, клавиатурные комбинации для вызова команд, отображение кнопок и другие параметры.


Команда Редактировать в КОМПАС

Позволяет отредактировать текущий документ в системе трехмерного твердотельного моделирования КОМПАС-3D.

Редактирование возможно, если названная система установлена на вашем рабочем месте.

После вызова команды в системе КОМПАС-3D откроется новое окно, в котором будет загружен для редактирования документ, просматривавшийся в КОМПАС-3D Viewer. Вы можете внести в этот документ любые изменения.


Команда Следующий документ

Позволяет открыть в активном окне следующий документ. Если активный документ открыт только в одном окне, то он закрывается.

Следующим документом по отношению к данному считается документ, находящийся в той же папке, что и данный, и следующий за ними при упорядочении файлов по типу.

Для вызова команды нажмите комбинацию клавиш <Alt>+<Page down>, или кнопку Следующий документ на панели Вид, или выберите название команды из меню Вид.

Если документ, открытый в активном окне, последний в отсортированном по типу списке файлов, то команда Следующий документ недоступна.


Команда Предыдущий документ

Позволяет открыть в активном окне предыдущий документ по отношению к активному. Если активный документ открыт только в одном окне, то он закрывается.

Предыдущим документом по отношению к данному считается документ, находящийся в той же папке, что и данный, и предшествующий ему при упорядочении файлов по типу.

Для вызова команды нажмите комбинацию клавиш <Alt>+<Page up>, или кнопку Предыдущий документ на панели Вид, или выберите название команды из меню Вид.

Если документ, открытый в активном окне, первый в отсортированном по типу списке файлов, то команда Предыдущий документ недоступна.


Команда Перечитать файл

Позволяет перечитать текущий документ.

Для вызова команды нажмите кнопку Перечитать файл на панели Стандартная или выберите ее имя из меню Файл.

После вызова команды произойдет «повторное открытие» текущего документа: система вновь обратится к хранящемуся на диске файлу и отобразит на экране его содержимое.

Это позволяет увидеть документ в его последней редакции, если редактирование было завершено после начала просмотра.

Команда Перечитать файл недоступна для документов — моделей


Команда Показать погашенные слои

Позволяет включить показ объектов, расположенных в погашенных слоях текущего графического документа.

Для вызова команды нажмите кнопку Показать погашенные слои.

Команда доступна, если текущий документ содержит погашенные слои.

По умолчанию кнопка для вызова команды отсутствует на панели. Чтобы команда была доступна, необходимо настроить панель Текущее состояние для работы с графическими документами, добавив на нее кнопку Показать погашенные слои.

Смотрите также


Команда Показать погашенные виды

Позволяет включить показ объектов, расположенных в погашенных видах текущего чертежа.

Для вызова команды нажмите кнопку Показать погашенные виды на панели Текущее состояние.

Команда доступна, если текущий чертеж содержит погашенные виды.

По умолчанию кнопка для вызова команды отсутствует на панели. Чтобы команда была доступна, необходимо настроить панель Текущее состояние для работы с чертежами, добавив на нее кнопку Показать погашенные виды.

Смотрите также


Команда Все окна...

Вызывает диалог управления окнами и документами.

В этом диалоге перечислены все документы, открытые в текущем сеансе работы (документы, открытые в нескольких окнах, названы соответствующее количество раз).

Выбрав один или несколько документов (окон) в списке, вы можете, воспользовавшись соответствующими кнопками, выполнить одно из следующих действий:

– активизировать (возможно, если выделен один документ),

– закрыть,

– расположить каскадом,

– расположить горизонтально,

– расположить вертикально,

– минимизировать.


Команда Отображение – Каркас

Позволяет отобразить модель в виде каркаса.

Каркас представляет собой совокупность всех ребер и линии очерка модели.

Для вызова команды нажмите кнопку Каркас на панели Вид или выберите ее название из меню Вид.

Сразу после вызова команды модель в активном окне отобразится в виде каркаса.

Отображение модели в виде каркаса

Смотрите также

Команда Отображение — Без невидимых линий

Команда Отображение — Невидимые линии тонкие

Команда Отображение — Полутоновое

Команда Отображение - Полутоновое с каркасом


Команда Показать все

Изменяет масштаб отображения в активном окне таким образом, чтобы в нем был виден полностью весь документ.

– для графических докумтов — так, чтобы в окне были полностью видны все объекты,

– для моделей — так, чтобы проекция габаритного параллелепипеда модели на плоскость экрана была вписана в окно.

Для вызова команды нажмите кнопку Показать все на панели Вид или выберите ее название из меню Вид. Можно также нажать клавишу <F9>.

Смотрите также


Команда Увеличить масштаб

Позволяет увеличить масштаб отображения в активном окне в определенное количество раз.

Для вызова команды нажмите кнопку Увеличить масштаб на панели Вид или выберите ее название из меню Вид. Можно также нажать комбинацию клавиш <Ctrl>+<+>.

Смотрите также


Команда Уменьшить масштаб

Позволяет уменьшить масштаб отображения в активном окне в определенное количество раз.

Для вызова команды нажмите кнопку Уменьшить масштаб на панели Вид или выберите ее название из меню Вид. Можно также нажать комбинацию клавиш <Ctrl>+<->.

Смотрите также


Команда Последующий масштаб

Позволяет вернуться к последующему масштабу отображения графического документа в активном окне. Команда доступна в том случае, если перед этим был выполнен возврат к предыдущему масштабу.

Для вызова команды нажмите кнопку Последующий масштаб или выберите ее название из меню Вид.

Смотрите также


Команда Предыдущий масштаб

Позволяет возвратиться к предыдущему масштабу отображения графического документа в активном окне.

Для вызова команды нажмите кнопку Предыдущий масштаб или выберите ее название из меню Вид.

Смотрите также


Команда Увеличить масштаб рамкой

Позволяет изменить масштаб отображения в активном окне с помощью прямоугольной рамки.

Для вызова команды нажмите кнопку Увеличить масштаб рамкой на панели Вид или выберите ее название из меню Вид.

После этого внешний вид курсора изменится: он превратится в перекрестье. Укажите первый угол, затем перемещайте курсор для достижения нужного размера рамки. На экране будет отображаться фантом рамки. Укажите второй угол рамки.

Масштаб изображения увеличится так, чтобы область, ограниченная рамкой, полностью умещалась в окне документа.

Смотрите также


Диалог выбора вида приложения

Этот диалог появляется на экране после первого запуска системы КОМПАС-3D Viewer или после вызова команды Сервис — Вид приложения....

Позволяет настроить стиль отображения элементов окна системы.

Описание элементов управления
Наименование | Описание
Стиль приложения | Список, из которого можно выбрать стиль приложения. Укажите в раскрывающемся списке один из вариантов.
Цветовая схема (только для Office 2007) | Список, из которого можно выбрать цветовое оформление приложения. Список доступен, если стиль приложения — Microsoft® Office 2007. Укажите в раскрывающемся списке один из вариантов.
Цветные закладки документов | Опция, управляющая стилем закладок документов. При включении этой опции закладки отображаются разноцветными, а кнопка прокрутки закладок влево находится слева от них.
Расширенные всплывающие подсказки | Опция, управляющая видом всплывающих подсказок. Если опция включена, то во всплывающую подсказку, появляющуюся при подведении курсора к элементу рабочего окна, добавляется информация, находящаяся в строке сообщений. Если опция выключена, то всплывающая подсказка будет содержать только название команды.
Показывать этот диалог при запуске | Опция, управляющая автоматическим открытием диалога. Если она включена, то диалог появляется на экране каждый раз после запуска системы.
ОК | Нажатие этой кнопки закрывает диалог и применяет выбранную настройку.
Закрыть | Нажатие этой кнопки закрывает диалог без применения выбранной настройки. Такой же результат дает закрытие диалога кнопкой в его заголовке.
Применить | Нажатие этой кнопки применяет выбранную настройку без закрытия диалога.

При первом запуске системы диалог выбора вида приложения появляется без кнопки Закрыть.


Диалог выбора стиля линии

Этот диалог появляется на экране после нажатия кнопки >> в диалоге настройки соответствия стилей линий КОМПАС и AutoCAD.

Позволяет выбрать стиль линии КОМПАС, которым будет заменяться тип линии AutoCAD, определенный в диалоге настройки соответствия.

Описание элементов управления

Элемент

Описание

Системные

Из библиотек

При переключении между закладками отображается список системных стилей линий либо список стилей линий из внешней библиотеки.

Стили в списках могут быть отсортированы по именам или по номерам. Чтобы изменить сортировку, щелкните мышью по заголовку нужного столбца. В заголовке столбца, по которому сортируются стили, отображается треугольник. Его положение показывает направление сортировки — по возрастанию или по убыванию.

Библиотеку...

Нажмите эту кнопку для подключения внешней библиотеки стилей. В появившемся диалоге укажите нужную библиотеку стилей линий — файл *.lcs, затем нажмите кнопку Открыть. Перечень стилей, хранящихся в выбранной библиотеке, отобразится на вкладке Библиотека.

Выбрать

Выделите нужный стиль и нажмите эту кнопку, чтобы подтвердить выбор. Диалог выбора стиля закроется, а в поле Стиль линии КОМПАС диалога настройки соответствия стилей линий появится название выбранного стиля.

Отмена

Для выхода из диалога без выбора стиля нажмите кнопку.

Для удобства поиска и выбора внешний вид стиля отображается в специальном окне просмотра.


Диалог настройки цветовой схемы

Этот диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Экран — Цветовая схема.

Диалог позволяет задать цвета отображения элементов документа и элементов системы.

Доступны следующие варианты настройки цветов элементов.

Элемент | Описание
Инверсный цвету фона | Если собственный цвет элемента (заданный при его настройке) совпадает с цветом фона или близок к нему, то элемент отображается цветом, противоположным цвету фона.
Заданный при настройке | Элементы отображаются теми цветами, которые были установлены при их настройке или создании.
Определить | Отображение всех элементов и объектов одним и тем же цветом. Цвета, установленные при их настройке, будут игнорироваться. После включения опции Определить становится доступна кнопка Цвет, позволяющая выбрать цвет элементов.

Если для моделей установлен цвет фона с градиентным переходом, то инверсные цвета элементов в документах-моделях не поддерживаются. Трехмерные элементы и элементы системы отображается цветами, заданными при их настройке.

Завершив настройку цветовой схемы, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


Не прочитан файл компонента

Этот диалог появляется на экране, если при открытии сборки выясняется, что один или несколько файлов компонентов испорчены или не найдены по пути, записанному в открываемой модели.

В поле Имя файла показаны пути к открываемому файлу сборки и файлу — источнику компонента, который невозможно прочитать (и, следовательно, отобразить в сборке).

– Если вы хотите вставить вместо непрочитанного компонента другую модель или указать новый путь к файлу компонента, нажмите кнопку Заменить и укажите, какая модель должна быть вставлена.

– Если вы хотите открыть сборку без ненайденного компонента, нажмите кнопку Игнорировать.

– Если не требуется открывать сборку, содержащую компонент, источник которого невозможно прочитать, нажмите кнопку Отказ от чтения.

Если данное предупреждение появляется при открытии сборки, созданной на другом рабочем месте (например, полученной от смежников), то наиболее вероятная причина ошибк — отсутствие нужных файлов. Для корректного отображения сборки необходимо получить эти файлы у ее разработчика, разместить их в определенных папках, а затем открыть сборку заново.

Можно выделить три наиболее типичных случая отсутствия файлов:

– Отсутствие файла стандартного изделия. Путь к файлу стандартного изделия содержит фрагмент «..\Libs\Partlib\Vault\methods\kompas\3D». Если вы видите в поле Имя файла указанный фрагмент пути, запросите у разработчика модели стандартных изделий, т.е. содержимое папки ..\Libs\Partlib\Vault\methods\kompas\3D. Полученные файлы и папки поместите в подпапку ..\Libs\Partlib\Vault\methods\kompas\3D главной папки КОМПАС-3D Viewer (при этом потребуется создать вложенные друг в друга папки Partlib, Vault и т.д.).

– Отсутствие библиотеки моделей. Путь к файлу библиотеки содержит фрагмент вида «XXX.l3d|YYY» где XXX - имя файла библиотеки моделей, а YYY - название модели в библиотеке. Если вы видите в поле Имя файла указанный фрагмент пути, запросите у разработчика файл библиотеки моделей (*.l3d), имя которого указано в диалоге. Полученный файл поместите в подпапку ..\Libs главной папки КОМПАС-3D Viewer.

– Отсутствие файла компонента (детали или подсборки, входящей в сборку). Путь к файлу компонента может быть любым. Если ни одного из вышеприведенных фрагментов нет в поле Имя файла, отправьте разработчику запрос, указав все содержимое этого поля. Полученный файл разместите на своем рабочем месте так, чтобы путь к нему совпадал с указанным в диалоге. Если это трудно сделать (например, на вашем компьютере нет жесткого диска с нужным именем), поместите полученный файл в ту папку, где находится сборка, которую необходимо открыть.


Диалог настройки параметров отрисовки обозначенияотклонений формы и базы

Диалог настройки параметров отрисовки обозначения
отклонений формы и базы

Этот диалог появляется на экране после вызова команды настройки отрисовки обозначения отклонений формы и базы в графических документах или моделях. Например, Сервис — Параметры — Текущий чертеж — Отклонения формы и база.

Позволяет назначить параметры отображения и печати допусков формы и расположения, а также обозначений баз.

Описание элементов управления
Элемент | Описание
Зачернять треугольник | Чтобы при отрисовке обозначения базы или допуска формы треугольник был закрашен, включите эту опцию.

После завершения настройки параметров отрисовки обозначений отклонений формы и базы нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог замены файла спецзнаков

Этот диалог появляется на экране, если в данном сеансе работы невозможно прочитать файл спецзнаков graphic.bss.

Вы можете заменить, создать новый или проигнорировать файл спецзнаков. В этом файле содержатся изображения таких знаков, как диаметр, корень, обозначения допусков формы и расположения и т.п.

Описание элементов управления
Элемент | Описание
Изменить путь | Нажмите эту кнопку для указания другого пути к файлу graphic.bss и в появившемся диалоге выберите этот файл в другом каталоге.
Создать новый | Нажмите эту кнопку для генерации нового файла graphic.bss из выбранного в открывшемся диалоге исходного файла спецзнаков *.sss.
Игнорировать | При нажатии этой кнопки будут игнорироваться все спецзнаки (без уведомления об их наличии) во всех документах в данном сеансе работы КОМПАС-3D Viewer, т.е. документы будут отображаться без спецзнаков.


Не найдено или неправильно задано оформление листов спецификации

Появление этого диалога означает, что при создании спецификации, которую вы пытаетесь открыть, использовался файл *.lyt, отличный от имеющегося на вашем рабочем месте. В этом случае рекомендуется поступить следующим образом.

1. Закрыть данный диалог.

2. Запросить у разработчика спецификации файл *.lyt, который был указан в диалоге.

3. Полученный файл поместить в подпапку ..\Sys главной папки КОМПАС-3D Viewer.

4. Открыть спецификацию заново.


Диалог настройки фильтров вывода на печать

Позволяет задать объекты документа, которые будут напечатаны.

Этот диалог появляется на экране в обычном режиме работы с КОМПАС-3D Viewer после вызова команды Сервис — Параметры — Система — Графический редактор — Фильтры вывода на печать, а в режиме предварительного просмотр — после вызова команды Сервис — Фильтры вывода на печать.

Описание элементов управления
Элемент | Описание
Все объекты | Чтобы отменить вывод на печать всех объектов документа, выключите эту опцию. Если для вывода на печать выбрана часть объектов, «галочка» включения опции будет показана на сером фоне. Чтобы на печать были выведены все объекты, включите опцию.
Выводить текст рамкой | Чтобы вместо текста в документе на печать выводилась его габаритная рамка, включите эту опцию.
Выводить растровые объекты рамками | Чтобы вместо растровых объектов в документе на печать выводились их габаритные рамки, включите эту опцию.
Выводить OLE-объекты рамками | Чтобы вместо OLE-объектов в документе на печать выводились их габаритные рамки, включите эту опцию.
Применять фильтры к макроэлементам и вставкам фрагментов | Чтобы фильтры были применены к объектам, входящим во вставленные макроэлементы и фрагменты, включите эту опцию. При выключенной опции эти объекты не будут рассматриваться как самостоятельные, подлежащие фильтрации.
Список элементов текущего чертежа | Содержит названия элементов чертежа и их групп. Вы можете выбрать объекты для вывода на печать. Чтобы раскрыть список группы, щелкните по значку <+> слева от ее названия.
Не использовать фильтры | Чтобы отменить применение фильтров и вывести на печать все объекты, включите эту опцию.
Применить | Чтобы задействовать сформированный фильтр без закрытия диалога, нажмите эту кнопку. Она доступна, если диалог был вызван в режиме предварительного просмотра.
ОК | Чтобы задействовать сформированный фильтр и закрыть диалог, нажмите эту кнопку.
Отмена | Чтобы закрыть диалог без изменения фильтра, нажмите эту кнопку.


Диалог настройки точности отрисовки

Этот диалог появляется на экране после вызова команды Сервис — Параметры — Текущая деталь (сборка) — Точность отрисовки.

Описание элементов управления

Элемент

Описание

Точность отрисовки

Позволяет увеличить или уменьшить точность аппроксимации криволинейных ребер и линий очерка модели отрезками прямых линий, а криволинейных поверхностей – треугольниками1.

Для изменения точности перемещайте «бегунок» между позициями Грубо и Точно. В справочном поле диалога будет показан условный коэффициент точности отображения – количество треугольников, а в окне просмотра – изображение поверхности сферы при выбранной степени точности.

Чем выше точность, тем более «гладким» выглядит изображение и тем больше времени требуется на расчеты.
  1. Изменение точности отрисовки модели сборки влияет только на отображение поверхностей, созданных в этой сборке или импортированных в нее.

Настроив точность отрисовки, нажмите кнопку OK диалога. Для выхода из диалога без изменения точности нажмите кнопку Отмена.


Не найден или испорчен файл библиотеки

Этот диалог появляется, если система не может обнаружить библиотеку, стиль или тип атрибута из которой присвоен объекту, содержащемуся в открываемом документе. Например, библиотека может быть удалена, перемещена или переименована.

Как исправить эту ошибку

– Чтобы указать библиотеку, из которой следует взять стиль или тип атрибута, нажмите кнопку Найти файл.

– Чтобы прервать открытие документа, нажмите кнопку Отказ от чтения.

– Если ошибка вызвана отсутствием библиотеки стилей, диалог содержит кнопку Удалить стиль. Нажмите ее, чтобы заменить отсутствующий стиль системным стилем.

Если ошибка вызвана отсутствием библиотеки типов атрибутов (*.lat), диалог содержит кнопку Игнорировать. Нажмите ее, чтобы открыть документ, проигнорировав присвоенные объектам атрибуты.

Атрибут — это неграфическая информация, которая связана с объектом КОМПАС-документа и хранящаяся в этом документе. Просмотр, редактирование или удаление атрибутов объектов в системе КОМПАС-3D Viewer невозможны. Поэтому игнорирование атрибутов в открываемом документе никак не повлияет на его внешний вид и возможности работы с ним.

Если данный диалог появляется при открытии документа, созданного на другом рабочем месте (например, полученного от смежников), то вероятнее всего это означает, что нужная библиотека не была передана вместе с документом. В этом случае рекомендуется поступить следующим образом.

1. Отказаться от чтения документа.

2. Запросить у разработчика документа файл, который был указан в диалоге.

3. Полученный файл поместить в подпапку ..\Sys главной папки КОМПАС-3D Viewer.

4. Открыть документ заново.


Диалог настройки упрощенной отрисовки

Этот диалог появляется на экране после вызова команды Сервис — Параметры — Система — Графический редактор — Упрощенная отрисовка.

Позволяет определить параметры для упрощенного изображения объектов на экране. Такая упрощенная отрисовка применяется в тех случаях, когда текущий масштаб изображения становится слишком мелким для детального показа документа.

Описание элементов управления
Элемент | Описание
Минимальная высота строки текста, отображаемая на экране, мм | Задайте минимальную высоту символов текста (в миллиметрах), при которой они будут отображаться на экране. Если высота текста на экране станет меньше установленного значения, надпись будет отрисовываться габаритным прямоугольником.
Масштаб изображения, при котором все линии отрисовываются как сплошные и не рисуются стрелки | Задайте масштаб изображения, при достижении которого будет выполняться упрощенная прорисовка линий (все линии будут отрисовываться как сплошные и не будут показываться стрелки).
Отрисовывать вместо растровых объектов их габаритные прямоугольники | Включение этой опции означает, что на месте вставленных в графические документы растровых объектов будут отображаться их габаритные прямоугольники.
Отрисовывать вместо OLE-объектов их габаритные прямоугольники | Включение этой опции означает, что на месте вставленных в графические документы ОLE-объектов будут отображаться их габаритные прямоугольники.1
  1. Включение отрисовки габаритных прямоугольников вместо растровых и OLE-объектов позволяет сократить время загрузки документов.

После завершения настройки упрощенной отрисовки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог настройки управления документами

Этот диалог появляется на экране после вызова команды Сервис — Параметры — Система — Файлы — Управление документами.

Позволяет настроить совместную работу системы КОМПАС-3D Viewer и системы документооборота, установленной на компьютере.

Описание элементов управления

Элемент

Описание

Использовать средства PDM для управления документами

Включите эту опцию, если для управления документами должна использоваться какая-либо система PDM.

Включение опции имеет смысл, только если на компьютере установлена система документооборота (например, КОМПАС-Менеджер, PartY+ или DocsOPEN).

Если данная опция выключена, то при открытии документов используются средства операционной системы (стандартный диалог Windows, предназначенный для указания каталога и файла).

Имя службы
для обслуживания доступа к PDM

Выберите из раскрывающегося списка службу управления документами. Элемент управления доступен при включенной опции Использовать средства PDM для управления документами.

Чтобы использовать для управления документами систему КОМПАС-МЕНЕДЖЕР, выберите из списка строку Kompas.OpenSave Provider for CADMan1.

Настроить...

Чтобы указать конкретную систему документооборота, нажмите эту кнопку. На экране появится диалог выбора системы. Названия систем отображаются в диалоге в том виде, в каком они зарегистрированы в Реестре Windows. Например, для указания системы PartY+ требуется выбрать из списка строку LotsiaSoft Party+ DMS (32 bit).
  1. КОМПАС-3D Viewer может работать с системой КОМПАС-МЕНЕДЖЕР версии старше 5.11 R03.
    Чтобы использовать для управления документами одну из систем, поддерживающих ODMA, выберите из списка строку Kompas.ODMA Connection Manager.

После завершения настройки управления документами нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог просмотра расположения системных файлов и папок

Этот диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Файлы — Расположение.

В диалоге отображается таблица, содержащая текущие пути к следующим файлам и папкам:

Элемент | Описание
Файл KViewer.ini | Файл KViewer.ini, содержащий информацию о расположении конфигурационных файлов и системных папок. Файл KViewer.ini используется, если это расположение должно отличаться от умолчательного (сведения об умолчательном расположении этих файлов и папок хранятся внутри системы в виде значений переменных среды КОМПАС-3D Viewer). Кроме указанных сведений, может содержать дополнительную информацию о параметрах работы системы.
Параметры системы | Файл *.cfg, содержащий информацию о настройках системы - о всех настройках, сделанных на вкладке Система общего настроечного диалога.
Параметры рабочего окна | Файл *.dsk, содержащий информацию о настройках рабочего окна системы.
Временные файлы | Папка для размещения временных файлов.
Рабочая папка | Папка для размещения КОМПАС-документов. Эта папка по умолчанию предлагается при первом открытии документа.
Системные файлы | Папка, содержащая служебные файлы: библиотеки оформлений, стилей, файл спецзнаков и т.д.
Файлы библиотек | Папка, содержащая системную библиотеку, необходимую для чтения файлов форматов DXF и DWG.

Если система КОМПАС-3D Viewer была запущена без использования файла KViewer.ini, то в диалоге отображаются умолчательные пути к файлам и папкам (путь к файлу KViewer.ini отсутствует). Чтобы записать файл KViewer.ini, нажмите кнопку Создать KViewer.ini. Файл KViewer.ini, содержащий текущие настройки, будет открыт в приложении, зарегистрированном в Windows для ini-файлов. Если ни одно приложение не зарегистрировано, выберите в появившемся диалоге любой текстовый редактор. Отредактируйте и сохраните файл.

Структура и синтаксис файла KViewer.ini

При запуске системы КОМПАС-3D Viewer поиск файла KViewer.ini ведется только в папке с файлом KViewer.exe, поэтому вновь созданный файл KViewer.ini автоматически располагается в этой папке. Размещение его в другой папке равносильно отсутствию этого файла.

Если в момент запуска системы файл KViewer.ini уже существовал, то в диалоге отображается текущий путь к этому файлу. Чтобы отредактировать файл, нажмите кнопку Редактировать KViewer.ini. Внесите необходимые изменения и сохраните файл.

Вновь созданный или отредактированный файл KViewer.ini будет использован в следующем сеансе работы с КОМПАС-3D Viewer.

Отмена создания или редактирования файла KViewer.ini невозможна. При необходимости удалите (переименуйте) файл на диске или отредактируйте его заново.


Диалог настройки линеек прокрутки

Этот диалог появляется на экране при настройке отображения линеек прокрутки, например, после вызова команды Сервис — Параметры — Система — Текстовый редактор — Линейки прокрутки или Сервис — Параметры — Текущее окно — Линейки прокрутки.

Позволяет установить параметры отображения линеек прокрутки на экране.

Описание элементов управления
Элемент | Описание
Горизонтальная линейка | Включите эту опцию, чтобы горизонтальная линейка прокрутки отображалась на экране.
Вертикальная линейка | Включите эту опцию, чтобы вертикальная линейка прокрутки отображалась на экране.

После завершения настройки линеек прокрутки нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Общий диалог настройки параметров

Позволяет настроить различные параметры системы и/или активного окна.

Он появляется на экране после вызова команды Сервис — Параметры... Если при вызове команды в главном окне системы не было открыто ни одного документа, то диалог настройки содержит одну вкладку — Система. Если же открытые документы имелись, то в диалоге есть также вкладка Текущее окно.

Для изменения какой-либо группы настроек выберите название этой группы из списка в левой части диалога и установите затем нужные значения параметров в правой части окна диалога.

Чтобы развернуть содержание какого-либо раздела, установите курсор на значке <+> рядом с заголовком раздела и щелкните левой кнопкой мыши. Повторный щелчок на этом символе (после разворачивания раздела он отображается как <->) приведет к сворачиванию содержания раздела.

После завершения настроек нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог указания текущего описания спецификации

Это диалог появляется на экране при открытии спецификации, если стиль, используемый в ней, не найден в библиотеке стилей спецификаций (*.lyt), либо если не найдена сама библиотека стилей.

Если диалог указания текущего описания спецификации появляется при открытии спецификации, созданной на другом рабочем месте (например, полученной от смежников), то это означает, что при создании спецификации использовался файл *.lyt, отличный от имеющегося на вашем рабочем месте. В этом случае рекомендуется поступить следующим образом.

1. Закрыть диалог указания текущего описания спецификации кнопкой Отмена.

2. Запросить у разработчика спецификации файл *.lyt, который был указан в диалоге.

3. Полученный файл поместить в подпапку ..\Sys главной папки КОМПАС-3D Viewer.

4. Открыть спецификацию заново.

Описание элементов управления диалога

Элемент

Описание

Библиотека стилей спецификаций

В этой строке отображается полное имя библиотеки стилей спецификаций, подключенной к открываемой спецификации.

Если список Стиль доступен, это означает, что библиотека найдена по пути, указанному в строке Библиотека стилей спецификаций, но в ней отсутствует нужный стиль.

Если список недоступен, это означает, что потеряна сама библиотека. В таком случае необходимо сначала указать библиотеку, воспользовавшись кнопкой Обзор..., а затем указать стиль из этой библиотеки.

Обзор...

Позволяет подключить к открываемой спецификации другую библиотеку стилей. После нажатия этой кнопки на экране появляется стандартный диалог открытия файлов. Выберите в нем нужный файл *.lyt.

Стиль

Выберите название из списка стилей спецификаций, имеющихся в подключенной библиотеке стилей1.
  1. При выборе стиля для спецификации, подключенной к графическому документу или к сборке, помните, что все спецификации, подключенные к одному документу, должны иметь разный стиль.

Выбрав стиль спецификации, нажмите кнопку ОК. Чтобы отказаться от открытия спецификации, нажмите кнопку Отмена.


Диалог настройки системных стилей линий

Этот диалог появляется на экране после вызова команды Сервис — Параметры — Система — Графический редактор — Системные линии.

Позволяет задать цвет, толщину на экране, толщину на бумаге системных (стандартно поддерживаемых КОМПАС-3D Viewer) стилей линий.

Описание элементов управления

Элемент

Описание

Толщина

Группа элементов управления, позволяющая установить толщину отрисовки для основных, тонких и утолщенных линий.

Чтобы задать толщину, с которой линии будут отображаться, введите или выберите нужное количество пискселей в поле На экране.

Чтобы задать толщину, с которой линии будут выводиться на печать, введите нужное нужно значение (в миллиметрах) в поле На бумаге.

Список линий

Список, содержащий все системные линии КОМПАС. Он представлен в виде таблицы из трех колонок: Цвет, Изображение, Наименование.

Чтобы изменить цвет линии, щелкните мышью на нужной строке таблицы. Затем нажмите кнопку с черным треугольником, появившуюся в ячейке Цвет. Выбранный цвет будет использоваться как для отображения, так и для печати линий соответствующих стилей.

При изменении цвета, а также толщины отображения линии изменяется ее отрисовка в ячейке Изображение.

Наименование линий редактировать нельзя.

После завершения настройки стилей линий нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог настройки системных стилей символов

Этот диалог появляется на экране после вызова команды Сервис — Параметры — Система — Графический редактор — Системные символы.

Позволяет установить цвет отрисовки системных (стандартно поддерживаемых КОМПАС-3D Viewer) стилей символов.

Чтобы выбрать цвет символа, нажмите кнопку с его названием. Откроется стандартный диалог выбора цвета.

Внешний вид символов показывается в окнах просмотра, что позволяет оценить сделанные изменения.

После завершения настройки цветов символов нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог настройки интерфейса

Этот диалог появляется на экране после вызова команды Сервис — Настройка интерфейса

Позволяет настроить интерфейс системы КОМПАС-3D Viewer. Элементы управления для задания параметров интерфейса расположены на вкладках диалога.

Вкладка Клавиатура

Вкладка Меню

Вкладка Параметры

Вкладка Команды

Вкладка Панели инструментов

Вследствие ограничений, накладываемых использованием операционных систем Windows 98 и Windows ME, часть функций настройки интерфейса КОМПАС-3D Viewer для этих ОС недоступны. Вы не можете изменять состав команд в Главном меню программы.

Для операционных систем, которые базируются на технологии NT (Windows 2000, XP), таких ограничений нет.


Диалог выбора ориентации модели

Этот диалог появляется на экране после вызова команды Ориентация.

В нем можно изменить текущую ориентацию модели на стандартную или пользовательскую ориентацию из списка или сохранить текущую ориентацию в списке.

Описание элементов управления
Элемент | Описание
Список названий ориентаций | В этом списке перечислены названия ориентаций, существующих в текущей модели.
Добавить | Если требуется сохранить текущую ориентацию, нажмите эту кнопку и в появившемся диалоге введите имя новой ориентации1.
Удалить | Если требуется удалить какую-либо пользовательскую ориентацию из списка, выберите ее имя и нажмите эту кнопку.
Установить | Если требуется установить какую-либо ориентацию из списка в качестве текущей, выберите ее имя и нажмите эту кнопку.
  1. Так как запись документов в КОМПАС-3D Viewer невозможна, сформированный пользователем список ориентаций сохраняется только до закрытия просматриваемой модели. При повторном ее открытии восстанавливается прежний перечень ориентаций.

Для закрытия диалога нажмите кнопку Выход.


Диалог ввода нового имени ориентации модели

Введите в поле этого диалога имя, под которым требуется запомнить текущую ориентацию модели. Это имя будет отображаться в списке ориентаций.

После ввода нового имени нажмите кнопку OK диалога.

Для выхода из диалога без создания новой ориентации нажмите кнопку Отмена.


Диалог настройки цвета фона для моделей

Этот диалог появляется на экране после вызова команды Сервис — Параметры — Система — Экран — Фон рабочего поля моделей.

Позволяет выбрать цвета для фона рабочего поля при полутоновом отображении и фона при остальных типах отображения модели.

Описание элементов управления
Элемент | Описание
Цвет окна, установленный в Windows | Чтобы цвет фона соответствовал общим цветовым настройкам Windows, включите эту опцию. Чтобы выбрать цвет фона рабочего поля (при любом типе отображения модели кроме полутонового), который будет отличаться от цветовых настроек Windows, выключите опцию.
Цвет | Чтобы выбрать цвет фона, нажмите эту кнопку. Откроется стандартный диалог выбора цвета. Элемент управления доступен при выключенной опции Цвет окна, установленный в Windows.
Использовать градиентный переход | Чтобы использовать градиентный переход, включите эту опцию. При работе с трехмерными моделями верхняя и нижняя части поля документа будут окрашены в выбранные цвета. Между ними будет плавный переход от одного цвета к другому.
Верхний цвет перехода Нижний цвет перехода | Окна просмотра цветов, между которыми будет сформирован градиентный переход. Чтобы выбрать эти цвета, нажмите соответствующие кнопки Цвет.

После завершения настройки цветов фона для моделей нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог настройки цвета рабочего поля

Этот диалог появляется на экране после вызова команды Сервис — Параметры — Система — Экран — Фон рабочего поля.

Позволяет выбрать нужные цвета для фона рабочего поля графических, текстовых документов и спецификаций.

Описание элементов управления
Элемент | Описание
Цвет окна, установленный в Windows | Чтобы цвет фона соответствовал общим цветовым настройкам Windows, включите эту опцию. Чтобы выбрать цвет фона рабочего поля, который будет отличаться от цветовых настроек Windows, выключите опцию.

После завершения настройки цвета рабочего поля нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог информации о документе

Этот диалог появляется на экране после вызова команды Файл — Свойства....

Позволяет просмотреть и отредактировать справочную информацию, хранящуюся вместе с документом.

Вкладка Общие сведения

Вкладка Внешние ссылки

Чтобы закрыть диалог, нажмите кнопку ОК.


Габаритный параллелепипед

Габаритный параллелепипед —условный параллелепипед, грани которого параллельны координатным плоскостям и проходят через наиболее удаленные друг от друга точки объектов модели.

Пользователь может выбрать типы объектов, которые будут учитываться при построении габаритного праллелепипеда.


Команда О программе...

Позволяет вывести на экран информацию о версии установленной на вашем компьютере копии системы КОМПАС-3D Viewer.


Команда Выход

Позволяет завершить сеанс работы КОМПАС — 3D Viewer.

Для вызова команды выберите ее название из меню Файл.


Команда Закрыть

Позволяет закрыть активный документ.

Для вызова команды выберите ее название из меню Файл.

Если документ был открыт в нескольких окнах, то закрываются все его окна.

Быстро закрыть активный документ можно с помощью двойного нажатия кнопки управляющего меню документа, которая находится в верхнем левом углу его окна.

Для быстрого закрытия всех документов и завершения сеанса работы с КОМПАС — 3D Viewer вызовите команду Файл — Выход.


Команда 1, 2, 3 ...

В нижней части страницы меню Файл отображается список документов, с которыми велась работа ранее. Фактически это перечень документов в той последовательности, в которой они закрывались.

Чтобы открыть один из документов, выберите его имя из списка.


Команда Открыть

Позволяет загрузить документ для просмотра.

Для вызова команды выберите ее название из меню Файл или нажмите кнопку Открыть на Стандартной панели.

После этого на экране появится диалог выбора файла.

В том случае, если вы недавно работали с документом, а затем закрыли его, повторное открытие можно выполнить более быстрым способом. В нижней части меню Файл отображается список последних девяти документов, с которыми велась работа. Фактически это перечень документов в той последовательности, в которой они закрывались. Чтобы открыть нужный документ, просто выберите его имя в меню.

Если вы попытаетесь открыть уже загруженный документ, КОМПАС-3D Viewer не выполнит повторное открытие, а просто активизирует окно этого документа.


Команда Печать...

При работе в обычном режиме КОМПАС — 3D Viewer команда Печать... доступна только для текстовых документов и спецификаций.

Для вызова команды выберите ее название из меню Файл или нажмите кнопку Печать на Стандартной панели.

На экране появится диалог, в котором можно настроить параметры вывода документа: устройство вывода (или файл, в который требуется вывести документ), масштаб вывода, диапазон печати, количество копий и др.

После установки всех параметров нажмите кнопку ОК для начала печати. Чтобы выйти из диалога без вывода документа на печать, нажмите кнопку Отмена.

При работе в режиме предварительного просмотра команда Печать доступна всегда. Она позволяет начать вывод текущего документа (документов) на печатающее устройство.

Для вызова команды выберите ее название из меню Файл или нажмите кнопку Печать на Панели управления печатью.


Команда Предварительный просмотр

Позв ооляет перейти в режим предварительного просмотра и печати документов.

Для вызова команды выберите ее название из меню Файл или нажмите кнопку Предварительный просмотр на Стандартной панели.

Для получения информации о том, как подключить принтер или плоттер, обратитесь к документации по Windows и имеющемуся у вас устройству вывода.


Команда Настройка плоттера/принтера

Позволяет настроить параметры плоттера или принтера, на котором будут печататься документы.

После вызова команды на экране появляется системный диалог настройки печати.

Описание элементов управления
Элемент | Описание
Имя | Показывает имя устройства, установленного как принтер по умолчанию. Вы можете выбрать из списка другое устройство вывода.
Ориентация | Позволяет выбрать ориентацию листов бумаги: книжная (вертикальная) или альбомная (горизонтальная).
Бумага | Позволяет задать параметры бумаги (размер и способ подачи), из числа поддерживаемых выбранным принтером.
Свойства | Кнопка, позволяющая изменить параметры текущего устройства. После ее нажатия на экране появится системный диалог драйвера принтера, в котором можно настроить различные параметров печати (градации оттенков, интенсивность и т.д.). Набор настраиваемых опций зависит от типа принтера или плоттера.

После завершения настройки печати нажмите кнопку ОК диалога. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Команда Содержание

Позволяет вывести на экран раздел с содержанием оперативной Справочной системы.

Смотрите также


Список окон открытых документов

В этом списке отображаются названия открытых в данный момент документов. Название активного документа отмечено в этом списке «галочкой». Щелчок мышью на названии любого документа в списке делает этот документ активным.


Закладки внизу

Позволяет разместить закладки документов под окном текущего документа.

Для вызова команды выберите ее название из контекстного меню закладки.


Закладки вверху

Позволяет разместить закладки документов над окном текущего документа.

Для вызова команды выберите ее название из контекстного меню закладки.


Способ вывода

Переключатели группы Способ вывода позволяют выбрать режим печати документа.

Активизируйте переключатель Вывести текущий документ полностью, чтобы вывести на печать документ целиком.

Активизируйте переключатель Вывести часть текущего документа, чтобы вывести на печать область документа, ограниченную прямоугольной рамкой.

Размер рамки настраивается в диалоге, вызываемом переключателем Указать часть на Панели свойств.


Документ

В окне предварительного просмотра отображаются все документы, выбранные для печати. Выберите из раскрывающегося списка документ, чтобы сделать его текущим.


Текущий масштаб печати

В этом поле отображается значение масштаба, с которым текущий документ будет выведен на печать.

Вы можете изменить масштаб, набрав вручную нужное значение. Чтобы поле ввода стало доступным, подведите к нему курсор и щелкните левой кнопкой мыши.

Можно также выбрать значение шага из списка. Чтобы открыть список, щелкните на клавише со стрелкой рядом с полем ввода.


Указать часть

Переключатель, позволяющий указать, какую часть текущего документа требуется вывести. После активизации этого переключателя на экране появляется диалог, в котором можно задать размеры прямоугольной области документа, которая будет напечатана.

В дальнейшем вы можете управлять способом печати текущего документа с помощью переключателей группы Способ вывода на Панели свойств. Активизация переключателя Вывести часть текущего документа отображает на поле вывода область документа, ограниченную рамкой, активизация переключателя Вывести текущий документ полностью - весь документ целиком.


Коор дината X

В этом поле отображается значение координаты X базовой точки текущего документа (левой нижней точки его габаритного прямоугольника).

Вы можете изменить значение координаты (переместить документ), набрав вручную нужное число. Чтобы поле ввода стало доступным, подведите к нему курсор и щелкните левой кнопкой мыши.


Координата Y

В этом поле отображается значение координаты Y базовой точки текущего документа (левой нижней точки его габаритного прямоугольника).

Вы можете изменить значение координаты (переместить документ), набрав вручную нужное число. Чтобы поле ввода стало доступным, подведите к нему курсор и щелкните левой кнопкой мыши.


Команда Закрыть(Системное меню)

Команда Закрыть
(Системное меню)

Закрывает окно, из системного меню которого команда была вызвана.

Закрытие Главного окна системы эквивалентно выходу из нее. Закрыть Главное окно можно также при помощи комбинации клавиш <Alt>+<F4>.

Закрытие единственного окна документа эквивалентно закрытию этого документа. Закрыть активное окно документа можно также при помощи комбинации клавиш <Ctrl>+<F4>.

Для закрытия окна можно нажать системную кнопку Закрыть в его правом верхнем углу.

Если перед выходом из системы или закрытием документа не были сохранены внесенные в него изменения, будет выдан запрос на их сохранение.


Команда Переместить(Системное меню)

Команда Переместить
(Системное меню)

Эта команда доступна в Главном окне системы, если оно занимает часть экрана, и в окне документа, если оно занимает часть Главного окна. Она позволяет изменить положение окна на экране.

После вызова команды курсор превращается в четырехстороннюю стрелку. Подведите его к заголовку окна, нажмите левую кнопку мыши и перемещайте окно, не отпуская кнопку мыши. Когда нужное положение окна будет достигнуто, отпустите кнопку.

Переместить окно можно и без вызова команды. Для этого в любом режиме работы подведите курсор к заголовку окна, зафиксируйте на нем и перемещайте окно, как описано выше.

Такой способ изменения положения окна называется перетаскиванием окна за заголовок.

Для изменения размеров окна пользуйтесь командой Размер из системного меню.


Команда Следующее

Эта команда доступна в системном меню окна документа, если это окно — не единственное в Главном окне системы.

Команда активизирует следующее в списке открытых окон окно документа.

Переключиться на следующее окно (активизировать его) можно также при помощи комбинаций клавиш <Ctrl>+<F6> или <Ctrl>+<Tab>.


Команда Восстановить(Системное меню)

Команда Восстановить
(Системное меню)

Эта команда доступна в Главном окне системы, если оно развернуто на весь экран, и в окне документа, если оно развернуто на все окно системы (то есть если окно максимизировано).

После вызова команды размер окна изменяется: оно занимает часть экрана, а его габариты и положение на экране соответствуют габаритам и положению, которые были установлены перед тем, как окно было развернуто на весь экран (то есть восстанавливается прежний размер окна).

Для восстановления размеров окна можно также нажать системную кнопку Восстановить в правом верхнем углу окна.

После вызова команды на месте кнопки Восстановить возникает кнопка Развернуть, которая вызывает противоположное действие — команду разворачивания окна на весь экран.

Для изменения размеров окна пользуйтесь командой Размер из системного меню.


Команда Свернуть(Системное меню)

Команда Свернуть
(Системное меню)

Эта команда сворачивает окно до пиктограммы (минимизирует окно). Если она была вызвана в Главном окне системы, то пиктограмма помещается на Панель задач Windows. Пиктограмма свернутого окна документа помещается в нижнюю часть Главного окна системы.

Для сворачивания окна можно также нажать системную кнопку Свернуть в правом верхнем углу окна.

Для восстановления размера окна или его максимизации (разворачивания на весь экран) пользуйтесь командами Восстановить и Развернуть из системного меню.


Команда Размер(Системное меню)

Команда Размер
(Системное меню)

Эта команда доступна в Главном окне системы, если оно занимает часть экрана, и в окне документа, если оно занимает часть Главного окна. Она позволяет изменить размеры окна.

После вызова команды курсор превращается в четырехстороннюю стрелку. Подведите его к границе или углу окна. Курсор превратится в двустороннюю стрелку, указывающую направление, в котором можно переместить границу окна. Нажмите левую кнопку мыши и перемещайте границу или угол окна, не отпуская кнопку мыши. Когда нужный размер окна будет достигнут, отпустите кнопку.

Изменить размер окна можно и без вызова команды. Для этого в любом режиме работы подведите курсор к границе или углу окна, зафиксируйте на нем и изменяйте размер окна, как описано выше.

Такой способ изменения размера окна называется перетаскиванием границ окна.

Для изменения положения окна пользуйтесь командой Переместить из системного меню.


Команда Развернуть(Системное меню)

Команда Развернуть
(Системное меню)

Эта команда доступна в Главном окне системы, если оно не развернуто на весь экран, и в окне документа, если оно не развернуто на все окно системы.

После вызова команды Главное окно системы разворачивается на весь экран, а окно документа разворачивается на все Главное окно системы.

Для разворачивания (максимизации) окна можно также нажать системную кнопку Развернуть в правом верхнем углу окна.

После вызова команды на месте кнопки Развернуть возникает кнопка Восстановить, которая вызывает противоположное действие — команду восстановления прежнего размера и положения окна.

Для изменения размеров окна пользуйтесь командой Размер из системного меню.


Команда Строка сообщений

Позволяет включить или отключить показ Строки сообщений — строки в нижней части главного окна КОМПАС — 3D Viewer, где выводятся сообщения системы, относящиеся к выполнению текущей команды или к тому элементу рабочего окна, на который указывает курсор.


Команда Упорядочить значки

Позволяет разместить значки свернутых (минимизированных) окон документов в одну или несколько строк в нижней части главного окна КОМПАС-3D Viewer.

Для вызова команды выберите ее название из меню Окно.


Команда Каскад

Позволяет разместить открытые окна документов таким образом, чтобы они последовательно перекрывали друг друга, а заголовок каждого окна оставался видимым.

Для вызова команды выберите ее название из меню Окно.


Команда Новое окно документа

Позволяет открыть дополнительное окно активного документа.

Для вызова команды выберите ее название из меню Окно. Команда доступна, если активен графический документ или документ — модель.

Если для этого документа уже открыто несколько окон и какое-либо из них минимизировано (свернуто до пиктограммы), то новое дополнительное окно также создается в минимизированном виде.

Количество дополнительных окон, которые можно открыть для документа, не ограничено.


Команда Мозаика горизонтально

Позволяет горизонтально разместить открытые окна всех документов таким образом, чтобы они прилегали друг к другу и все были видимыми.

Для вызова команды выберите ее название из меню Окно.

Чтобы разместить мозаикой только окна активного документа, используйте команду Мозаика для текущего документа.


Команда Мозаика вертикально

Позволяет вертикально разместить открытые окна всех документов таким образом, чтобы они прилегали друг к другу и все были видимыми.

Для вызова команды выберите ее название из меню Окно.

Чтобы разместить мозаикой только окна активного документа, используйте команду Мозаика для текущего документа.


Диалог выбора варианта добавления листов документов

Диалог позволяет выбрать вариант загрузки листов документов в предварительный просмотр.

Появляется на экране после вызова команд Файл — Добавить документ... и Файл — Загрузить задание на печать... в режиме предварительного просмотра.

Описание элементов управления

Наименование

Описание

Добавить к имеющимся листам

Нажмите эту кнопку, чтобы добавить листы загружаемых документов к листам документов, открытых для просмотра. При этом листы загружаемых документов будут расположены после листов документов, открытых для просмотра.

В случае выбора этого варианта при загрузке задания на печать игнорируется сохраненный в задании признак печатаемости страниц устройства вывода, установленный при помощи команды Включить/выключить печать страниц.

Заменить имеющиеся листы

Нажмите эту кнопку, чтобы заменить листы документов, открытых для просмотра, листами загружаемых документов.

Отмена

Нажмите эту кнопку, чтобы отказаться от загрузки листов документов.


Диалог настройки отрисовки стрелок и засечек размеров

Этот диалог появляется на экране после вызова команды настройки отрисовки стрелок и засечек размеров для графических документов и моделей. Например, Сервис — Параметры — Текущий чертеж — Размеры — Стрелки и засечки.

Позволяет настроить параметры отображения и печати стрелок и засечек.

Описание элементов управления

Элемент

Описание

Стрелки размерных линий

Чтобы стрелки размерных линий зачернялись, включите опцию Зачернять.
Изменение состояния опции отражается на примере стрелки.

Настройка зачернения распространяется на следующие объекты:

– все размеры со стрелками следующих видов: «Стрелка», «Стрелка закрытая», «Точка», «Точка маленькая»;

– обозначения допусков формы;

– стрелки направления взгляда;

– обозначения шероховатости на полке.

После завершения настройки отрисовки стрелок нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Предупреждение о большом количестве блоков

Это предупреждение появляется в случае, если импортируемый документ формата DXF или DWG содержит большое количество блоков — составных объектов этого формата.

По умолчанию элементы, составляющие блоки, после импорта автоматически объединяются в макрообъекты.

Если количество блоков велико, импортирование документа может занять значительное время. Вы можете отказаться от создания макрообъектов, что ускорит чтение. Для этого нажмите кнопку Да. Все элементы, из которых состоят блоки, будут прочитаны, но макрообъекты из этих элементов созданы не будут.

Если объединение элементов, составляющих блоки, в макрообъекты обязательно, нажмите кнопку Нет.


Диалог настройки соответствия стилей линий

Появляется на экране после нажатия кнопки Добавить или Изменить в диалоге задания параметров чтения DXF/DWG.

Позволяет установить соответствие между типами линий AutoCAD и стилями линий КОМПАС для замены линий системы AutoCAD линиями КОМПАС при импорте файлов форматов DWG и DXF.

Описание элементов управления

Элемент

Описание

Параметры линии AutoCAD

В этой группе опций вы можете задать параметры линии в AutoCAD.

Цвет

Установите в этом поле номер цвета линии в AutoCAD. Цвет, имеющий указанный номер, показывается в окне просмотра. Для указания цвета линии можно использовать диалог выбора цвета. Для его вызова щелкните левой кнопкой мыши в окне просмотра цвета.

Тип

Введите в это поле название типа линии в AutoCAD.

Толщина

Если эта опция выключена, то все имеющиеся в импортируемом документе AutoCAD линии указанного цвета и типа вне зависимости от их толщины будут заменены линиями КОМПАС выбранного стиля.

Включите опцию Толщина, если при замене линий AutoCAD должна учитываться их толщина, и введите значение толщины линии в миллиметрах.

В этом случае линиями КОМПАС выбранного стиля будут заменены только те линии AutoCAD указанного цвета и типа, которые имеют заданную толщину. При этом для линий с теми же цветом и типом, но с другой толщиной (если таковые имеются в импортируемом документе) будут созданы соответствующие пользовательские стили линий.

Стиль линии КОМПАС

Выберите из этого списка системный стиль для линий, которыми будут заменены линии документа AutoCAD, имеющие указанные параметры.

Кнопка >>

Нажмите эту кнопку, чтобы выбрать библиотечный стиль для линий, которыми будут заменены линии документа AutoCAD, имеющие указанные параметры.
После нажатия кнопки на экране появится диалог выбора стиля линии. Нажмите в нем кнопку Библиотеку... и укажите в появившемся диалоге нужный файл библиотеки стилей линий (*.lcs). Список стилей линий, хранящихся в выбранной библиотеке, появится на вкладке Библиотека диалога выбора стиля линии. Укажите нужный стиль и нажмите кнопку Выбрать. Диалог выбора стиля линии закроется, а в поле Стиль линии КОМПАС диалога настройки соответствия стилей появится выбранный библиотечный стиль.

ОК

После завершения настройки соответствия типа и стиля линии нажмите кнопку.

Отмена

Для выхода из диалога без изменения соответствия нажмите кнопку.


Диалог параметров чтения DXF и DWG

Диалог параметров чтения
DXF и DWG

Диалог появляется на экране при импорте файлов формата DXF или DWG.

Позволяет задать различные параметры импорта.

В результате импорта формируется временный КОМПАС-фрагмент, который отображается в новом окне КОМПАС-3D Viewer.

Описание элементов управления

Элемент

Описание

Вкладка Свойства

Масштаб

Выберите из списка или введите значение коэффициента масштабирования графических объектов. Эта настройка обычно требуется для преодоления ограничения КОМПАС-фрагментов на максимальную длину объектов при импорте изображений крупных объектов, выполненных в натуральную величину.

Единицы измерения

Выберите нужные единицы измерения для импортируемых объектов (миллиметры или дюймы).

Читать данные из пространства модели

Включите эту опцию, если в результирующий документ требуется передать только графическое изображение, существующее в пространстве модели AutoCAD.

Если данная опция выключена, то в документ КОМПАС передаются объекты из пространства листа.

Приводить тексты к системным

Включите эту опцию, чтобы тексты из импортируемого файла имели параметры, использующиеся в КОМПАС-фрагментах по умолчанию для соответствующих надписей (текст на чертеже, текст над/под полкой линии выноски и т.д.).

При выключенной опции для каждого стиля текста, имеющегося в файле DXF/DWG, внутри КОМПАС-фрагмента создается специальный пользовательский стиль текста.

Конвертировать текст из OEM в ANSI

Включите эту опцию, если при импорте необходимо выполнить перекодирование текстов из DOS-кодировки в Windows-кодировку. Конвертация обычно требуется, если исходный документ создан в версии AutoCAD для DOS.

Конвертировать тексты из OEM в ANSI можно также с помощью файла convtxt.tfn. Включение опции Конвертировать текст из OEM в ANSI приводит к преобразованию всех текстов, имеющихся в импортируемом документе, а в файле convtxt.tfn можно указать конкретные шрифты — и перекодированы будут только те тексты, которые набраны этими шрифтами.

Не следует использовать файл convtxt.tfn и опцию Конвертировать текст из OEM в ANSI одновременно. В результате этого произойдет двойное перекодирование и тексты будут искажены.

Сужение текста

Эта опция позволяет задавать отношение ширины получившихся при импорте текстов к их ширине в исходном документе с целью подгонки ширины надписей к конкретным габаритам. Например, если при импорте документа, содержащего таблицу, тексты «вылезли» за пределы отведенных для них ячеек, произведите импорт вновь, увеличив значение коэффициента сужения.

Коэффициент высоты текстов

Эта опция позволяет задавать отношение высоты получившихся при импорте текстов к их высоте в исходном документе с целью подгонки высоты надписей к конкретным габаритам.

Таблица чтения некоторых объектов оформления

Эта таблица позволяет настроить чтение линий-выносок, штриховок, допусков формы и размеров, записанных в файле DXF/DWG.

В колонке AutoCAD перечислены объекты, чтение которых можно настроить, а в колонке КОМПАС — варианты объектов, которые можно получить в результате чтения. Чтобы выбрать вариант, щелкните в ячейке колонки КОМПАС, разверните список и укажите нужную строку. Доступны следующие варианты.

– Обычный — объект AutoCAD преобразуется в аналогичный объект КОМПАС. Для выбора этого варианта укажите объект КОМПАС, соответствующий объекту AutoCAD. Например, для линии-выноски AutoCAD выберите линию-выноску КОМПАС.

– Макроэлемент — объект AutoCAD преобразуется в макроэлемент КОМПАС, состоящий из графических объектов (отрезков, точек и текстов). При этом теряется информация о типе объекта, т.е. макроэлементы лишь «имитируют» соответствующие объекты оформления.

Размеры хранятся в файле DXF/DWG в двух видах: в виде размерной структуры (координаты линий выносок, размерной линии, текста и т.д.) и в виде блока изображения размера (набор отрезков, заливок, точек и текстов). Поэтому для объекта «размер» доступен еще один вариант чтения — комбинированный объект. При его выборе графические примитивы, из которых состоят размеры, будут считаны из размерных структур файла DXF/DWG, а тексты — из блоков изображений размеров. Тип объекта — «размер» — сохраняется.

Вкладка Символы

Вы можете интерактивно редактировать соответствие между спецсимволами КОМПАС и последовательностями символов ASCII, которыми они обозначаются в текстовом файле DXF.По умолчанию загружается последовательность символов, которая соответствует поставляемому в составе дистрибутива КОМПАС-3D файлу B_ESKD.SHX.

Выбрать файл

Для подключения ранее сохраненного файла соответствия символов (системный файл КОМПАС с расширением *.ACS) нажмите эту кнопку.

Записать в файл

Для сохранения сделанной настройки соответствия символов в файле нажмите эту кнопку.

Символы по умолчанию

Для загрузки настройки соответствия символов по умолчанию нажмите эту кнопку.

Вкладка Типы линий

По умолчанию при импорте файлов DXF в КОМПАС-фрагменте создаются пользовательские стили линий, имеющие такие же названия и начертания, как и типы линий системы AutoCAD.

Установить соответствие типов линий

Чтобы при импорте происходила замена линий системы AutoCAD системными или библиотечными линиями КОМПАС, необходимо задать соответствия между типами линий в AutoCAD и стилями линий в КОМПАС-3D. Для этого включите данную опцию. После включения опции становятся доступными остальные опции и кнопки вкладки.

В окне просмотра отображаются уже имеющиеся соответствия между типами и стилями линий: в колонке AutoCAD отображаются цвет, название типа линии и ее толщина в AutoCAD, а в колонке КОМПАС — название стиля линии в КОМПАС.

Добавить

Чтобы добавить соответствие, нажмите эту кнопку. В появившемся на экране диалоге настройки соответствия введите название типа линии AutoCAD, ее цвет и толщину, введите и установите стиль линии КОМПАС. Закройте диалог, нажав кнопку ОК. В конец списка будет добавлено установленное вами соответствие.

Изменить

Чтобы отредактировать соответствие, выберите его в окне просмотра и нажмите эту кнопку.

Отредактируйте соответствие в появившемся на экране диалоге и нажмите кнопку ОК. Внесенное вами изменение отобразится в списке соответствий.

Удалить

Чтобы удалить соответствие, выберите его в окне просмотра и нажмите эту кнопку.

Прочитать из чертежа AutoCAD

Эта кнопка позволяет отобразить в окне просмотра названия типов линий, используемых в выбранном для чтения чертеже AutoCAD, цвета и толщины этих линий.

В строках, соответствующих типам линий, которые используются в объектах с толщиной линий «default», значение толщины отсутствует.

Для установки стилей линий КОМПАС, которые должны соответствовать обнаруженным типам линий, используйте кнопку Изменить.

Записать в файл

Для сохранения сделанной настройки соответствий в файле нажмите эту кнопку. В появившемся диалоге укажите имя файла для записи. Система сформирует текстовый файл соответствия типов и стилей линий ( *.ALS).

Выбрать файл

Для подключения созданного или ранее сохраненного файла соответствия типов и стилей линий нажмите эту кнопку.

Вы можете создать файл соответствия типов и стилей линий в текстовом режиме и подключать его при импорте файлов DXF.

Типы линий
по умолчанию

Для загрузки настройки соответствия типов и стилей линий по умолчанию нажмите эту кнопку.

Вкладка Полилиния

Данная вкладка позволяет настроить импорт полилиний, для сегментов которых заданы индивидуальные толщины линий. Если установлена постоянная толщина линии, то сегмент имеет форму прямоугольника, если переменная — то трапеции.

Вы можете указать, в какие системные объекты КОМПАС нужно преобразовать эти сегменты.

в линию

Сегменты, образующие полилинию, объединяются в контур.

в заливку

Сегмент преобразуется в заливку. Форма контура заливки соответствует форме сегмента в файле формата DXF/DWG. Цвет заливки также соответствует заданному в этом файле.

Контур, ограничивающий заливку, не строится.

в штриховку

Сегмент преобразуется в штриховку. Форма контура и цвет штриховки соответствуют форме и цвету сегмента в файле формата DXF/DWG.

Контур, ограничивающий штриховку, не строится.

При выборе данного варианта становится доступным раскрывающийся список Шаг штриховки. Вы можете выбрать или ввести с клавиатуры нужное значение шага.

Чтение линий с толщиной «default»

После завершения настройки параметров нажмите кнопку Начать чтение. Для выхода из диалога без чтения файла нажмите кнопку Отмена.

Иногда в процессе чтения возможно возникновение сообщения о наличии в импортируемом файле критической ошибки. Это означает, что в файле отсутствует часть данных, необходимых для корректного чтения.

Сообщение содержит также запрос на восстановление файла.

– Нажмите кнопку ОК, чтобы подтвердить восстановление. Система прочтет файл снова, дополняя его данными по умолчанию. В результате файл импортируется корректно, но не исключена вероятность искажения имеющейся в нем информации.

– Нажмите кнопку Отмена, чтобы отказаться от чтения файла с ошибкой.

Смотрите также


Диалог параметров чтения группы файлов DXF и DWG

Диалог параметров чтения
группы файлов DXF и DWG

Диалог появляется на экране при пакетном (групповом) импорте файлов формата DXF или DWG.

Позволяет задать параметры импорта.

В результате импорта формируются временные КОМПАС-фрагменты, которые отображаются в новых окнах КОМПАС-3D Viewer.

Описание элементов управления

Элемент

Описание

Вкладка Свойства

Масштаб

Выберите из списка или введите значение коэффициента масштабирования графических объектов. Эта настройка обычно требуется для преодоления ограничения КОМПАС-фрагментов на максимальную длину объектов при импорте изображений крупных объектов, выполненных в натуральную величину.

Единицы измерения

Выберите нужные единицы измерения для импортируемых объектов (миллиметры или дюймы).

Читать данные из пространства модели

Включите эту опцию, если в результирующий документ требуется передать только графическое изображение, существующее в пространстве модели AutoCAD.

Если данная опция выключена, то в документ КОМПАС передаются объекты из пространства листа.

Приводить тексты к системным

Включите эту опцию, чтобы тексты из импортируемого файла имели параметры, использующиеся в КОМПАС-фрагментах по умолчанию для соответствующих надписей (текст на чертеже, текст над/под полкой линии выноски и т.д.).

При выключенной опции для каждого стиля текста, имеющегося в файле DXF/DWG, внутри КОМПАС-фрагмента создается специальный пользовательский стиль текста.

Конвертировать текст из OEM в ANSI

Включите эту опцию, если при импорте необходимо выполнить перекодирование текстов из DOS-кодировки в Windows-кодировку. Конвертация обычно требуется, если исходный документ создан в версии AutoCAD для DOS.

Конвертировать тексты из OEM в ANSI можно также с помощью файла convtxt.tfn. Включение опции Конвертировать текст из OEM в ANSI приводит к преобразованию всех текстов, имеющихся в импортируемом документе, а в файле convtxt.tfn можно указать конкретные шрифты — и перекодированы будут только те тексты, которые набраны этими шрифтами.

Не следует использовать файл convtxt.tfn и опцию Конвертировать текст из OEM в ANSI одновременно. В результате этого произойдет двойное перекодирование и тексты будут искажены.

Сужение текста

Эта опция позволяет задавать отношение ширины получившихся при импорте текстов к их ширине в исходном документе с целью подгонки ширины надписей к конкретным габаритам. Например, если при импорте документа, содержащего таблицу, тексты «вылезли» за пределы отведенных для них ячеек, произведите импорт вновь, увеличив значение коэффициента сужения.

Коэффициент высоты текстов

Эта опция позволяет задавать отношение высоты получившихся при импорте текстов к их высоте в исходном документе с целью подгонки высоты надписей к конкретным габаритам.

Таблица чтения некоторых объектов оформления

Эта таблица позволяет настроить чтение линий-выносок, штриховок, допусков формы и размеров, записанных в файле DXF/DWG.

В колонке AutoCAD перечислены объекты, чтение которых можно настроить, а в колонке КОМПАС — варианты объектов, которые можно получить в результате чтения. Чтобы выбрать вариант, щелкните в ячейке колонки КОМПАС, разверните список и укажите нужную строку. Доступны следующие варианты.

– Обычный — объект AutoCAD преобразуется в аналогичный объект КОМПАС. Для выбора этого варианта укажите объект КОМПАС, соответствующий объекту AutoCAD. Например, для линии-выноски AutoCAD выберите линию-выноску КОМПАС.

– Макроэлемент — объект AutoCAD преобразуется в макроэлемент КОМПАС, состоящий из графических объектов (отрезков, точек и текстов). При этом теряется информация о типе объекта, т.е. макроэлементы лишь «имитируют» соответствующие объекты оформления.

Размеры хранятся в файле DXF/DWG в двух видах: в виде размерной структуры (координаты линий выносок, размерной линии, текста и т.д.) и в виде блока изображения размера (набор отрезков, заливок, точек и текстов). Поэтому для объекта «размер» доступен еще один вариант чтения — комбинированный объект. При его выборе графические примитивы, из которых состоят размеры, будут считаны из размерных структур файла DXF/DWG, а тексты — из блоков изображений размеров. Тип объекта — «размер» — сохраняется.

Вкладка Символы

Вы можете интерактивно редактировать соответствие между спецсимволами КОМПАС и последовательностями символов ASCII, которыми они обозначаются в текстовом файле DXF. По умолчанию загружается последовательность символов, которая соответствует поставляемому в составе дистрибутива КОМПАС-3D файлу B_ESKD.SHX.

Выбрать файл

Для подключения ранее сохраненного файла соответствия символов (системный файл КОМПАС с расширением *.ACS) нажмите эту кнопку.

Записать в файл

Для сохранения сделанной настройки соответствия символов в файле нажмите эту кнопку.

Символы по умолчанию

Для загрузки настройки соответствия символов по умолчанию нажмите эту кнопку.

Вкладка Типы линий

По умолчанию при импорте файлов DXF в КОМПАС-фрагменте создаются пользовательские стили линий, имеющие такие же названия и начертания, как и типы линий системы AutoCAD.

Установить соответствие типов линий

Чтобы при импорте происходила замена линий системы AutoCAD системными или библиотечными линиями КОМПАС, необходимо задать соответствия между типами линий в AutoCAD и стилями линий в КОМПАС-3D. Для этого включите данную опцию. После включения опции становятся доступными остальные опции и кнопки вкладки.

В окне просмотра отображаются уже имеющиеся соответствия между типами и стилями линий: в колонке AutoCAD отображаются цвет, название типа линии и ее толщина в AutoCAD, а в колонке КОМПАС — название стиля линии в КОМПАС.

Добавить

Чтобы добавить соответствие, нажмите эту кнопку.В появившемся на экране диалоге настройки соответствия введите название типа линии AutoCAD, ее цвет и толщину, введите и установите стиль линии КОМПАС. Закройте диалог, нажав кнопку ОК. В конец списка будет добавлено установленное вами соответствие.

Изменить

Чтобы отредактировать соответствие, выберите его в окне просмотра и нажмите эту кнопку.

Отредактируйте соответствие в появившемся на экране диалоге и нажмите кнопку ОК. Внесенное вами изменение отобразится в списке соответствий.

Удалить

Чтобы удалить соответствие, выберите его в окне просмотра и нажмите эту кнопку.

Прочитать из чертежа AutoCAD

Эта кнопка позволяет отобразить в окне просмотра названия типов линий, используемых в выбранном для чтения чертеже AutoCAD, цвета и толщины этих линий.

В строках, соответствующих типам линий, которые используются в объектах с толщиной линий «default», значение толщины отсутствует.

Для установки стилей линий КОМПАС, которые должны соответствовать обнаруженным типам линий, используйте кнопку Изменить.

Записать в файл

Для сохранения сделанной настройки соответствий в файле нажмите эту кнопку. В появившемся диалоге укажите имя файла для записи. Система сформирует текстовый файл соответствия типов и стилей линий ( *.ALS).

Выбрать файл

Для подключения созданного или ранее сохраненного файла соответствия типов и стилей линий нажмите эту кнопку.

Вы можете создать файл соответствия типов и стилей линий в текстовом режиме и подключать его при импорте файлов DXF.

Типы линий
по умолчанию

Для загрузки настройки соответствия типов и стилей линий по умолчанию нажмите эту кнопку.

Вкладка Полилиния

Данная вкладка позволяет настроить импорт полилиний, для сегментов которых заданы индивидуальные толщины линий. Если установлена постоянная толщина линии, то сегмент имеет форму прямоугольника, если переменная — то трапеции.

Вы можете указать, в какие системные объекты КОМПАС нужно преобразовать эти сегменты.

в линию

Сегменты, образующие полилинию, объединяются в контур.

в заливку

Сегмент преобразуется в заливку. Форма контура заливки соответствует форме сегмента в файле формата DXF/DWG. Цвет заливки также соответствует заданному в этом файле.

Контур, ограничивающий заливку, не строится.

в штриховку

Сегмент преобразуется в штриховку. Форма контура и цвет штриховки соответствуют форме и цвету сегмента в файле формата DXF/DWG.

Контур, ограничивающий штриховку, не строится.

При выборе данного варианта становится доступным раскрывающийся список Шаг штриховки. Вы можете выбрать или ввести с клавиатуры нужное значение шага.

Чтение линий с толщиной «default»

После завершения настройки параметров нажмите кнопку Начать чтение. Для выхода из диалога без чтения файла нажмите кнопку Отмена.

Иногда в процессе чтения возможно возникновение сообщения о наличии в импортируемом файле критической ошибки. Это означает, что в файле отсутствует часть данных, необходимых для корректного чтения.

Сообщение содержит также запрос на восстановление файла.

– Нажмите кнопку ОК, чтобы подтвердить восстановление. Система прочтет файл снова, дополняя его данными по умолчанию. В результате файл импортируется корректно, но не исключена вероятность искажения имеющейся в нем информации.

– Нажмите кнопку Отмена, чтобы отказаться от чтения файла с ошибкой.

Смотрите также


Диалог общей настройки

Этот диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Общие — Отображение имен файлов.

Диалог позволяет настроить показ имени файла в заголовке окна и количество файлов в списке последних открывавшихся.

Описание элементов управления
Элемент | Описание
Полное имя файла в заголовке окна | Чтобы в заголовке окна системы был указан путь к файлу текущего документа и его имя, включите эту опцию. При выключенной опции путь к файлу выводиться не будет. Варианты показа имени файла отображаются в поле Пример.
Помнить список из N файлов | Поле для ввода или выбора количества файлов в списке последних открывавшихся. Этот список отображается в нижней части меню Файл.

Завершив общую настройку, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


Диалог подгонки масштаба документа

Предназначен для автоматического пересчета масштаба печати изображения при размещении изображения на фиксированном количестве листов.

Этот диалог появляется на экране после вызова команды Сервис — Подогнать масштаб....

Описание элементов управления
Элемент | Описание
Документ | Поле содержит полный путь к файлу документа.
Количество страниц по горизонтали Количество страниц по вертикали Масштаб | Введите, задайте с использованием счетчика или выберите из списка требуемое значение любого из параметров. Два остальных будут вычислены автоматически.
Общее количество страниц | Количество листов бумаги для печати документа с заданными параметрами.
ОК | Для вступления в силу выполненных настроек и закрытия диалога нажмите эту кнопку. Изображение будет перерисовано в соответствии с новым значением масштаба.
Отмена | Для закрытия диалога без применения выполненных настроек нажмите эту кнопку.


Диалог настройки параметров вывода

Позволяет настроить параметры вывода документа на печать.

Этот диалог появляется на экране после вызова команды Настройка параметров вывода... из меню Файл.

Описание элементов управления

Элемент

Описание

Количество копий

Задает количество печатаемых копий документов, включенных в набор предварительного просмотра.

Копии в подбор

Управляет выводом страниц при печати нескольких копий. Включите эту опцию, если хотите, чтобы сначала были последовательно напечатаны все страницы первой копии, затем - все страницы второй, и так далее.

Диапазон привязки документов к углам страниц устройства вывода, %

Задается в процентах от длины короткой стороны страницы.

Применять

Если опция включена, то выполняется привязка страниц документа к углам страниц устройства вывода. Если опция Применять выключена, то привязка не выполняется.

Гарантированное расстояние при привязке к углам документов, мм

Определяет точность привязки углов одновременно печатаемых документов друг к другу.

Применять

Если опция включена, то производится привязка углов документов друг к другу. Если опция Применять выключена, то привязка не осуществляется.

Масштаб печати документов по умолчанию

Поле для ввода масштаба, который будет использоваться по умолчанию для всех документов, открытых в режиме просмотра и добавленных в этот режим. В дальнейшем масштаб печати для каждого документа можно изменить.

Цвет вывода

Выберите из списка вариант использования цветов при выводе документа на печать.

– черный

Чтобы при печати документа использовались только оттенки серого цвета, выберите этот вариант.

– установленный для вида

Чтобы объекты, расположенные в разных видах, были напечатаны цветами, установленными для этих видов, выберите этот вариант.

– установленный для слоя

Чтобы объекты, расположенные на разных слоях, были напечатаны цветами, установленными для этих слоев, выберите этот вариант.

– установленный для объекта

Чтобы при печати изображений объектов использовались цвета, установленные для этих объектов в диалоге настройки системы или в диалогах настройки свойств этих объектов, выберите этот вариант.

Вывод тонкими линиями

Чтобы все линии имели толщину, установленную для тонких линий в диалоге настройки системы ,включите опцию. По умолчанию это значение составляет 0,18мм1.

Вывести в файл

Чтобы вывод выполнялся не на устройство печати (принтер или плоттер), а в файл (с расширением prn) на диске, включите опцию.

Точность вывода моделей

Для изменения точности вывода перемещайте «бегунок» между позициями Грубо и Точно. При уменьшении точности вывода уменьшается разрешение растрового изображения модели, передаваемого на принтер. Чем выше точность, тем более «гладким» выглядит изображение и тем больше памяти требуется для его обработки.

При печати изображений большого размера могут возникать проблемы, связанные с переполнением памяти компьютера или принтера.
В случаях, когда трудности возникают при печати полутоновых изображений моделей больших размеров или сложной формы, рекомендуется уменьшать точность вывода.
В остальных случаях (проблемы с печатью документов, содержащих растр или имеющих большой формат) рекомендуется изменить настройку драйвера принтера.

Порядок вывода страниц на печать

Разновидности порядка вывода страниц. Схема вывода, соответствующая каждому из вариантов, показана на пиктограмме.
Данная настройка позволяет соотнести расположение страниц на поле предварительного просмотра и последовательность их печати. Очевидно, что настройка порядка печати имеет смысл, если поле вывода состоит более чем из одной страницы.
  1. Состояние опции Вывод тонкими линиями не влияет на толщину линий шрифта.

Для вступления в силу выполненных настроек и закрытия диалога нажмите кнопку ОК.

Если был изменен цвет вывода, а также, если была включена или отключена опция Вывод тонкими линиями, изображение перерисовывается. Изменение умолчательного масштаба никак не отражается на уже открытых документах. Новый масштаб будет применен лишь к вновь добавленным в просмотр документам.

Если была включена печать в файл, то после вызова команды Печать на экране появится диалог, в котором потребуется задать имя файла и указать папку для его размещения.

Для закрытия диалога без применения выполненных настроек нажмите кнопку Отмена.


Диалог оформления Панели свойств

Этот диалог появляется на экране после вызова команды Сервис — Параметры — Система — Экран — Панель свойств.

Позволяет установить параметры отображения Панели свойств.

Описание элементов управления

Элемент

Описание

Группа «Корешки» вкладок

Позволяет задавать параметры отображения «корешка» вкладки.

Группа Шрифт

Позволяет настроить шрифт надписи на «корешке». Элементы управления группы Шрифт доступны, если в группе Вид выбран вариант Плоские.

Выберите из раскрывающегося списка название шрифта. Список содержит все шрифты, подключенные в Windows.

Цвет

Нажмите эту кнопку, чтобы вызвать диалог изменения цвета символов.

Размер в пикселях

Введите в это поле значение высоты символов (в пикселах) или задайте счетчиком.

Курсив

Включите эту опцию, чтобы задать курсивное начертание символов.

Жирный

Включите эту опцию, чтобы задать утолщенное начертание символов.

Группа Вид

Выберите вариант отображения "корешка" вкладки: плоский или объемный.

Сброс

Нажмите эту кнопку, чтобы восстановить умолчательные параметры отображения Панели свойств.

Внешний вид настраиваемых объектов показывается окне просмотра. Это позволяет оценить сделанные изменения.

После завершения настройки параметров отображения Панели свойств нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог настройки отрисовки стрелок и засечек обозначений позиций

Этот диалог появляется на экране после вызова команды настройки отрисовки стрелок и засечек обозначений позиций для графических документов и моделей. Например, Сервис — Параметры — Текущий чертеж — Обозначение позиции — Стрелки и засечки.

Позволяет настроить параметры отображения и печати стрелок обозначений позиций.

Описание элементов управления
Элемент | Описание
Стрелки обозначений позиций | Чтобы стрелки обозначений позиций зачернялись, включите опцию Зачернять. Изменение состояния опции отражается на примере стрелки в диалоге.

После завершения настройки отрисовки стрелок нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Предупреждение о наличии PROXY-объектов, чтение которых невозможно

Предупреждение о наличии PROXY-объектов,
чтение которых невозможно

Документы формата DXF или DWG могут содержать PROXY-объекты. Некоторые элементы, составляющие эти объекты, не могут быть импортированы.

Данное сообщение появляется в случае, если импортируемый документ содержит PROXY-объект, включающий в себя элемент (элементы), прочитать который невозможно.

Вы можете продолжить чтение документа. Для этого нажмите кнопку Да. Все объекты документа, за исключением PROXY-объекта, содержащего нечитаемые элементы, будут импортированы (в том числе PROXY-объекты, все элементы которых можно прочитать).

Чтобы отказаться от чтения документа, нажмите кнопку Нет.


Диалог указания выводимой части документа

Этот диалог появляется на экране после активизации переключателя Указать часть на Панели свойств в режиме предварительного просмотра.

В диалоге показан текущий документ и рамка, ограничивающая печатаемую часть.

Чтобы изменить размеры рамки, введите нужные значения в поля группы Отступ в левой части диалога. Можно также переместить стороны или углы рамки мышью. Завершив настройку, закройте диалог.

После этого на поле вывода будет отображаться не весь документ, а только указанная часть.

Вы можете управлять способом печати текущего документа с помощью переключателей группы Способ вывода на Панели свойств. Активизация переключателя Вывести часть текущего документа отображает на поле вывода область документа, ограниченную рамкой, активизация переключателя Вывести текущий документ полностью - весь документ целиком.


Диалог выбора документов для печати

Позволяет выбрать документы, которые необходимо включить в набор предварительного просмотра для печати.

Этот диалог появляется на экране после вызова команды Предварительный просмотр... из меню Файл.

В диалоге отображается список открытых в данный момент документов. В списке выделен активный документ.

Отображение имен файлов (длинное или короткое) в диалоге подчиняется настройке отображения имен файлов.

Чтобы выделить несколько документов для печати, нажмите клавишу <Ctrl> и, удерживая ее, указывайте нужные документы.

Чтобы выделить в диалоге несколько документов, расположенных подряд друг за другом, выделите первый (последний) из этих документов, нажмите и удерживайте клавишу <Shift>, затем выделите последний (первый) документ. Выделение будет распространено на все документы между ними.

Чтобы выделить весь список открытых документов, включите опцию Выделить все документы.

После завершения выбора документов для предварительного просмотра нажмите кнопку ОК, чтобы перейти в режим предварительного просмотра.

Чтобы выбрать документ, которого нет в списке данного диалога, нажмите кнопку Из файла....

Для выхода из диалога без выбора документов (и, следовательно, отказа от печати) нажмите кнопку Отмена.


Диалог настройки габарита модели

Этот диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Редактор моделей — Габарит.

Позволяет указать типы объектов модели, которые должны учитываться при построении ее габаритного параллелепипеда.

Чтобы указать типы объектов, включите опции слева от их названий.

Все опции выключить невозможно — какая-либо одна обязательно останется включена.

Чтобы в определении габарита модели участвовали также скрытые объекты указанных типов, включите опцию Учитывать скрытые объекты.

После завершения настройки габарита нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.

Габаритный параллелепипед используется, например:

– для работы команды Показать все — масштаб отображения изменяется так, чтобы проекция габаритного параллелепипеда модели на плоскость экрана вписалась в окно,

– при центрировании изображения после изменения ориентации модели — центр проекции габаритного параллелепипеда совмещается с центром окна модели.


Диалог настройки управления изображением

Этот диалог появляется на экране после вызова команды Сервис — Параметры — Система — Редактор моделей — Управление изображением.

Диалог позволяет задать параметры изображения моделей в окне.

Описание элементов управления

Элемент

Описание

Шаг перемещения изображения модели (% окна)

В этом поле устанавливается величина перемещения изображения модели в окне при однократном нажатии клавиши, сдвигающей изображение. Шаг перемещения устанавливается в процентах от размера окна.

Например, после ввода в это поле значения 25 при нажатии комбинации клавиш <Shift>+<Стрелка вправо> изображение сместится вправо на четверть (25 процентов) ширины окна.

Шаг угла поворота модели (гр.)

В этом поле устанавливается величина поворота модели в окне при однократном нажатии клавиатурной комбинации, вращающей деталь. Шаг перемещения устанавливается в градусах.

Например, после ввода в это поле значения 15 градусов при нажатии комбинации <Alt>+<Стрелка вправо> деталь повернется вокруг вертикальной оси вправо на 15 градусов (и ее изображение изменится соответствующим образом).

Коэффициент изменения масштаба

В этом поле устанавливается коэффициент увеличения или уменьшения изображения в окне при однократном нажатии клавиатурной комбинации, изменяющей масштаб изображения.

Например, после ввода в это поле значения 1,5 при нажатии комбинации <Shift>+<-> линейные размеры изображения будут уменьшены в полтора раза.

Использовать дополнительный буфер изображения

Опция для включения и отключения использования дополнительных аппаратных возможностей видеокарты компьютера, которые позволяют ускорить отображение трехмерных моделей.

Использование дополнительного буфера изображения позволяет ускорить обновление ранее сформированного изображения. Например, возможно ускорение восстановления части изображения, которая была закрыта меню или диалогом.
Ускорение заметно тем сильнее, чем сложнее модель.

Следует, однако, иметь в виду, что не все видеокарты обладают дополнительными возможностями ускорения отображения, а также не все драйверы видеокарт задействуют эти возможности. Поэтому появление ускорения в результате включения опции Использовать дополнительный буфер изображения зависит от модели видеокарты и версии драйвера, установленных на конкретном компьютере1.

Прозрачность

Группа опций, позволяющая выбрать способ отображения прозрачных объектов (граней, компонентов, поверхностей и др.).

Включите опцию Сетчатая, чтобы прозрачные объекты отображались в виде сетки пикселов.

Включите опцию Реалистичная, чтобы отображение прозрачных объектов было максимально приближено к виду объектов, выполненных из прозрачного материала.
  1. Иногда включение опции может давать обратный эффект. В таком случае выключите ее.

Задав параметры изображения, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


Диалог настройки упрощенного отображения моделей

Этот диалог появляется на экране после вызова команды Сервис — Параметры — Система — Редактор моделей — Упрощения — Модель.

Диалог позволяет настроить параметры отрисовки моделей в режиме упрощенного отображения.

Описание элементов управления

Элемент

Описание

Уровень детализации

Позволяет задать уровень детализации компонентов сборки и тел детали при работе режима упрощенного отображения.

Если этот режим включен, то относительно мелкие компоненты сборки или тела детали заменяются параллелепипедами соответствующих габаритов и цветов в следующих случаях:

– сдвиг и поворот модели мышью или с помощью команд Сдвиг и Поворот,

– изменение ориентации и масштаба модели (если включена плавность),

– установка мелкого масштаба отображения.

По завершении изменения положения или масштаба, а также после увеличения масштаба отображение модели восстанавливается.

Для изменения уровня детализации перемещайте «бегунок» между позициями Больше (медленнее) и Меньше (быстрее). Чем степень детализации меньше, тем более крупные компоненты или тела превращаются в параллелепипеды и тем быстрее происходит изменение положения (масштаба) модели.

Включение и выключение режима упрощенного отображения производится при работе с моделью командой Вид — Упрощения — Упрощенное отображение. По умолчанию режим упрощенного отображения включен.

Применять дополнительный режим для стандартных компонентов

Активизируйте эту опцию, чтобы включить специальный режим упрощения стандартных компонентов сборки (например, моделей стандартных изделий, вставленных из Библиотеки крепежа). При отключенной опции стандартные компоненты упрощаются в общем режиме, т.е. подчиняются настройке уровня детализации компонентов сборки.

Упрощать

При выборе этого варианта стандартные компоненты во время работы режима упрощенного отображения всегда показываются в виде параллелепипедов вне зависимости от установленного уровня детализации.

Скрывать

При выборе этого варианта стандартные компоненты всегда скрываются во время работы режима упрощенного отображения.

Применять упрощение при непрерывном вращении

Активизируйте эту опцию, чтобы применить упрощение отображения моделей при непрерывном вращении с помощью команды Вращать модель

Чтобы завершить настройку упрощенного отображения, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


Диалог прочих настроек режима упрощенного отображения

Этот диалог появляется на экране после вызова команды Сервис — Параметры — Система — Редактор моделей — Упрощения — Прочие.

В этом диалоге вы можете включить дополнительные средства упрощения, позволяющие еще более ускорить работу в режиме упрощенного отображения модели. Если этот режим отключен, то дополнительные средства упрощения не используются.

Описание элементов управления

Элемент

Описание

При изменении изображения

Группа опций, позволяющая включить или отключить дополнительные упрощения, которые будут действовать при включенном режиме упрощенного отображения во время изменения изображения.

На статичное изображение модели состояние опций этой группы не влияет.

Быстрое отображение линий

Позволяет использовать быстрое отображение линий модели. Если эта опция включена, то при изменении изображения автоматически активизируется команда Быстрое отображение линий.

Скрыть конструктивные оси, плоскости и пр.

Позволяет управлять отображением вспомогательных объектов модели.

Если эта опция включена, то при изменении изображения автоматически активизируются следующие команды:

– Скрыть — Начала координат,

– Скрыть — Конструктивные плоскости,

– Скрыть — Конструктивные оси,

– Скрыть — Эскизы,

– Скрыть — Изображения резьбы,

– Скрыть — Контрольные точки.

Скрыть поверхности

Позволяет управлять отображением поверхностей, присутствующих в окне модели. Если эта опция включена, то при изменении изображения автоматически активизируется команда Скрыть — Поверхности.

При отключенной опции поверхности остаются видны и упрощаются в соответствии с заданным уровнем детализации.

Скрыть пространственные кривые

Позволяет управлять отображением пространственных кривых - ломаных, сплайнов и спиралей.

Если эта опция включена, то при изменении изображения автоматически активизируется команда Скрыть — Пространственные кривые.

Отключить режим "Полутоновое с каркасом"

Позволяет управлять использованием указанного типа отображения модели.

Если эта опция включена, то для тех компонентов или тел, которые не превратились в параллелепипеды, при изменении изображения отключается полутоновое отображение с каркасом (если оно было включено).

Отключить отрисовку очерков

Позволяет отключить отрисовку линий очерков компонентов или тел при изменении изображения.

Скрыть сетку

Позволяет отключить изображение сетки при изменении масштаба эскиза.

Скрыть селектирование

Позволяет отключить подсветку выделенных объектов (кроме граней) при изменении изображения.

Если опция выключена, то выделенные объекты остаются подсвеченными.

Наличие или отсутствие выделенных граней не влияет на скорость изменения изображения

Сетчатая прозрачность

Позволяет включить показ прозрачных объектов (если таковые имеются) в виде сетки пикселов при изменении изображения.

Скрыть контрольные точки,

Скрыть условные изображения резьбы,

Скрыть размеры,

Скрыть условные обозначения

Позволяют отключить отрисовку контрольных и присоединительных точек, изображений резьбы, размеров и обозначений во время работы режима упрощенного отображения.

Невидимые объекты отображать в виде точек

Позволяет включить отображение точек на месте компонентов (или тел), ставших невидимыми из-за мелкого масштаба. Ставшие невидимыми объекты могут отображаться в виде точек только в режиме упрощенной отрисовки.

Если опция Невидимые объекты отображать в виде точек выключена, то компоненты и тела относительно малого размера могут совсем «исчезнуть» при определенном масштабе уменьшения1.
  1. Стандартные компоненты могут также стать невидимыми в результате включения опции Скрывать в диалоге настройки упрощения модели.

Чтобы завершить настройку упрощенного отображения, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


Диалог настройки изменения ориентации модели

Этот диалог появляется на экране после вызова команды Сервис — Параметры — Система — Редактор моделей — Изменение ориентации.

Диалог позволяет задать параметры отображения моделей во время изменения ориентации (масштаба) и после изменения ориентации.

Описание элементов управления

Элементы

Описание

Плавность

Опция, включающая показ промежуточных кадров между кадрами, изображающими модель в начальном и конечном положениях (масштабах). Благодаря этому изменение положения (масштаба) модели выглядит не скачкообразным, а плавным.

Когда опция Плавность включена, вы можете настроить количество промежуточных кадров, перемещая «бегунок» между позициями Меньше и Больше. При уменьшении количества кадров изменение изображения модели становится менее плавным, но ускоряется, а при увеличении - наоборот.

Центрировать изображение

Опция, включающая центрирование изображения модели во время изменения ее ориентации.

Сохранять текущий масштаб окна

Опция, включающая сохранение масштаба, установленного в окне модели, при изменении ее ориентации.

Если опция отключена, то после изменения ориентации масштаб отображения модели изменяется. Подбирается такой масштаб, чтобы в окне модели полностью умещался ее габаритный параллелепипед.

Задав параметры отображения, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


Диалог настройки параметров перспективной проекции

Этот диалог появляется на экране после вызова команды Сервис — Параметры — Система — Редактор моделей — Перспективная проекция.

Диалог позволяет настроить параметры перспективной проекции (степень вносимого перспективой искажения).

Описание элементов управления

Элемент

Описание

Расстояние в габаритах модели

Значение в этом поле показывает, во сколько раз расстояние от модели до плоскости изображения больше, чем максимальный габарит модели.

Другими словами, на экране показывается такое изображение модели, которое получил бы оптический прибор, находящийся на указанном расстоянии от модели. Чем меньше указанное расстояние, тем сильнее будет заметно искажение изображения.

Задав параметры перспективной проекции, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


Не найден файл с описанием формы

Это предупреждение появляется на экране при попытке импортировать файл формата DXF или DWG, содержащий формы (shape), если система не может загрузить файл, в котором описаны эти формы.

Файл с описанием формы (*.shx) может быть недоступен по разным причинам: либо он не существует вообще (например, файл с описанием формы удалили или при передаче файла формата DXF или DWG в другую организацию не передали вместе с ним файл с описанием формы), либо он существует под другим именем (например, файл с описанием формы переименовали), либо он находится по другому пути (например, при копировании файлов на другой компьютер изменились пути, по которым размещены файлы с описанием форм), либо файл поврежден.

Описание элементов управления

Элемент

Описание

В справочном поле диалога отображаются сведения о первой форме, описание которой не найдено. Если импортируется файл DXF, то это имя формы, а если DWG — индекс формы и путь к файлу с ее описанием.

Заменить

Если вы хотите указать, какой shx-файл требуется использовать, нажмите эту кнопку. В появившемся диалоге выберите нужный файл.

Игнорировать

Игнорировать все

Если вы хотите импортировать файл формата DXF или DWG, несмотря на отсутствие файла с описанием формы, нажмите кнопку Игнорировать или Игнорировать все.

Выбор кнопки Игнорировать означает, что в графическом документе КОМПАС будет отсутствовать изображение, соответствующее форме, описание которой не найдено.

Выбор кнопки Игнорировать все означает, что в графическом документе КОМПАС будут отсутствовать изображения, соответствующие всем формам, описания которых не найдены.

Отказ от чтения

Нажмите эту кнопку, чтобы прервать импорт файла.


Диалог настройки отрисовки стрелок и засечек линий-выносок

Этот диалог появляется на экране после вызова команды настройки отрисовки стрелок и засечек линий-выносок для графических документов и моделей. Например, Сервис — Параметры — Текущий чертеж — Линия-выноска — Стрелки и засечки.

Позволяет настроить параметры отображения и печати стрелок и засечек линий-выносок.

Описание элементов управления
Элемент | Описание
Стрелки линий-выносок | Чтобы стрелки линий-выносок зачернялись, включите опцию Зачернять. Изменение состояния опции отражается на примере стрелки в диалоге.

После завершения настройки отрисовки стрелок нажмите кнопку ОК. Для выхода из диалога без сохранения изменений нажмите кнопку Отмена.


Диалог печати текстовых документов

Позволяет установить нужные параметры для печати текущего текстового документа или спецификации.

Этот диалог появляется на экране после вызова команды Печать... из меню Файл.

Описание элементов управления
Элемент | Описание
Устройство | Отображает имя принтера, который установлен как текущий.
Устройство... | Для вызова диалога, в котором можно назначить другое устройство вывода, нажмите эту кнопку.
Вывести в файл | Включите эту опцию, если нужно вывести документ не на принтер, а в файл. Имя файла предлагается системой автоматически. Оно совпадает с именем документа и имеет расширение prn.
Обзор | Чтобы изменить расположение файла, в который будет «напечатан» документ, нажмите кнопку.
Размер поля печати Размер страницы Количество страниц документа Текущая страница | Указаны для справки.
Масштаб вывода | Задайте нужное значение масштаба при печати.
Подогнать | Для автоматического вписывания документа в размер реального поля печати принтера нажмите кнопку.
Диапазон | Выберите диапазон страниц документа для вывода на печать.
Все страницы | Будут напечатаны все страницы документа.
Текущую страницу | Будет напечатана только текущая страница — страница, номер которой был задан в поле Текущая страница перед вызовом команды печати. Если номер страницы специально не вводился, то текущей считается первая страница документа вне зависимости от того, какая страница отображалась на экране перед вызовом команды печати.
Страницы | Задайте номера и диапазоны страниц, которые нужно напечатать, разделяя их запятыми. Например, 1, 3, 6 — 13, 17, 22 — 25.
Выводить | Выберите из списка, какие страницы диапазона нужно напечатать (все страницы, только четные, только нечетные).
Количество | Задайте количество копий документа, которое необходимо напечатать.
Копии в подбор | Включите эту опцию, чтобы выбранные страницы документа выводились последовательно для каждой его копии.
Цветная печать | Включите эту опцию, если будет производиться вывод на цветное устройство (принтер, плоттер и т.д.), и требуется напечатать текст теми же цветами, которыми он отображается на экране.
Вывод тонкими линиями | Включение этой опции означает, что все линии (например, рамка, изображение во вставленных фрагментах) будут иметь толщину, установленную для тонких линий в диалоге настройки системы1. По умолчанию это значение составляет 0,18мм.
Положение начала документа | Задайте координаты левого нижнего угла габаритной рамки документа относительно левого нижнего угла поля вывода (листа бумаги).
  1. Состояние опции не влияет на начертание шрифта.

После установки всех параметров нажмите кнопку ОК для начала печати. Чтобы завершить диалог без вывода документа на печать, нажмите кнопку Отмена.


Предупреждение о наличии невекторных объектов

В этом диалоге перечислены документы, в которых обнаружены шрифты True Type, растровые изображения и заливки, а также типы объектов (например, размеры, макроэлементы и т.д.), содержащих эти объекты.

В перечне указаны также документы, в которых используется очистка фона для размеров и обозначений, так как очистка реализуется с помощью заливки.

Диалог выдается при попытке вывести указанные в нем объекты (а следовательно, и шрифты True Type, растровые изображения и заливки) на устройство (например, плоттер), драйвер которого не поддерживает такие шрифты и сплошные заливки.

Вы можете указать, выводить или не выводить эти документы, нажав соответствующую кнопку диалога.

Вы можете отказаться от вывода растровых изображений и заливок, включив соответствующую опцию.

При подтверждении вывода перечисленных в диалоге документов следует иметь в виду, что гарантии корректной печати указанных объектов отсутствуют: Вы можете увидеть на бумаге совсем не то, что видели на экране.


Главное окно КОМПАС-3D Viewer

Это главное окно системы. На нем расположены Главное меню и Инструментальные панели.

Все окна открываемых документов являются подчиненными по отношению к главному окну.

Для управления главным окном можно использовать стандартные средства Windows — кнопку Системного меню в левом верхнем углу экрана и кнопки управления размером окна в правом верхнем углу.


Окно предварительного просмотра перед печатью

Главное окно системы в режиме предварительного просмотра перед печатью.

Режим предварительного просмотра имеет собственное Главное меню, Панель управления и Панель свойств.

На экране показывается условное поле вывода (один или несколько листов бумаги). На этом поле реалистично отображаются те документы, которые выбраны для печати. Вы можете перемещать, поворачивать, масштабировать документы для достижения наилучшего их размещения на поле вывода.


Чтение линий с толщиной «default» при импорте DXF, DWG

Чтение линий с толщиной «default»
при импорте DXF, DWG

В импортируемом документе AutoCAD для некоторых объектов может быть установлена толщина линии «default». Толщина таких линий определяется текущими настройками системы AutoCAD, которые в разных сеансах работы, а также на разных рабочих местах могут отличаться. Таким образом, «default» не задает никакого определенного значения толщины. Поэтому при импорте документов, содержащих объекты с типом линии «default», необходимо учитывать следующее.

1. Если настройка соответствия типов и стилей линий производится (опция Установить соответствие типов линий включена), то в диалоге настройки соответствия для того типа линии, который используется в объектах с толщиной лини «default», не следует вводить значение толщины — нужно указать только цвет и тип линии в AutoCAD и системный стиль линии в КОМПАС.

2. Если настройка соответствия типов и стилей линий при импорте не производится (опция Установить соответствие типов линий выключена), или если не найдено соответствие, настроенное с учетом предыдущего пункта, то в документе КОМПАС для линии с толщиной «default» будет создан пользовательский стиль линий с толщиной 0,18 мм.


Окно документа

Окна документов являются подчиненными по отношению к главному окну системы. Одно из окон документов активно — его заголовок подсвечен.

При просмотре документов пользователю доступны команды страниц Главного меню.

Кнопки для быстрого вызова многих из этих команд расположены на Инструментальных панелях.

Для управления окнами служат команды Системного меню, кнопки управления размером окна в правом верхнем углу, а также команды меню Окно.

Смотрите также


Меню панелей

Меню панелей позволяет управлять отображением на экране Инструментальных панелей.

Это меню появляется на экране после вызова команды Вид — Панели инструментов.

Чтобы нужная панель была показана в окне программы, щелкните мышью по ее названию в Меню панелей. Слева от названия панели появится «галочка». Чтобы убрать панель с экрана, щелкните по этой «галочке» или названию панели. Можно также нажать стандартную кнопку Закрыть в заголовке панели.


Центрирование

Центрирование — совмещение центра габаритного параллелепипеда модели (параллелепипеда, построенного через точки модели, наиболее удаленные от начала координат) с центром окна документа.


Перемещение документа на поле вывода

Перемещение документов на поле вывода можно осуществлять мышью, с помощью клавиш со стрелками или путем указания координат базовой точки изображения.

При помощи мыши возможно размещение документа

– произвольное,

– с привязкой к углу листа,

– с привязкой к углу другого документа.

Произвольное размещение документа на листе удобно применять, когда необходимо напечатать документ с большими полями. Размещение с привязкой к углам, напротив, позволяет экономить бумагу, печатая документы рядом друг с другом или максимально близко к краям листа.

При перемещении документа с помощью клавиш со стрелками одно нажатие клавиши сдвигает изображение на один шаг. Для изменения шага перемещения введите или выберите его из списка Текущий шаг курсора на Панели управления.

После того, как с помощью клавиш со стрелками достигнуто нужное положение габаритной рамки изображения, зафиксируйте ее нажатием клавиши <Enter>. Изображение будет перерисовано в соответствии с новым положением документа на поле вывода.

Вы можете задать точное положение изображения, введя координаты его базовой точки в соответствующие поля на Панели свойств. Базовой точкой изображения является его левый нижний угол (в нем расположено условное обозначение координатных осей), а началом системы координат — левый нижний угол листа бумаги.

Обратите внимание на то, что ввод каждой координаты необходимо подтверждать нажатием клавиши <Enter>.

Если текущими являются несколько документов, то их можно перемещать мышью произвольно, с помощью клавиш со стрелками или путем указания координат базовой точки изображения. Перемещение нескольких документов с использованием привязки невозможно.

Перемещение мышью и клавишами осуществляется так же, как и в случае, если текущим документ единственный.

Перемещение же путем указания координат имеет следующие особенности.

Базовой точкой нескольких выделенных документов считается левый нижний угол документа, который был указан первым. В этой точке расположено условное обозначение координатных осей, а ее координаты отображаются в полях на Панели свойств.

Вы можете ввести в эти поля новые значения, подтверждая ввод нажатием клавиши <Enter>. Текущие документы будут размещены на поле вывода так, чтобы базовая точка заняла указанное положение.

При этом вы можете задавать только такие координаты базовой точки, при которых все текущие документы умещаются на поле вывода. Таким образом, смещение документов вверх и вправо не ограничено, а вниз и влево — ограничено габаритами поля вывода.


Масштабирование документа

Вы можете установить увеличенный или уменьшенный масштаб для вывода документа на печать.

Для этого сделайте текущим документ (документы), масштаб которого следует изменить. Затем введите или выберите из списка Масштаб на Панели свойств нужное значение масштаба.

Иногда требуется уместить документ на определенном количестве листов, при этом масштаб изображения на бумаге заранее точно не известен. Для такого размещения документов воспользуйтесь командой Сервис — Подогнать масштаб....

После вызова этой команды на экране появляется диалог выбора количества листов. В диалоге можно указать требуемое количество листов бумаги по горизонтали или по вертикали или требуемый масштаб печати. После ввода одного из перечисленных параметров оставшиеся два рассчитываются автоматически.

Обратите внимание на то, что команда Сервис — Подогнать масштаб... доступна, только если выделен один документ. Подгонка масштаба для нескольких документов одновременно невозможна.

Вы можете установить умолчательный масштаб печати документов. Для этого вызовите команду Файл — Настройка параметров вывода. В появившемся диалоге введите нужное значение в поле Масштаб печати документов по умолчанию. Указанный масштаб будет использоваться по умолчанию для всех документов, открытых в режиме просмотра и добавленных в этот режим. В дальнейшем масштаб печати для каждого документа можно будет изменить.


Поворот документа

Чтобы более рационально использовать бумагу, иногда бывает необходимо повернуть печатаемое изображение.

Поворот документа осуществляется с помощью команд Повернуть по часовой стрелке и Повернуть против часовой стрелки.

Повернутое изображение можно также перемещать и масштабировать, как и прямое.

Вы можете повернуть как один, так и несколько текущих документов одновременно.


Линейки прокрутки

Линейки прокрутки позволяют перемещать изображение строго по вертикали или горизонтали. Они отображаются в окне документа внизу и справа.

Для прокрутки изображения нажимайте кнопки со стрелками, расположенные по краям линеек. Можно также перемещать бегунок, расположенный на линейке.

Если линейки отображаются на экране, для прокрутки изображения можно вращать колесо мыши (если вы пользуетесь мышью с колесом). Текстовые документы и спецификации можно прокручивать постранично. Для этого следует дополнительно удерживать нажатой клавишу <Shift>.

Настройка отображения линеек прокрутки для текущего окна производится в диалоге, вызываемом командой Сервис — Параметры… — Текущее окно.


Размещение документов с привязкой к углам других документов

Размещение документов с привязкой
к углам других документов

Если для предварительного просмотра выбрано несколько документов, то вы можете перемещать их по полю вывода, привязывая углы документов друг к другу.

Такое перемещение производится мышью, но курсор перед началом перемещения нужно установить не в середине документа, а ближе к его углу, так, чтобы курсор принял вид уголка, заключенного в рамку (ориентация курсора зависит от того, рядом с каким углом он был зафиксирован).

Нажмите левую клавишу мыши и перемещайте габаритную рамку изображения по полю вывода.

Когда угол габаритной рамки, за который вы перемещаете изображение, приближается к углу габаритной рамки другого изображения, внутри рамки курсора возникает маркер в виде маленького квадрата. Если отпустить кнопку мыши, когда маркер находится на экране, произойдет привязка соответствующего угла документа к углу другого документа (при этом другие углы этих документов могут и не совпасть, если размеры сторон документов не равны).

Значение расстояния между углами документов, при достижении которого возникает маркер привязки, можно изменить в диалоге настройки параметров вывода. В этом же диалоге можно отключить привязку углов документа друг к другу. Для вызова диалога служит команда Файл — Настройка параметров вывода.


Размещение документа с привязкой к углу листа бумаги

Привязка изображения к углу листа бумаги производится во время перемещения изображения по полю вывода мышью.

Когда один из углов габаритной рамки изображения приближается к углу любого из листов, составляющих поле вывода, в углу листа возникает маркер в виде небольшого кружочка. Если отпустить кнопку мыши, когда маркер находится на экране, произойдет привязка соответствующего угла изображения к углу листа (при этом другие углы документа могут и не попасть точно в углы листа, если размеры документа не кратны размерам листа).

Значение расстояния между углом листа и углом габаритной рамки изображения, при достижении которого возникает маркер привязки, можно изменить в диалоге настройки параметров вывода. В этом же диалоге можно отключить привязку документа к углам листа. Для вызова диалога служит команда Файл — Настройка параметров вывода.


Увеличение масштаба произвольного участка изображения

Увеличение масштаба
произвольного участка изображения

Чтобы увеличить произвольный участок изображения, вызовите команду Увеличить масштаб рамкой.

Щелкните мышью в точке первого угла рамки, которая должна охватить увеличиваемую область. Затем перемещайте курсор для достижения нужного размера рамки. При этом на экране будет отображаться фантом рамки.

После фиксации второго угла рамки изображение будет увеличено таким образом, чтобы область документа, ограниченная рамкой, занимала всю площадь окна.


Автоматический подбор масштаба

Автоматический подбор масштаба — изменение масштаба таким образом, чтобы страница документа полностью умещалась в окне по ширине (горизонтальный размер изображения становится равным ширине окна) или по высоте (вертикальный размер изображения становится равным высоте окна).

Для автоматического подбора масштаба вызовите команду Подогнать масштаб по ширине или Подогнать масштаб по высоте.


Плавное изменение масштаба

Если требуемый коэффициент изменения масштаба неизвестен, вы можете подобрать его визуально, панорамируя («приближая» или «отдаляя») изображение.

Для этого вызовите команду Приблизить/отдалить.

Внешний вид курсора изменится.

Нажмите левую кнопку мыши и, не отпуская ее, перемещайте курсор в вертикальном направлении. При движении курсора вверх изображение будет плавно увеличиваться, в обратном направлении — уменьшаться. Центром масштабирования считается центральная точка окна документа. Достигнув края экрана, отпустите кнопку мыши, переместите курсор в середину экрана, а затем вновь нажмите левую кнопку и перемещайте мышь.

Чтобы центр панорамирования находился в точке, в которой была нажата левая кнопка мыши, удерживайте нажатой клавишу <Shift>.


Переход к предыдущему или последующему масштабу отображения

Переход к предыдущему
или последующему масштабу отображения

Вы можете вернуться к одному из предыдущих масштабов отображения в окне.

Чтобы вернуться к предыдущему масштабу, вызовите команду Предыдущий масштаб.

Чтобы вновь перейти к следующему масштабу отображения, вызовите команду Последующий масштаб.

Количество переходов к предыдущим и последующим масштабам не ограничено.


Отображение документа целиком

Чтобы отобразить в окне весь редактируемый документ, вызовите команду Показать все.


Диалог настройки отображения размеров и обозначений

Этот диалог появляется на экране после вызова команды Сервис — Параметры... — Система — Редактор моделей — Размеры и обозначения.

Диалог позволяет настроить параметры отображения размеров и обозначений в модели.

Диалог настройки отображения размеров и обозначений

Элемент

Описание

Оптимизировать отображение

Опция, управляющая отображением размерных надписей справочных размеров и размеров эскиза, а также текстов в составе условных обозначений.

– Если опция включена, то размерные надписи всегда отображаются в плоскости экрана. Высота шрифта размерной надписи и текста обозначения не изменяется при изменении масштаба отображения модели.

– Если опция отключена, то размерные надписи справочных размеров отображаются в плоскости простановки размера, а размеров эскиза — в плоскости эскиза. Высота шрифта размерной надписи и текста обозначения изменяется соответственно изменению масштаба отображения модели.

Текст обозначения отображается в плоскости создания обозначения вне зависимости от состояния опции Оптимизировать отображение.

Обратите внимание на то, что оптимизация отображения размеров и обозначений не распространяется на печать изображения моделей. Модель выводится на печать так, как она показывается на экране при выключенной опции Оптимизировать отображение.

Показывать соединительные линии

Если опция включена, то на экране отображаются соединительные линии проставленных размеров — выносные линии, линии проекций и т.д.

По умолчанию все опции, управляющие отображением размеров и обозначений, включены.

Чтобы завершить настройку отображения размеров и обозначений в модели, нажмите кнопку OK. Для выхода из диалога без изменения настроек нажмите кнопку Отмена.


Произвольное размещение документа

Чтобы переместить изображение на поле печати, выполните следующие действия.

1. Сделайте текущим документ, который необходимо переместить.

2. Установите курсор так, чтобы он находился в пределах документа.

Вид курсора изменится.

3. Нажмите левую кнопку мыши и, не отпуская ее, перемещайте мышь. Габаритная рамка изображения будет передвигаться по полю вывода.

4. Когда необходимое положение габаритной рамки достигнуто, отпустите клавишу мыши.

Изображение будет перерисовано в соответствии с новым положением документа на поле вывода. Дополнительные листы на поле печати будут появляться автоматически при выходе документа за текущие габариты поля вывода.


Задание на печать

Задание на печать — файл с расширением pjd, в который записываются номера листов и имена файлов документов, выбранных для печати, настройки их размещения на поле вывода, настройки параметров вывода и данные об устройстве вывода.

Файл задания имеет текстовый формат, поэтому он может быть открыт и отредактирован любым текстовым редактором, например, Блокнотом, входящим в состав Windows.


Список заданий на печать

В меню Файл — Задание на печать (в главном окне) и в меню Файл (в режиме предварительного просмотра) отображается список заданий на печать. Фактически это перечень файлов заданий, которые сохранялись или загружались в последнее время.

Чтобы загрузить одно из заданий, выберите его имя из списка.

При загрузке из главного окна программы происходит автоматический переход в режим предварительного просмотра, в котором отображаются листы документов задания.

При загрузке из окна предварительного просмотра на экране появляется диалог выбора варианта добавления листов документов. Для продолжения загрузки выберите один из предлагаемых в диалоге вариантов добавления листов. Для прекращения загрузки нажмите кнопку Отмена.

Количество заданий на печать, имена которых хранятся в списке, можно задать в диалоге Настройка параметров вывода. По умолчанию список содержит девять последних сохраненных или загруженных заданий.

Смотрите также

Команда Сохранить задание на печать...

Команда Загрузить задание на печать...


Сокращения

В описании переменных приняты следующие сокращения.

Сокращение | Расшифровка
[COMMON_APPDATA] | Если файлы ОС находятся, например, на диске С:, то C:\Documents and Settings\All Users\Application Data
[APPDATA] | Если файлы ОС находятся, например, на диске С:, то C:\Documents and Settings\[текущий пользователь]\Application Data
[версия] | Номер версии системы в формате «X.X», например: 7.0.


Активный документ

Документ, с которым ведется работа в текущий момент времени. Активный графический документ или документ—модель может отображаться одновременно в нескольких окнах, одно из которых является активным.

Заголовок активного окна всегда подсвечен.


Активное окно

Окно, в котором ведется работа в текущий момент времени. В этом окне отображается активный документ.

Заголовок активного в настоящий момент окна подсвечен.


Компонент

Деталь, подсборка или стандартное изделие, входящее в состав модели.


Файлы конфигурации

Файлы конфигурации — файлы *.cfg и *.dsk (по умолчанию они называются КViewer.cfg и КViewer.dsk).

В файле *.cfg хранятся настройки системы — настройки, сделанные на вкладке Система общего диалога настройки параметров. По выходе из этого диалога автоматически создается файл *.cfg.

К настройкам системы не относятся сведения, отображающиеся в диалоге просмотра расположения служебных файлов и папок.

В файле *.dsk хранятся настройки рабочего окна — настройки, определяющие внешний вид главного окна системы:

– размер главного окна,

– настройки интерфейса, сделанные в одноименном диалоге,

– вид приложения,

– расположение и состав строки меню и инструментальных панелей (в том числе пользовательских).

Файл *.dsk автоматически создается по выходе из системы КОМПАС-3D Viewer.

При отсутствии конфигурационных файлов (например, при первом запуске системы КОМПАС-3D Viewer) используются хранящиеся внутри системы умолчательные параметры конфигурации.


Линия очерка

Граница проекции детали на плоскость экрана.


Контрольная точка

Контрольная точка позволяет задать пространственное положение элемента трубопровода на его траектории. Свойством контрольной точки является ее положение в модели.

Элемент трубопровода может содержать несколько контрольных точек. Одна из них должна быть расположена в заданной точке траектории. Для расположения контрольной точки на траектории целесообразно использовать привязки.


Панель управления в режиме предварительного просмотра

Панель управления
в режиме предварительного просмотра

Панель управления содержит кнопки для быстрого вызова наиболее часто используемых команд.


Текущий лист

Текущий лист - лист, который расположен так, что захватывает центр окна документа. Его номер отображается в списке листов на панели Текущее состояние.


Элементы документа

Элементы документа - элементы, составляющие содержимое документа. Это элементы, созданные пользователем: кривые, точки, штриховки, размеры, обозначения и др. (в графическом документе); тела, поверхности, оси, плоскости (в документе-модели) и т.д.


DWG

DWG — закрытый двоичный формат, являющийся собственностью компании Autodesk Inc (СШA).


DXF

DXF (Data eXchange Format) — специальный символьный формат обмена информацией, разработанный компaнией Autodesk Inc. (СШA) для своих программных продуктов, в первую очередь AutoCAD.

Этот формат обмена стал стaндapтом де-фaкто для чеpтежно-гpaфических систем и поддерживается практически всеми разработчиками программных продуктов САПР.


Варианты импорта файлов форматов DXF и DWF

Команды меню кнопки Открыть:

– Открыть — импорт файла без изменения параметров импорта,

– Открыть с параметрами... — импорт файла с вызовом диалога настройки параметров импорта.


Ребро

Кривая, разделяющая две грани.


Грань

Гладкая (необязательно плоская) часть поверхности детали.

Гладкая поверхность детали может состоять из нескольких сопряженных граней в случае, когда она образована операцией над несколькими сопряженными графическими объектами.


Как получить справку при работе

При возникновении затруднительных ситуаций во время работы в системе КОМПАС-3D Viewer вы можете быстро получить необходимую справочную информацию. Для этого разработана справочная система, которая содержит сведения о командах меню и панелях кнопок, клавиатурных комбинациях, типовых последовательностях выполнения различных операций и т.д.

Получить справочную информацию можно одним из следующих способов:

– Вызовите команду Справка — Содержание. Найдите в содержании подходящий раздел. Можно также воспользоваться индексом или полнотекстовым поиском.

– Нажмите клавишу <F1> для получения раздела справки о текущем действии, активном элементе интерфейса, или элементе, на который указывает курсор.


Настройка клавиш быстрого вызова команд («горячие клавиши»)

Настройка клавиш быстрого вызова команд
(«горячие клавиши»)

Вы можете назначать сочетания клавиш быстрого вызова команд. Для этого на вкладке Клавиатура диалога Настройка интерфейса выберите категорию и команду из этой категории. Если команде уже было назначено сочетание клавиш, оно будет показано на панели Текущие. Одной команде может быть назначено несколько клавиатурных комбинаций.

Раскрывающийся список Установить сочетание содержит перечень типов документов. Вы можете выбрать тип документа, для которого будет действовать комбинация клавиш для вызова команды. Выбор варианта По умолчанию означает, что клавиатурная комбинация будет действовать при работе с документами любого типа.

Щелкните мышью в поле Новое сочетание клавиш:. Система ожидает ввода клавиатурной комбинации. Рекомендуется использовать алфавитно-цифровые клавиши в сочетании с клавишами <Ctrl>, <Shift>, <Alt> во избежание путаницы при вызове команд и вводе букв и цифр. При нажатии клавиш их названия будут появляться в поле. Если предлагаемое сочетание клавиш совпадает с уже используемым в системе, сообщение об этом появится ниже поля. Назначение такой клавиатурной комбинации невозможно. Если данное сочетание клавиш не используется, то появится строка «Не связана».

Чтобы назначить выбранную клавиатурную комбинацию для вызова команды, нажмите кнопку Связать. Чтобы отменить назначенное сочетание клавиш, выберите его на панели Текущие и нажмите кнопку Удалить.

Чтобы восстановить умолчательные назначения клавиатурных комбинаций командам системы КОМПАС-3D Viewer, нажмите кнопку Сбросить все.


Изменения изображения:

– сдвиг и поворот модели мышью или с помощью команд Сдвиг и Поворот,

– изменение ориентации и масштаба (если включена плавность).


Информационное окно

Это окно появляется на экране, если при загрузке файла задания на печать были обнаружены проблемы.

В окне отображаются:

– текущая дата,

– полное имя файла задания на печать,

– список проблем, возникших при загрузке.


Структура и синтаксис файла KViewer.ini

KViewer.ini — текстовый файл с данными, определяющими различные параметры работы системы.

Эти данные представлены в виде значений ключей, распределенных по секциям.

Таблица значений ключей
Секция, ключи | Описание
[Directories] CFG DSK SYS LIBS TEMP WORK | Содержит сведения о путях к конфигурационным файлам и системным папкам. Имена и назначение ключей этой секции совпадают с именами и назначением переменных среды системы КОМПАС-3D Viewer.
[Bmp] | Содержит сведения о максимальном размере блока для вывода растровых и полутоновых изображений на принтер.
MaxBlockSize | Указывает максимальный размер блока (в сотнях килобайт). Например, если ключ равен 10, то растровые и полутоновые изображения выводятся блоками по 1000 килобайт (1 Мб). Если значение ключа меньше или равно 0, все изображение выводится за один проход.
[FontEscapement] | Содержит сведения о способе вывода текста.
TextAsBitmap | Значение YES включает вывод символов текста в виде растра, NO — отключает. Включение вывода текста в виде растра позволяет решить проблему печати на некоторых плоттерах (например, Calcomp 720C) шрифтов True Type, поставляемых вместе с системой.

В файле KViewer.ini для указания расположения папок и файлов возможно использование как абсолютных путей (например, SYS=C:\Program Files\Ascon\KOMPAS-3D Viewer\Sys), так и путей относительно папки, содержащей файлы KViewer.ini и KViewer.exe (например, SYS=..\Sys).

Кроме того, при задании путей возможно использование системных переменных (например, TEMP=%TEMP%).

Строки, начинающиеся с символа «точка с запятой» (;), считаются комментариями и не учитываются при обработке файла KViewer.ini.

Если значение ключа содержит пробел, то оно должно заключаться в кавычки (например, TEMP=«D:\Рабочие материалы\Временные файлы»).

При запуске системы КОМПАС-3D Viewer поиск файла KViewer.ini ведется только в папке, содержащей файл KViewer.exe. Поэтому размещение файла KViewer.ini в другой папке равносильно его отсутствию.


Присоединительная точка

Присоединительная точка позволяет задать пространственное положение соединяемых (стыкуемых) элементов трубопровода и направление присоединяемого элемента. Свойствами присоединительной точки являются ее положение в модели и вектор, который задает направление присоединения в этой точке.

Элемент трубопровода может содержать несколько присоединительных точек. Чтобы связать два элемента трубопровода, необходимо совместить их присоединительные точки.


Изменение значка

Этот диалог представляет собой несложный графический редактор. Окно Иконка содержит увеличенное изображение редактируемого значка. В этом окне вы можете изменять рисунок по точкам (пикселам). Панель Цвета содержит набор из шестнадцати цветов, которые можно выбрать для рисования. На панели Инструменты расположен набор инструментов для создания значка.

При создании или редактировании значка вы можете использовать буфер обмена Windows. Кнопка Копировать в буфер обмена позволяет скопировать в него текущий значок. Кнопка Вставить из буфера обмена позволяет вставить из буфера обмена в окно редактирования значка графический объект. Если габарит объекта превышает 16х16 пикселов, то он будет обрезан по этому размеру (будет вставлен верхний левый угол рисунка).

Кнопка Очистить позволяет очистить окно Иконка.

После завершения редактирования значка нажмите кнопку Применить. Новый значок появится на кнопке. Чтобы закрыть диалог без сохранения изменений, нажмите кнопку Отмена.


Настройка представления кнопок на панели инструментов

Настройка представления кнопок
на панели инструментов

Если диалог настройки интерфейса находится на экране, вы можете настраивать представление кнопки на панели инструментов.

Чтобы выбрать способ представления кнопки, вызовите из ее контекстного меню одну из команд Иконка, Текст, Иконка и текст. Если по умолчанию в системе КОМПАС-3D Viewer не предусмотрен значок для этой кнопки, а вы выбрали один из вариантов с иконкой, то на экране появится диалог, позволяющий выбрать значок.

Чтобы настроить представление кнопки вызова команды на панели инструментов, вызовите из контекстного меню этой кнопки команду Свойства кнопки. В появившемся на экране диалоге выберите вариант представления кнопки: Иконка, Текст, Иконка и текст.

Если будет выбран вариант Текст, то вы сможете изменить название кнопки, которое отображается на панели. Введите в поле Текст новое название.

Если будет выбран вариант Иконка, то вы сможете изменить значок кнопки. Если для кнопки в системе КОМПАС-3D Viewer предусмотрен значок, то будут доступными варианты Иконка по умолчанию: и Пользовательская иконка:. Вариант Иконка по умолчанию: позволяет использовать умолчательный значок. Чтобы изменить значок на кнопке, выберите вариант Пользовательская иконка:. Вы можете отредактировать выбранный значок. Для этого нажмите кнопку Изменить. На экране появится диалог Изменение значка с открытым для редактирования значком.

Вы также можете создать значок для кнопки. Для этого нажмите кнопку Новая. На экране также появится диалог Изменение значка.

Если будет выбран вариант Иконка и текст, вы сможете задать или изменить название кнопки и значок на ней.

Чтобы перед кнопкой появился разделитель групп, вызовите из контекстного меню кнопки команду Начать группу.


Внешние файлы

– библиотеки оформлений,

– библиотеки фрагментов,

– библиотеки стилей,

– библиотеки типов атрибутов,

– документы—спецификации, подключенные к текущей сборке или чертежу,

– сборки или листы сборочного чертежа, подключенные к текущей спецификации,

– документы, подключенные к объектам спецификации в текущем документе,

– документы, к объектам спецификации в которых подключен текущий документ,

– вставленные фрагменты,

– файлы деталей, связанных с ассоциативными видами,

– файлы деталей и сборок, вставленные в сборку.


Описание переменных среды системы КОМПАС-3D Viewer

Описание переменных среды
системы КОМПАС-3D Viewer

Принятые сокращения

Переменная

Описание

Значение

CFG

Указывает имя конфигурационного файла *.cfg и путь к нему.

CFG=[APPDATA]\Ascon\Kompas-3D Viewer\[версия]\KViewer.cfg

DSK

Указывает имя конфигурационного файла *.dsk и путь к нему.

DSK=[APPDATA]\Ascon\Kompas-3D Viewer\[версия]\KViewer.dsk

SYS

Указывает, в какой папке находятся служебные файлы: библиотеки стилей, оформлений, файл спецзнаков и т.д. Если требуемый служебный файл не будет найден в этой папке, пользователю предоставляется возможность явно указать путь к нему.

При запуске КОМПАС-3D Viewer проверяется наличие папки [APPDATA]\Ascon\Kompas-3D Viewer\[версия]\Sys.

Если она найдена, то

SYS=[APPDATA]\Ascon\Kompas-3D Viewer\[версия]\Sys

Если она не найдена, то проверяется наличие папки [COMMON_APPDATA]\Ascon\Kompas-3D Viewer\[версия]\Sys.

Если она найдена, то

SYS=[COMMON_APPDATA]\Ascon\Kompas-3D Viewer\[версия]\Sys

Если она не найдена, то папка Sys разыскивается по пути относительно файла KViewer.exe (т.е. в папке, содержащей папку с файлом KViewer.exe).

Если папка Sys найдена по относительному пути, то

SYS=..\Sys

Если папка Sys не найдена по относительному пути, то переменная среды SYS принимает значение, содержащее путь к папке с файлом KViewer.exe.

LIBS

Указывает, в какой папке находится системная библиотека, необходимая для чтения файлов форматов DXF, DWG.

При запуске КОМПАС-3D Viewer проверяется наличие папки [APPDATA]\Ascon\Kompas-3D Viewer\[версия]\Libs.

Если она найдена, то

LIBS=[APPDATA]\Ascon\Kompas-3D Viewer\[версия]\Libs

Если она не найдена, то проверяется наличие папки [COMMON_APPDATA]\Ascon\Kompas-3D Viewer\[версия]\Libs.

Если она найдена, то
LIBS=[COMMON_APPDATA]\Ascon\Kompas-3D Viewer\[версия]\Libs

Если она не найдена, то папка Libs разыскивается по пути относительно файла KViewer.exe (т.е. в папке, содержащей папку с файлом KViewer.exe).

Если папка Libs найдена по относительному пути, то

LIBS=..\Libs

Если папка Libs не найдена по относительному пути, то переменная среды LIBS принимает значение, содержащее путь к папке с файлом KViewer.exe.

TEMP

Указывает, в какой папке нужно размещать временные файлы.

TEMP=%TEMP%

Если переменная среды TEMP (TMP) определена для текущего пользователя, то используется эта переменная. Например, TEMP=«%USERPROFILE%\Local Settings\Temp».

В противном случае используется системная переменная TEMP (TMP). Например, TEMP=%SystemRoot%\TEMP.

WORK

Указывает, в какой размещаются КОМПАС-документы.

Эта папка будет по умолчанию предложена при первом открытии документа.

WORK=«%USERPROFILE%\Мои документы»


Многолистовой чертеж

Многолистовой чертеж — конструкторский документ, содержащий несколько листов с единым обозначением и наименованием и сквозной нумерацией.

Все листы многолистового чертежа хранятся в одном файле *.cdw.


Создание пользовательской Инструментальной панели

Вы можете создавать пользовательские панели инструментов. На таких панелях могут быть размещены кнопки для вызова команд из любых категорий.

Чтобы создать пользовательскую панель инструментов, вызовите команду Сервис — Настройка интерфейса. Активизируйте вкладку Панели инструментов и нажмите кнопку Новая.... В появившемся на экране диалоге введите название новой панели и нажмите кнопку Применить. После этого новая панель появится на экране.

Первоначально панель не содержит кнопок вызова команд. Вы можете настроить состав панели инструментов.


ODMA

ODMA (Open Document Management API) - один из стандартных интерфейсов, обеспечивающих взаимодействие между системой документооборота и другими программами (например, между PartY+ и КОМПАС).


Ориентация

Положение модели относительно наблюдателя.


Панель свойств

Панель, содержащая элементы управления процессом предварительного просмотра документов перед печатью.


Стандартная панель

Панель, на которой расположены кнопки вызова команд стандартных операций с файлами.

Для включения отображения ее на экране служит команда Вид — Панели инструментов — Стандартная.


Настройка состава Главного меню и панелей инструментов

Настройка состава Главного меню
и панелей инструментов

Вы можете изменять состав Главного меню и панелей инструментов, добавляя или удаляя кнопки вызова команд и настраивая их отображение.

Для этого вызовите команду Сервис — Настройка интерфейса. Активизируйте вкладку Команды.

Чтобы добавить команду в меню или на панель инструментов, выберите категорию и название команды. «Перетащите» команду на нужную панель. Отпустите кнопку мыши. Команда появится в указанном месте.

Названия команд могут дополняться пиктограммами, принятыми в системе КОМПАС-3D Viewer по умолчанию. Если пиктограмма по умолчанию отсутствует, то на панели появится только название команды. Вы можете настроить представление кнопок на панели инструментов. Чтобы восстановить умолчательное представление кнопки на панели инструментов, вызовите из контекстного меню этой кнопки команду Сбросить.

Чтобы удалить кнопку с панели инструментов, вызовите из этого контекстного меню команду Удалить.

Вы можете изменять положение команд и их групп на панелях инструментов и в меню, «перетаскивая» их мышью.


Панель Вид

Панель, на которой расположены кнопки вызова команд настройки отображения активного документа.

Набор полей и кнопок панели Вид зависит от того, какой документ активен.

Для включения отображения ее на экране служит команда Вид — Панели инструментов — Вид.

Панель Вид при работе с моделями


PDM

Система PDM (Product Data Management System) - система управления данными об изделии (продукте). В ее состав обязательно входит система управления документами - DMS (Document Management System).


Настройка параметров перспективной проекции

Степень вносимого перспективой искажения изображения можно настроить.

Если требуется настроить перспективу только в текущем окне, вызовите команду Сервис — Параметры — Текущее окно — Параметры перспективной проекции.

Если требуется настроить перспективу во всех вновь открываемых окнах, вызовите команду Сервис — Параметры — Система — Редактор моделей — Параметры перспективной проекции.

В диалоге находится единственная опция — Расстояние в габаритах модели. Она показывает, во сколько раз расстояние от детали до плоскости изображения больше, чем максимальный габарит детали. Другими словами, на экране показывается такое изображение детали, которое получил бы оптический прибор, находящийся на указанном расстоянии от детали.

Чем меньше указанное расстояние, тем сильнее заметно искажение изображения.

Введите нужное значение расстояния и закройте диалог, нажав кнопку OK. После этого перспективная проекция в текущем окне (или в новых окнах) будет отображаться с учетом сделанной Вами настройки.


Зависимость между движением курсораи направлением поворота элемента

Зависимость между движением курсора
и направлением поворота элемента

Если курсор перемещается вертикально, то компонент вращается в вертикальной плоскости, перпендикулярной плоскости экрана.

Если курсор перемещается горизонтально, то деталь вращается в горизонтальной плоскости, перпендикулярной плоскости экрана.

Если курсор перемещается по диагонали, то вращение компонента складывается из соответствующих вертикальной и горизонтальной составляющих.


Поворот модели с помощью клавиатурных комбинаций

Для быстрого перехода к вращению модели (без вызова специальной команды) можно воспользоваться комбинациями клавиш <Ctrl>+<Shift>+<стрелки>.

При использовании комбинаций <Ctrl>+<Shift>+<стрелка вверх> и <Ctrl>+<Shift>+<стрелка вниз> модель поворачивается в вертикальной плоскости, перпендикулярной плоскости экрана.

При использовании комбинаций <Ctrl>+<Shift>+<стрелка вправо> и <Ctrl>+<Shift>+<стрелка влево> модель поворачивается в горизонтальной плоскости.

Если требуется повернуть модель в плоскости экрана, используйте клавиатурные комбинации <Alt>+<стрелка вправо> и <Alt>+<стрелка влево>.

Иногда нужно повернуть модель ровно на 90 градусов. Для выполнения такого поворота в вертикальной плоскости, перпендикулярной плоскости экрана, служат клавиатурные комбинации <Пробел>+<стрелка вверх> и <Пробел>+<стрелка вниз>, в горизонтальной плоскости – комбинации <Пробел>+<стрелка вправо> и <Пробел>+<стрелка влево>, а в плоскости экрана – комбинации <Alt>+<стрелка вверх> и <Alt>+<стрелка вниз>.


Настройка драйвера принтера для печати КОМПАС-документов

В случаях, когда при печати КОМПАС-документов, содержащих растровые изображения или имеющих большой формат, возникают проблемы, рекомендуется настроить драйвер принтера следующим образом.

1. Уменьшить разрешение печати.

2. Если при настройке драйвера имеется возможность выбора между подготовкой изображения к печати на принтере и подготовкой на компьютере, то следует включить подготовку изображения к печати на компьютере.


Шрифт SHX

Векторный шрифт собственного формата AutoCAD.


Перекодирование текстов, набранных шрифтами SHX

Если документ формата DXF или DWG содержит тексты, набранные шрифтами SHX, то во время импорта возможны следующие преобразования этих текстов:

– замена шрифта,

– корректировка высоты и сужения символов,

– конвертирование из OEM в ANSI (в частности, для русского языка это означает преобразование кодировки из CP866 в Windows 1251),

– нестандартное преобразование кодировки.

Перекодирование осуществляется при наличии файла convtxt.tfn и в соответствии с заданными в нем параметрами. Данный файл должен находиться в папке, путь к которой указан системной переменной SYS. По умолчанию это папка \Sys системы КОМПАС-3D Viewer.

Файл convtxt.tfn — текстовый, поэтому его можно просматривать и редактировать в любом текстовом редакторе, например, в программе Блокнот, входящей в состав ОС Windows.

Структура и синтаксис файла convtxt.tfn


Тело

Часть пространства, ограниченная замкнутой поверхностью. Считается, что эта область заполнена однородным материалом детали.


Особенности упрощения подсборок

Отображение подсборок в упрощенном виде имеет следующие особенности.

– Параллелепипед, которым заменяется подсборка, отображается цветом, заданным для этой подсборки при настройке ее свойств. Цвета, заданные для отдельных деталей, не учитываются.

– Если сборка разнесена, то параллелепипед, заменяющий подсборку, располагается в пространстве в соответствии с параметрами разнесения, заданными для этой подсборки. Параметры разнесения, заданные для отдельных деталей подсборки, игнорируются.


Элементы системы

Элементы системы - начало координат и рамка, отображающаяся на экране при увеличении масштаба рамкой.


Номера системных стилей линий КОМПАС

Системные стили линий КОМПАС-3D LT имеют следующие номера:

основная | 0
тонкая | 1
осевая | 2
штриховая | 3
утолщенная | 4
штрих-пунктирная с 2 точками | 5
осевая основная | 6
штриховая основная | 7
вспомогательная | 8
для линии обрыва | 9
ISO 02 штриховая линия | 10
ISO 03 штриховая линия (дл. пробел) | 11
ISO 04 штрихпунктирная линия (дл. штрих) | 12
ISO 05 штрихпунктирная линия (дл. штрих 2 пунктира) | 13
ISO 06 штрихпунктирная линия (дл. штрих 3 пунктира) | 14
ISO 07 пунктирная линия | 15
ISO 08 штрихпунктирная линия (дл. и кор. штрихи) | 16
ISO 09 штрихпунктирная линия (дл. и 2 кор. штриха) | 17
ISO 10 штрихпунктирная линия | 18
ISO 11 штрихпунктирная линия (2 штриха) | 19
ISO 12 штрихпунктирная линия (2 пунктира) | 20
ISO 13 штрихпунктирная линия (3 пунктира) | 21
ISO 14 штрихпунктирная линия (2 штриха 2 пунктира) | 22
ISO 15 штрихпунктирная линия (2 штриха 3 пунктира) | 23


Настройка интерфейса. Вкладка Команды

Элементы управления, расположенные на этой вкладке, позволяют добавить команды на инструментальные панели.

Описание элементов управления

Описание элементов управления
Элемент | Описание
Категории | Поле содержит перечень категорий команд системы КОМПАС-3D Viewer.
Команды | Поле содержит перечень команд, входящих в выбранную категорию.
Описание | В поле приводится описание назначения выбранной команды.


Вкладка Общие сведения

В окне просмотра этой вкладки показаны общие сведения об активном документе.

Описание элементов управления
Элемент | Описание
Автор | Справочное поле, содержащее сведения об авторе документа.
Комментарий | Комментарий к документу. Комментарий может состоять из нескольких строк.
Создан | Поле содержит дату и время создания документа.
Последнее изменение | Поле содержит дату и время последнего сохранения документа.


Вкладка Внешние ссылки

В окне просмотра этой вкладки перечислены все внешние файлы, на которые ссылается данный документ, и с которыми он связан.

Описание элементов управления
Элемент | Описаение
Полный путь | Если полный путь и имя файла не помещаются в окне просмотра, происходит сжатие пути. Если нужно получить информацию о полном пути, вы можете включить опцию Полный путь и читать строки в окне просмотра, пользуясь линейкой прокрутки.
Записать в файл | При необходимости представленную в окне информацию о внешних связях документа можно записать в текстовый файл, воспользовавшись этой кнопкой


Настройка интерфейса. Вкладка Клавиатура

Элементы управления, расположенные на этой вкладке, позволяют назначить комбинации клавиш для вызова команд.

Описание элементов управления
Элемент | Описание
Категории | Поле содержит перечень категорий команд системы КОМПАС-3D Viewer.
Команды | Поле содержит перечень команд, входящих в выбранную категорию.
Описание | В поле приводится описание назначения выбранной команды.
Установить сочетание | Раскрывающийся список содержит перечень типов документов системы КОМПАС-3D Viewer. Вы можете выбрать тип документа, для которого будет действовать комбинация клавиш для вызова команды. Выбор варианта По умолчанию означает, что клавиатурная комбинация будет действовать при работе с документами любого типа.
Текущие | Поле содержит список действующих клавиатурных комбинаций для вызова выбранной команды.
Новое сочетание клавиш: | Поле содержит вновь назначаемую команде клавиатурную комбинацию. Ниже поля будет появляться информационное сообщение. Если предлагаемое сочетание клавиш уже используется для вызова другой команды, то будет показано ее название. Если данное сочетание клавиш не используется, то появится строка «Не связана».
Связать | Эта кнопка позволяет назначить команде комбинацию клавиш.
Удалить | Эта кнопка позволяет удалить клавиатурную комбинацию из списка назначенных данной команде.
Сбросить все | Эта кнопка позволяет восстановить умолчательные назначения клавиатурных комбинаций командам системы КОМПАС-3D Viewer.


Настройка интерфейса. Вкладка Меню

Элементы управления, расположенные на этой вкладке, позволяют управлять отображением меню в окне программы.

Описание элементов управления
Элемент | Описание
Показать меню | Выберите из раскрывающегося списка вариант Главного меню, который необходимо отобразить в текущем окне для настройки. Чтобы изменить состав меню, перейдите на вкладку Команды.
Показать контекстное меню | Чтобы настроить контекстное меню оконных закладок, выберите в этом списке строку Оконные закладки. Чтобы изменить состав меню, перейдите на вкладку Команды.
Сбросить | Эта кнопка позволяет отменить все изменения в меню (Главном или контекстном), т.е. привести его к умолчательному виду.
Эффект | Раскрывающийся список визуальных эффектов, которые могут сопровождать раскрытие списка команд.
Показывать тени меню | Данная опция позволяет включать отображение теней меню.


Настройка интерфейса. Вкладка Панели инструментов

Элементы управления, расположенные на этой вкладке, позволяют управлять отображением панелей инструментов в окне КОМПАС-3D Viewer.

Описание элементов управления
Элемент | Описание
Панели | Поле содержит перечень панелей инструментов системы КОМПАС-3D Viewer. «Галочка» рядом с названием панели означает, что эта панель отображается в окне программы. Чтобы отменить отображение панели, щелкните по «галочке» рядом с ее названием.
Сбросить | Эта кнопка позволяет привести в умолчательное состояние выбранную панель инструментов. Если вы добавляли или удаляли команды панели или настраивали ее отображение, то после нажатия кнопки Сбросить все изменения будут отменены.
Сбросить все | Эта кнопка позволяет привести в умолчательное состояние все панели инструментов и меню.
Новая... | Эта кнопка позволяет создать пользовательскую панель инструментов.
Переименовать | Эта кнопка позволяет изменить название пользовательской панели инструментов.
Удалить | Эта кнопка позволяет удалить пользовательскую панель инструментов.
Подписи к кнопкам | Включите эту опцию, чтобы на выбранной панели инструментов рядом с кнопками отображались названия команд.


Настройка интерфейса. Вкладка Параметры

Элементы управления, расположенные на этой вкладке, позволяют настроить отображение кнопок и названий команд в окне программы.

Описание элементов управления
Элемент | Описание
Отображать подсказки для кнопок | Эта опция позволяет управлять отображением всплывающих подсказок с названиями команд при наведении курсора на кнопку.
Включить в подсказки сочетания клавиш | Эта опция позволяет включать во всплывающую подсказку комбинации клавиш для быстрого вызова команды. Опция доступна при включенном отображении подсказок для кнопок.
Крупные значки | Эта опция позволяет управлять размером отображения кнопок.
Показывать недавно использованные команды первыми | Эта опция позволяет отображать наиболее часто используемые команды меню в первую очередь. Чтобы все команды отображались одновременно, выключите опцию.
Показывать полное меню после небольшой задержки | Эта опция позволяет управлять способом показа полного меню. Если задержать указатель мыши на открытом меню при включенной опции, то через короткий промежуток времени будут выведены все входящие в это меню команды. Если опция выключена, то, чтобы раскрыть полное меню, необходимо нажать кнопку Раскрыть (нижняя строка частично открытого меню).
Сбросить все настройки | Эта кнопка позволяет вернуть в умолчательное состояние перечень команд, которые отображаются в первую очередь при раскрытии меню при включенной опции Показывать недавно использованные команды первыми.


Структура и синтаксис файла convtxt.tfn

Файл convtxt.tfn используется при импорте документов форматов DXF и DWG для перекодирования текстов, набранных шрифтами SHX.

Данный файл должен находиться в папке, путь к которой указан системной переменной SYS. По умолчанию это папка \Sys системы КОМПАС-3D Viewer. В случае отсутствия этого файла в папке \Sys перекодирование не производится.

Файл convtxt.tfn содержит описания соответствий между шрифтами SHX и TrueType-шрифтами. Каждое описание состоит из трех строк:

– первая строка содержит имя файла шрифта SHX (*.shx);

– вторая строка содержит имя TrueType-шрифта, которым будет заменен шрифт SHX, указанный в первой строке;

– третья строка содержит числовые параметры, разделенные пробелом:

• коэффициент высоты символов; задается положительным десятичным числом с разделителем — точкой;

• коэффициент сужения символов; задается положительным десятичным числом с разделителем — точкой;

• вариант перекодирования; задается целым числом из диапазона 0 – 3 (см. ниже).

Каждое описание соответствия в обязательном порядке должно содержать все три строки в вышеуказанной последовательности. Третья строка обязательно должна содержать все три параметра.

Наличие пустых строк не допускается.

Таблица вариантов перекодирования
Вариант | Описание
0 | Отсутствие перекодирования. Используется, если требуется только заменить шрифт надписи и откорректировать высоту или сужение символов.
1 | Перекодирование из OEM в ANSI. Например, для русского языка этот вариант означает преобразование кодировки из CP866 в Windows 1251.
2 | Первый нестандартный способ перекодирования. Используется для тех SHX-шрифтов, в которых символы кодируются последовательностями вида \U+00YY. Каждая последовательность рассматривается как символ с кодом 0xYY, полученный результат преобразуется так же, как в варианте 1.
3 | Второй нестандартный способ перекодирования. Отличается от первого нестандартного способа отсутствием последнего этапа — преобразования по варианту 1.

Пример файла convtxt.tfn:

eskd.shx

Lucida Console

0.9 0.8 2

eskdw.shx

Lucida Console

0.9 0.8 3


Сетчатая прозрачность

Сетчатая прозрачность - способ отображения прозрачного объекта, при котором область, занимаемая этим объектом, заполняется отдельными пикселами. Цвет пикселов соответствует цвету объекта при нулевой прозрачности. Пикселы размещаются на экране, образуя регулярную структуру - сетку. «Ячейки сетки», т.е. участки, где пикселы прозрачного объекта отсутствуют, тем крупнее, чем большее значение параметра «Прозрачность» имеет данный объект (см. рисунок).

{ | { | {
а) | б) | в)
Модель подшипника с прозрачным наружным кольцом: а) 25% прозрачности, б) 50% прозрачности, в) 75% прозрачности


Прозрачный объект

Прозрачный объект — объект, степень прозрачности которого больше 0% и меньше 100%.

Степень прозрачности объекта задается при настройке его свойств во время создания модели в КОМПАС-3D. По умолчанию значение параметра «Прозрачность»равно 0%, т.е. все объекты создаются непрозрачными. При необходимости можно увеличить прозрачность любого объекта. 100%-ная прозрачность означает, что объект будет невидим.


Закладки документов

Закладки служат для управления документами.

Для включения и отключения закладок предназначена команда Окно — Показать закладки. Если рядом с этой командой в меню отображается «галочка»», то закладки находятся на экране. На закладках документов написаны их имена. Способ отображения имен — полные или короткие — зависит от настройки заголовков окон.

Чтобы активизировать окно документа, щелкните мышью по его закладке.

Если открытых документов много, все закладки не умещаются на экране. Для доступа к закладкам, которые не видны, служат кнопки прокрутки закладок.

Контекстное меню закладки содержит команду закрытия документа и команды управления закладками (Вверху, Внизу, Показать закладки).

Чтобы закрыть активное окно, нажмите кнопку Закрыть, расположенную рядом с кнопками прокрутки закладок.

Если текущий стиль приложения — Microsoft Office 2003, то для закладок можно установить стиль OneNote®. Для этого следует включить соответствующую опцию в диалоге настройки вида приложения.